Go Back   FlashFXP Forums > > > >

General Discuss anything and everything related to FlashFXP

 
 
Thread Tools Display Modes
Old 10-01-2002, 07:54 PM   #1
pstahl
Junior Member
 
Join Date: Oct 2002
Posts: 5
Question Please help - site to site transfers

I'm using FlashFXP 1.4.3 Build 835 on windows XP to do site transfers between two servers I built here in the office.

One of the servers (secure.mydomain.com) is a RedHat 7.2 build on X86 hardware with the default ftp loaded, and the second (gta.mydomain.com) is a Sun Solaris9 on E220 hardware with pureFTP loaded.

There is no firewall or address nat - it's a pretty straight shot.

I read another post on the passive settings in the site manager and tried to make one "all passive" and the other "all not passive" (I took the check out of use passive, and checked both boxes at the bottom). Was this the right approach? I'm having absolutely no luck. The error activity is:

I connect and it lists on both sites -
I start a transfer from secure (passive) to gta (not passive) -
I automatically see a "connection lost" - then "attempting to reconnect". in green.
Then I get in red a "transfer failed" - "1 file failed to transfer" - "server error aborted"

and it will do this over and over and over again.
pstahl is offline  
Old 10-01-2002, 09:49 PM   #2
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,869
Default

perhaps you should post stats log. it'll show exactly what's going on
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Old 10-01-2002, 10:59 PM   #3
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

I suspect the site loosing connection doesn't allow site to site transfers. It is very common for some ftp servers to drop the connection if you attempt to perform a site to site transfer.
bigstar is offline  
Old 10-02-2002, 10:13 AM   #4
pstahl
Junior Member
 
Join Date: Oct 2002
Posts: 5
Default

I control the site on both ends and I didn't choose to not accept in the ftp servers. The end with pureFTP even explicitly says it does accept FXP
pstahl is offline  
Old 10-02-2002, 11:03 AM   #5
pstahl
Junior Member
 
Join Date: Oct 2002
Posts: 5
Default

This seems identical to another poster's issue titled "Problems with site to site transfers..."

I've really tried setting this up exactly in the manner shown there, but my site manager interface is a little different

Here are some more notes:

Administrative client - Windows XP with FlashFXP version 1.4.3 build 835
Site A = Sun server (solaris9) with pureFTP - active and passive transfer allowed/tested from client.
Site B = Debian Linux with wu-ftp - active and passive transfer allowed/tested from client.
same username/password on both.

In FlashFXP Site Manager:
Site 1 (linux secure.spro.net) - I left this sites options totally alone. It has a grayed out passive mode, and no checks in either of the lower Alternative (FXP) site to site methods.

Site 2 (Sun grandtheftaudio.us) - In the options here I changed from grayed out to no check under passive mode - and in the Alternative (FXP) site to site method I checked both boxes.

Attached is the log from my attempt.

Thanks for your support - I'm really feeling pretty stupid -seems like this shouldn't be that difficult

Peace,

//Patrick

*** Log Opened: 10/2/2002 9:36:04 AM
WinSock 2.0
*** Log Closed: 10/2/2002 9:36:07 AM
*** Log Opened: 10/2/2002 9:36:16 AM
WinSock 2.0
Connecting to grandtheftaudio.us
Connected to 204.228.224.84 Port 21
220-=(<*>)=-.:. (( Welcome to PureFTPd 1.0.12 )) .:.-=(<*>)=-
220-You are user number 1 of 50 allowed.
220-Local time is now 09:42 and the load is 0.00. Server port: 21.
220-IPv6 connections are also welcome on this server.
220 You will be disconnected after 15 minutes of inactivity.
USER pstahl
331 User pstahl OK. Password required
PASS (hidden)
230-User pstahl has group access to: other
230-This server supports FXP transfers
230 OK. Current directory is /home/pstahl
SYST
215 UNIX Type: L8
REST 100
350 Restarting at 100. But we're in ASCII mode
REST 0
350 Restarting at 0
PWD
257 "/home/pstahl" is your current location
TYPE A
200 TYPE is now ASCII
PORT 204,228,196,112,18,92
200 PORT command successful
LIST
150 Connecting to port 4700
226-Options: -l
226 5 matches total
Connecting to secure
Connected to secure.spro.net Port 21
220- ____ _ _ _ ____
220-/ ___| ___ | |_ _| |_(_) ___ _ __ | _ \ _ __ ___
220-\___ \ / _ \| | | | | __| |/ _ \| '_ \| |_) | '__/ _ \
220- ___) | (_) | | |_| | |_| | (_) | | | | __/| | | (_) |
220-|____/ \___/|_|\__,_|\__|_|\___/|_| |_|_| |_| \___/
220-
220-
220 FTP server ready.
USER pstahl
331 Password required for pstahl.
PASS (hidden)
230 User pstahl logged in.
SYST
215 UNIX Type: L8
REST 100
350 Restarting at 100. Send STORE or RETRIEVE to initiate transfer.
REST 0
350 Restarting at 0. Send STORE or RETRIEVE to initiate transfer.
PWD
257 "/home/pstahl" is current directory.
TYPE A
200 Type set to A.
PORT 204,228,196,112,18,94
200 PORT command successful.
LIST
150 Opening ASCII mode data connection for /bin/ls.
226 Transfer complete.
TYPE A
200 Type set to A.
TYPE A
200 TYPE is now ASCII
PASV
227 Entering Passive Mode (204,228,224,84,146,81)
PORT 204,228,224,84,146,81
Connection lost: secure
Attempting to Reconnect.
Transfer Failed!
1 File failed to transfer
Server Error, Aborted
Connecting to secure
Connected to secure.spro.net Port 21
220- ____ _ _ _ ____
220-/ ___| ___ | |_ _| |_(_) ___ _ __ | _ \ _ __ ___
220-\___ \ / _ \| | | | | __| |/ _ \| '_ \| |_) | '__/ _ \
220- ___) | (_) | | |_| | |_| | (_) | | | | __/| | | (_) |
220-|____/ \___/|_|\__,_|\__|_|\___/|_| |_|_| |_| \___/
220-
220-
220 FTP server ready.
USER pstahl
331 Password required for pstahl.
PASS (hidden)
230 User pstahl logged in.
SYST
215 UNIX Type: L8
REST 100
350 Restarting at 100. Send STORE or RETRIEVE to initiate transfer.
REST 0
350 Restarting at 0. Send STORE or RETRIEVE to initiate transfer.
PWD
257 "/home/pstahl" is current directory.
TYPE A
200 Type set to A.
TYPE A
200 TYPE is now ASCII
PASV
227 Entering Passive Mode (204,228,224,84,246,153)
PORT 204,228,224,84,246,153
Connection lost: secure
Attempting to Reconnect.
Transfer Failed!
1 File failed to transfer
Server Error, Aborted
Connecting to secure
Connected to secure.spro.net Port 21
220- ____ _ _ _ ____
220-/ ___| ___ | |_ _| |_(_) ___ _ __ | _ \ _ __ ___
220-\___ \ / _ \| | | | | __| |/ _ \| '_ \| |_) | '__/ _ \
220- ___) | (_) | | |_| | |_| | (_) | | | | __/| | | (_) |
220-|____/ \___/|_|\__,_|\__|_|\___/|_| |_|_| |_| \___/
220-
220-
220 FTP server ready.
USER pstahl
331 Password required for pstahl.
PASS (hidden)
230 User pstahl logged in.
SYST
215 UNIX Type: L8
REST 100
350 Restarting at 100. Send STORE or RETRIEVE to initiate transfer.
REST 0
350 Restarting at 0. Send STORE or RETRIEVE to initiate transfer.
PWD
257 "/home/pstahl" is current directory.
TYPE A
200 Type set to A.
TYPE A
200 TYPE is now ASCII
PASV
227 Entering Passive Mode (204,228,224,84,22,35)
PORT 204,228,224,84,22,35
Connection lost: secure
Attempting to Reconnect.
Transfer Failed!
1 File failed to transfer
Server Error, Aborted
Retry attempt Aborted
QUIT
221-Goodbye. You uploaded 0 and downloaded 0 kbytes.
221 Logout - CPU time spent: 0.010 seconds.
Logged off: grandtheftaudio.us
*** Log Closed: 10/2/2002 9:37:52 AM
pstahl is offline  
Old 10-02-2002, 01:37 PM   #6
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Most ftp servers by default do not allow site to site transfers did you specifically enable it?

Quote:
Originally posted by pstahl
I control the site on both ends and I didn't choose to not accept in the ftp servers. The end with pureFTP even explicitly says it does accept FXP
bigstar is offline  
Old 10-02-2002, 02:32 PM   #7
pstahl
Junior Member
 
Join Date: Oct 2002
Posts: 5
Default

In a common ftp installation like pureFTP or proftpd - what setting would allow site-to-site. I don't know of any off the top of my head and I didn't see any at the maker's site.

Do you recommend a flavor of FTP I can run on the Sun server. This is a dedicated hosting server and the customer wants it specifically for this reason alone
pstahl is offline  
Old 10-02-2002, 03:25 PM   #8
Linkster
Moderator
Administrator
 
Join Date: Oct 2001
Location: New Mexico, USA
Posts: 1,070
Default

in proftpd.conf you need AllowForeignAddress on
Linkster is offline  
Old 10-03-2002, 02:13 PM   #9
pstahl
Junior Member
 
Join Date: Oct 2002
Posts: 5
Default

Problem Solved

We got it working. I was so busy worrying about the two site servers and a firewall there, I didn't take time to see what was in front of me here where I was using the actual flashfxp client. Seems that a firewall in front of this tool, regardless whether files are transferred here or not matters. Seems to create a love triangle when making connections

Thanks for everyone's help.

//Patrick
pstahl is offline  
 

Tags
error, loaded, passive, site, transfer

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:44 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)