Go Back   FlashFXP Forums > > > >

General Discuss anything and everything related to FlashFXP

 
 
Thread Tools Display Modes
Old 09-20-2002, 05:47 PM   #1
Celeste
Junior Member
 
Join Date: Sep 2002
Posts: 1
Question startup commands

hi, I am interested in making a startup command that will goto the directory currently in my clipboard. Now I have successfully made a command that works while on the site.
command name in command editor is clipcommand.
CWD /Today
CWD %c
LIST -al

so when i use it in the drop down menu commands>clipcommand it goes into the today folder then into the folder in my clipboard then lists. that works perfectly. Problem is when adding this command to the advanced tab inside site manager so that it is performed on startup of the site.
CWD /Today
CWD %c
LIST -al

when logging in it does this

CWD /Today
250 CWD command successful.
CWD %c
550 %c: No such file or directory.
LIST -al

as you can see its not processing the %c. now i am not a scriptor or programmer at all so i dont know how to fix this

i also tried adding the command name to the perform on startup section
clipcommand

when logging in does this

clipcommand
500 'CLIPCOMMAND': Command not understood.


... any help is greatly appreciated. thanks
Celeste is offline  
Old 09-20-2002, 11:46 PM   #2
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

The "perform on connect event" didn't support custom command macro's, support will be added into the next build.

FYI the following code will cause problems.
CWD /Today
CWD %c

The correct way would be to use
&cd /Today
&cd %c

CWD sends the command directly to the ftp server while &cd tells FlashFXP to change directory.
bigstar is offline  
 

Tags
clipcommand, command, cwd, list, startup

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Having some odd issues: Blackcomb General Discussion 3 05-13-2005 03:24 PM


All times are GMT -5. The time now is 09:07 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)