Go Back   FlashFXP Forums > > > >

General Discuss anything and everything related to FlashFXP

 
 
Thread Tools Display Modes
Old 11-19-2001, 08:34 AM   #1
zid
Junior Member
 
Join Date: Nov 2001
Posts: 2
Default Netgear RT314

I can't fxp when I'm using this router and I wounder if anyone knowes how to fix this.

PASV
227 Entering Passive Mode (212,116,67,50,14,186).
LIST
150 Opening ASCII mode data connection for file list
226 Transfer complete.
TYPE I
200 Type set to I.
TYPE I
200 Type set to I.
PASV
227 Entering Passive Mode (213,112,162,37,85,145).
PORT 213,112,162,37,85,145
200 PORT command successful.
STOR 300kmh.mpg

and then nothing happends

plz help Andreas
zid is offline  
Old 11-19-2001, 01:44 PM   #2
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,838
Default

did you try alternative transfer modes in site manager?
MxxCon is offline  
Old 11-19-2001, 02:11 PM   #3
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

One down side to FXP is that alot of routers now provide NAT (Network address translations) for seamless protocol forwarding.

So when the client send the PORT command the router maps the port locally, changing the original value. This provides transparent connectivity, and without it you would be forced to use PASV mode.

However the router is not smart enough to know the difference between local and FXP. Thus breaking FXP support.

The only solution I am aware of is to turn off NAT or ask the site owner to use a non-standard port. Most routers only monitor port 21 for ftp traffic. So if the FTP server is on port 414 the router wont modify the protocol.
bigstar is offline  
Old 11-20-2001, 04:34 AM   #4
zid
Junior Member
 
Join Date: Nov 2001
Posts: 2
Default

thx for the help but i don't know how to turn NAT of kan i turn it of only for that port?
zid is offline  
Old 12-03-2001, 01:30 AM   #5
SilentBob
Junior Member
 
Join Date: Dec 2001
Posts: 2
Default

I am having same problem with the same equipment.

I have tried setting my PC as the "default" for all unmapped ports, and I have tried using several different proxies.

Some proxies I get connected, and when I start the transfer it makes all of the directories, but when it tries transferring the files It says "data transfer faild attempting alternate method" and then "data transfer failed" immediately after that.

Is this because I have yet to find a "good" proxy? I have had this same problem with all 10 that I have actually gotten connected with.

There has got to be a solution to this...
SilentBob is offline  
Old 12-03-2001, 01:41 AM   #6
Fusion
Senior Member
FlashFXP Beta Tester
ioFTPD Registered User
 
Join Date: Oct 2001
Posts: 542
Default

One solution with regards to uncooperative NATs is to make sure the specific rules get added prior to any and all "open" rules, eg. before the lines that go like "set nat add local-ip". That way you ensure that the right local-ip gets the request. Works well with my Cisco-routers.
Fusion is offline  
Old 12-03-2001, 01:51 AM   #7
SilentBob
Junior Member
 
Join Date: Dec 2001
Posts: 2
Default

okay, well for using FXP, what "specific" rules should be set to allow it to work properly?

I guess what I hear you saying is that you have site-to-site transferring working using NAT on your Cisco routers.

If you don't mind, please tell me the exact settings on both the router side and on the FlashFXP side that allow this to work for you..
SilentBob is offline  
 

Tags
200, 227, mode, pasv, type

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
how to disable "Command Tokens" shawn1 General Discussion 6 10-28-2004 03:05 PM


All times are GMT -5. The time now is 07:51 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)