Go Back   FlashFXP Forums > > > >

Bug Reports Report bugs here. (non-beta releases only)

 
 
Thread Tools Display Modes
Old 07-05-2004, 01:33 PM   #1
jmlsteele2
Junior Member
FlashFXP Registered User
 
Join Date: Nov 2003
Posts: 4
Default SSL/TLS + File Corruption

Multiple testers so multiple options selected where appropriate.

FlashFXP v[2].[1], build [924], [x]registered, [x]unregistered, [ ]pirated
OS [x] WinXP, [x] Win2K, [ ] Win98, [ ] WinME, [ ] Other
Running behind NAT/router [x] Yes & Model [various], [x] No, [ ] Not sure
Running firewall [ ] Yes, Name [ ], Ver. [ ], or [x] No
Running Antivirus [x] Yes, Name [NAV 2002] or [x] No
Network [x] xDSL, [x] CABLE, [x] Dail-Up, [ ] Other

FTP server(s) name [vsftpd], version [2.0.0/2.0.1]


When downloading files using AUTH SSL/TLS with Secure Data Transfers selected, the file is often corrupted. The larger the file, the larger the change of corruption. According to FFXP the transfer completed successfully.

When testing on dialup a 117K file was "complete" at 112K. Attempts to resume it resulted in even more missing data, I assume because of rollback. With Cable/DSL the 117K file was fine, but largers files, 600K and 15MB, were corrupted. The files transfer fine with other clients (tested with SmartFTP, and another whose name is escaping me at the moment).

I let the server's author know, because I thought it was a bug with the server at first. He provided hack fix, where the server doesnt report file completion (226) for 10 seconds after the file is actually complete. He suggests FFXP may 'react badly to receiving a "transfer complete" message before it has finished reading the data stream.'


I originally though this bug was server side, but after testing successfully with other clients I'm not so sure any more. I decided to post this here as well because I didnt notice much recent mention in the forums (most recent dated back to November of 2003 (search string: "SSL corrupted"), and there was no notice as to whether this was resolved.

If you would like/need an account I can set you up with one on both the patched (with the mentioned hack) and unpatched servers.

If this has been fixed in version 3 then just mention it and I'll test it out with the new RC.

Jody Steele
jmlsteele2 is offline  
Old 07-05-2004, 09:28 PM   #2
Linkster
Moderator
Administrator
 
Join Date: Oct 2001
Location: New Mexico, USA
Posts: 1,070
Default

Please upgrade to FlashFXP v3.0 RC4 and let us know if its fixed. I believe ssl issues were addressed.
Linkster is offline  
Old 07-05-2004, 09:34 PM   #3
jmlsteele2
Junior Member
FlashFXP Registered User
 
Join Date: Nov 2003
Posts: 4
Default

I just tested and it seems to be working. I have only tested a small amount (4 transfers) but with 2.1 4 transfers meant 4 corrpupted files.

Thanks for the speedy reply. I probably should have though about testing the RC before I posted, but I wasn't thinking straight.

jmlsteele

P.S. Not that it matters, or at least it shouldnt, but i tested with an unregistered version (installed to a clean dir as opposed to upgrade)
jmlsteele2 is offline  
 

Tags
file, flashfxp, ftp, servers, [x]

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 04:55 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)