Go Back   FlashFXP Forums > > > >

Bug Reports Report bugs here. (non-beta releases only)

 
 
Thread Tools Display Modes
Old 04-21-2004, 03:40 PM   #1
kieranmullen
Member
FlashFXP Registered User
 
Join Date: Apr 2004
Location: Portland, Oregon
Posts: 46
Default copying files (self to self)

Hello

I make 2 connections on either side to make a copy of a folder on the same server. This linux servier running Red Had Processional supports site to site becuase I was able to use it from another server.

Anyhow when I copy the directory (which I had just finished upkloaded with the same program) the program creates a copy of the folders then stops on the first file.

I am running the latest version available on the website today on a demo program. I am considering purchasing it...
kieranmullen is offline  
Old 04-21-2004, 04:26 PM   #2
kieranmullen
Member
FlashFXP Registered User
 
Join Date: Apr 2004
Location: Portland, Oregon
Posts: 46
Default

Sorry forgot to include this info...

* FlashFXP v[2].[1 ], build [294 ], [ ]registered, [X]unregistered, [ ]pirated
* OS [X] WinXP, [ ] Win2K, [ ] Win98, [ ] WinME, [ ] Other
* Running behind NAT/router [X ] Yes & Model [ Dlink Wireless G with 4 hub switch], [ ] No, [ ] Not sure
* Running firewall [ ] Yes, Name [ ], Ver. [ ], or [X ] No
* Running Antivirus [X] Yes, Name [ AVG ANTI VIRUS] or [ ] No
* Network [X] xDSL, [ ] CABLE, [ ] Dail-Up, [ ] Other
kieranmullen is offline  
Old 04-30-2004, 09:08 AM   #3
kieranmullen
Member
FlashFXP Registered User
 
Join Date: Apr 2004
Location: Portland, Oregon
Posts: 46
Default

bunp - Seeing a lack of response such as this does not really make me want to become a registered member. Address this issue and there is no reason why I cant buy today. Thanks
kieranmullen is offline  
Old 04-30-2004, 09:13 AM   #4
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Sorry, I never saw your original post.

Can you perform site to site transfers on other ftp servers? If not then I suspect your router w/ NAT is preventing you from performing a site to site transfer. One way to confirm this is to run the ftp server on a non-standard port, say 2120.
bigstar is offline  
Old 04-30-2004, 09:40 AM   #5
kieranmullen
Member
FlashFXP Registered User
 
Join Date: Apr 2004
Location: Portland, Oregon
Posts: 46
Default

Downloaded 2.4 944 to another location using RDP and used on a server already using a non standard port 8387 (cant change live server) both computers have no firewall or nat using public Ips.

Login on both sides of the screen to the same folder...select files for a copy...it starts the STOR command then it says Connection lost... Using passive mode...
kieranmullen is offline  
Old 04-30-2004, 10:01 AM   #6
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Can you check your ftp server log, perhaps there is something to explain why it's not allowing the site to site transfer.

Since we have ruled out NAT, it seems like a problem with the ftp server configuration.
bigstar is offline  
Old 04-30-2004, 10:20 AM   #7
kieranmullen
Member
FlashFXP Registered User
 
Join Date: Apr 2004
Location: Portland, Oregon
Posts: 46
Default

site to site is enabled becuase I was able to do site to site from another server.

Just internal transfers do not work. None the less I have listed the proftpd config below... From what I am told you need to have AllowForeignAddress on for ftpd plus have the ports open on firewall.


# This is a basic ProFTPD configuration file (rename it to
# 'proftpd.conf' for actual use. It establishes a single server
# and a single anonymous login. It assumes that you have a user/group
# "nobody" and "ftp" for normal operation and anon.

ServerName "FTP"
ServerType standalone
DefaultServer on

# Define this if you want to prevent your server from displaying what FTP
# server and version you are using.
ServerIdent on "FTP Server ready."

#Time out parameters
TimeoutIdle 600
TimeoutNoTransfer 600
TimeoutLogin 300

# Port 21 is the standard FTP port.

# Port 21 is the standard FTP port.
Port 8387

# To prevent DoS attacks, set the maximum number of child processes
# to 30. If you need to allow more than 30 concurrent connections
# at once, simply increase this value. Note that this ONLY works
# in standalone mode, in inetd mode you should use an inetd server
# that allows you to limit maximum number of processes per service
# (such as xinetd)
MaxInstances 30

# Set the user and group that the server normally runs at.
User root
Group root

# To disable use of system-wide password file
PersistentPasswd off

<Global>
# Umask 022 is a good standard umask to prevent new dirs and files
# from being group and world writable.
Umask 022

# Setting this to 'on' makes PAM the final authority on what gets
# authenticated. Turning this off will tell PAM to allow other
# authentication modules compiled into ProFTPD a chance at the user.
AuthPAMAuthoritative On

# This is the PAM configuration file that will be referenced when
# authenticating. It can be set globally and/or per VirtualHost.
# The default is 'ftp'. Note: all PAM configuration files must be in
# /etc/pam.d
AuthPAMConfig ftp


# Don't let people pass % characters to the server and to protect against DoS a$
DenyFilter (\*.*/)|%

<Limit SITE_CHMOD>
AllowAll
</Limit>
AllowForeignAddress on
AllowStoreRestart on
RequireValidShell on
</Global>

# Normally, we want files to be overwriteable.
<Directory /*>
AllowOverwrite on
</Directory>

include "/etc/proftpd/proftpd.conf.wp"
kieranmullen is offline  
Old 04-30-2004, 10:58 AM   #8
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Hmm. I compared your config to the one we use it's almost identical. Your right after reviewing the proftpd docs it looks like you just need to set AllowForeignAddress which you've done.

Is it possible that your firewall is still active or it's rejecting the connections due to some sort of configuration.

You might try limiting the PASV port range to narrow down the ports you need to make sure are opened.

Something like this

# Use to set range of passive ports to use
PassivePorts 6000 7000
bigstar is offline  
Old 04-30-2004, 12:06 PM   #9
kieranmullen
Member
FlashFXP Registered User
 
Join Date: Apr 2004
Location: Portland, Oregon
Posts: 46
Default

Not possible. I never HAD a firewall installed at these locations.

Which line should I put your text in at? I went ahead and put it under default server. Restarted ftp service and logged in double again then I transferred a 14MB file to itself in a subfolder and it said after 30 seconds (which on a sever to server trans should only take a second) and it said "transfer aborted"

Anyting else?

Thanks

KM
kieranmullen is offline  
Old 05-03-2004, 01:45 PM   #10
kieranmullen
Member
FlashFXP Registered User
 
Join Date: Apr 2004
Location: Portland, Oregon
Posts: 46
Default

I could always setup test account for you, but I am sure you have access to those type of things anyway.

KM
kieranmullen is offline  
Old 05-04-2004, 06:56 PM   #11
kieranmullen
Member
FlashFXP Registered User
 
Join Date: Apr 2004
Location: Portland, Oregon
Posts: 46
Default

A reason why server to server is important to me is becuase I have to install OSCommerce on a bunch of servers and it helps to have the files on the server.

Thanks!

Kieran
kieranmullen is offline  
Old 05-04-2004, 08:02 PM   #12
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

It really doesn't make any sense to me, You might try a proftpd mailing list or one related to your linux distro.

I wish I could be of more help.

btw are you using the latest version of proftpd?
I tested using proftpd v1.2.9
bigstar is offline  
 

Tags
copy, program, running, server, site

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
"Only resume files transferred in binary mode" Gary King General Discussion 1 03-31-2005 01:19 AM


All times are GMT -5. The time now is 04:15 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)