Go Back   FlashFXP Forums > > > >

Bug Reports Report bugs here. (non-beta releases only)

 
 
Thread Tools Display Modes
Old 09-11-2003, 04:40 AM   #1
jweber
Junior Member
FlashFXP Registered User
 
Join Date: May 2003
Posts: 16
Default transfer mode

* FlashFXP v[ 2].[1 ], build [924 ], [ #]registered, [ ]unregistered, [ ]pirated
* OS [ #] WinXP, [ ] Win2K, [ ] Win98, [ ] WinME, [ ] Other
* Running behind NAT/router [# ] Yes & Model [ ], [ ] No, [ ] Not sure
* Running firewall [ # ] Yes, Name [ Tiny Personal Firewall ], Ver. [ 2.015 ], or [ ] No
* Running Antivirus [ # ] Yes, Name [ Norton Antivirus 2003 ] or [ ] No
* Network [# ] xDSL, [ ] CABLE, [ ] Dail-Up, [ ] Other

Hi, i switched the transfer mode to upload txt files and then again to binary mode. But when i wanted to upload images the transfer mode was always in the asccii mode. I had to restart flashfxp to resolve this. is that normal?
jweber is offline  
Old 09-11-2003, 02:04 PM   #2
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

I tried to reproduce this problem but I was unsuccessful. I'm not sure why you encounter this behavior, Can you reproduce it?
bigstar is offline  
Old 09-11-2003, 04:11 PM   #3
jweber
Junior Member
FlashFXP Registered User
 
Join Date: May 2003
Posts: 16
Default

here is what i just exactly did:
I started flashfxp, switched to Ascii mode, transferred a textfile. Then i switched to binary mode (without disconnecting or restarting flashfxp) and transferred an exe file. it was transferred in ascii mode.

Here is the log:
1)switched to ascii mode
PASV
227 Entering Passive Mode (xxx,xxx,xxx,xxx,xxx,xxx).
STOR test.txt
150 Opening ASCII mode data connection for test.txt
226 Transfer complete.
Transferred: test.txt 31 bytes in 0,84 (0,03 KBps)
Transfer queue completed
Transferred 1 file totaling 31 bytes in 3,76 (0,03 KBps)
2) Here i switched to binary mode
PASV
227 Entering Passive Mode (xxx,xxx,xxx,xxx,xxx,xxx).
STOR FlashFXP.exe
150 Opening ASCII mode data connection for FlashFXP.exe
(soft abort)
ABOR
(hard abort)
QUIT

----
it works only if i set a mode I want and close flashfxp and restart it.
jweber is offline  
Old 09-12-2003, 03:27 PM   #4
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Which method are you using to change the transfer mode? Please give the location of where your changing this setting.
bigstar is offline  
Old 09-12-2003, 03:41 PM   #5
jweber
Junior Member
FlashFXP Registered User
 
Join Date: May 2003
Posts: 16
Default

I open the preferences menu and go to the transfer tab. There I switched between the transfer modes ascii and binary. then i click ok.
jweber is offline  
Old 09-13-2003, 07:49 AM   #6
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Ahhhhhh. Changing the setting there does not change the current setting, What you've done is changed the default behavior when FlashFXP starts up.

To change the current transfer mode you need to change it via the toolbar (it's a custom button, you may need to activate it by right clicking on the toolbar and selecting it) or via FTP > Transfer Mode.

I took a look in the help file and I see that this is not explained, we'll update the help file to include this information.
bigstar is offline  
Old 09-13-2003, 01:48 PM   #7
jweber
Junior Member
FlashFXP Registered User
 
Join Date: May 2003
Posts: 16
Default

ah didn't know about that button
It works fine now!
Thank you very much
jweber is offline  
 

Tags
firewall, flashfxp, mode, running, transfer

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:17 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)