Go Back   FlashFXP Forums > > > >

Bug Reports Report bugs here. (non-beta releases only)

 
 
Thread Tools Display Modes
Old 06-06-2003, 04:02 AM   #1
Fused
Member
 
Join Date: Oct 2001
Posts: 31
Default LAN transfer speed and corrupt uploads

I've noticed when uploading files to my XBOX, FlashFXP uploads at a consistant 1200k/s.

By comparison, WS_FTP and Xisomanager both upload at 4.5MB/s.

I've tested this with multiple files, and every time FlashFXP is consistantly about 4x slower.

Is there any possible reason for this? The client should not affect transfer speeds once the control connection has sent all the commands and the transfer has started, correct?


Something else I noticed while transferring files around between pc>xbox>pc, is that files transferred through FlashFXP become corrupt on the other end quite frequently during very fast transfers of large numbers of mixed size files.

This happens consistantly with FlashFXP and has yet to happen with WS_FTP or XisoManager.
Fused is offline  
Old 06-06-2003, 04:09 AM   #2
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,831
Default

Preference, Advanced tab, "Upload Packet Size".
play around w/ that setting untill you find optimal value
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Old 06-06-2003, 04:48 AM   #3
Fused
Member
 
Join Date: Oct 2001
Posts: 31
Lightbulb

I don't see that, it may be time to upgrade.


I think I did figure out the problem though, I was comparing transfer logs from Smart and Flash and came across a port command difference.

Smart was sending my LAN IP 192.168.1.100 in the PORT command.
Flash I had previously set up to bind PORT commands to my WAN IP 24.86.x.x so it was sending this as the port command.

I am using a router.
The router has the 24.86.x.x address.
The XBOX is 192.168.1.200.
My PC is 192.168.1.100.

I did test this out by disabling the "bind sockets to this address" option in Flash and the transfers were about 5mb/s and it was using my LAN ip in the port command.

This not only fixed the speed problem, but files are no longer becoming corrupt either.

I switched Smart to use my 24.86.x.x for PORT commands and it too all of a sudden was transferring at about 1200k/s and was now corrupting files as well.

Now I don't exactly understand why this difference causes such a dramatic slowdown, not to mention corrupting files, perhaps you have some idea?

All the traffic is still going through the router regardless.

All I can really think of, is that the router has to match the destination MAC in the packets to route it properly and this is what causes the slowdown, and is somehow also causing this file corruption problem.

Maybe i'll contact Linksys when I get around to it ...

Quite a strange situation but i'm glad to know the cause even if I don't understand it.
Fused is offline  
Old 06-06-2003, 05:34 PM   #4
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,831
Default

interesting
try DSLReports linksys forum. maybe they seen/know something about this.
i still suggest you upgrade your flashfxp and play around with upload packet size setting. you might be able to get more than 5meg/sec
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
 

Tags
files, flashfxp, transfer, ws_ftp, xisomanager

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 07:35 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)