Go Back   FlashFXP Forums > > > >

FlashFXP 4.1 beta feedback Please post all 4.1 beta comments, suggestions and bug reports in this forum.

Reply
 
Thread Tools Display Modes
Old 07-22-2011, 02:59 PM   #1
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default FlashFXP 4.1 BETA build 1614

FlashFXP 4.1 BETA build 1614
  1. Fixed > Queue window > target column > when en-queuing a rename or move, the target column was blank. It should of displayed the new location/filename.
  2. Changed > Queue window > Edit. If multiple queue items of different type are selected its impossible to edit them all at once, now the item with focus is edited and the rest of the selection is ignored.
  3. Fixed > Queue window > Edit. There were some issues where the editor allowed the user to edit certain fields with a multiple selection that shouldn't of been allowed.
  4. Fixed > The skip [reason] status message was sometimes indicating "unknown" in situations where it should of displayed "file exists", this is shown when the action is set to skip within "On transfer error" or "if no rules match then"
  5. Changed > When manually re-sorting the queue list via the columns, any en-queued delete operation is now sorted so that they appear at the end of the queue regardless of the sort method or direction.
Update available via LiveUpdate

Known issues:

  1. I am currently investigating some issues with the update installer failing to complete the update installation.
  2. Possible issue restoring a flashfxp backup file (.fbk) from (backup\restore) when an application password set. The restore appears to work without issues, but on restart the correct password isn't accepted. I have not been able to reproduce this issue.
  3. I discovered that several features in the FTP server search window aren't working correctly, this appears to be caused by the listview item selection code changes back in or around build 1602.

Last edited by bigstar; 07-22-2011 at 05:27 PM.
bigstar is offline   Reply With Quote
Old 07-23-2011, 06:20 AM   #2
hennie1nl
Junior Member
FlashFXP Beta Tester
 
Join Date: Jan 2007
Posts: 15
Default

Hi..I'm not sure if I'm supposed to report the issues below here and I apologize if that is not the case.
I have issues using flashfxp to connect to certain sites.
I get errors like the ones below:

[R] Connected. Negotiating TLSv1 session
[R] error:1408F10B:SSL routines:SSL3_GET_RECORD:wrong version number
[R] Failed SSLv3 negotiation, disconnected

[L] Connected. Negotiating TLSv1 session
[L] error:14094438:SSL routines:SSL3_READ_BYTES:tlsv1 alert internal error
[L] Connection failed (Connection closed by server)

I tried all possible ways to connect. I tried Filezilla too to test another ftp client and it works fine with those sites. I would very much like to see this fixed.

Btw: using FlashFXP 4.1 BETA build 1614

and I'm using WinSock 2.0 -- OpenSSL 1.0.0d 8 Feb 2011

Last edited by MxxCon; 07-23-2011 at 09:11 AM.
hennie1nl is offline   Reply With Quote
Old 07-23-2011, 10:02 AM   #3
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

hennie1nl
Do you know what software is being used on the FTP server?

Yes, I prefer bug reports posted directly to the thread for the specific beta release.
bigstar is offline   Reply With Quote
Old 07-23-2011, 11:02 AM   #4
chrisi1909
Junior Member
 
Join Date: Jul 2010
Posts: 4
Default

I have a little type of listing bug with the filesize.
On HDD (C:\ or d:\) it is displayed correkt.
On all types of USB Sticks, oder external things i get this :
Attached Thumbnails
FlashFXP 4.1 BETA build 1614-bug-1614-png  
chrisi1909 is offline   Reply With Quote
Old 07-23-2011, 12:31 PM   #5
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Quote:
Originally Posted by chrisi1909 View Post
I have a little type of listing bug with the filesize.
On HDD (C:\ or d:\) it is displayed correkt.
On all types of USB Sticks, oder external things i get this :
Thank you, I have confirmed the issue and it will be addressed in the next build.

I'm surprised no one caught this earlier, its been in play for a few builds now.

I do special handling on removable drives to get the data as fast as possible and in some cases some minor details are excluded, I managed excluded the size and date by creating an evaluation that would never be true.
bigstar is offline   Reply With Quote
Old 07-24-2011, 06:36 AM   #6
hennie1nl
Junior Member
FlashFXP Beta Tester
 
Join Date: Jan 2007
Posts: 15
Default

Quote:
Originally Posted by bigstar View Post
hennie1nl
Do you know what software is being used on the FTP server?

Yes, I prefer bug reports posted directly to the thread for the specific beta release.
[R] Connected. Negotiating TLSv1 session
[R] error:1408F10B:SSL routines:SSL3_GET_RECORD:wrong version number
[R] Failed SSLv3 negotiation, disconnected

belongs to:

[R] 220 DrFTPD+ 2.0 (+STABLE+) $Revision: 1761 $ http://drftpd.org

and

[L] Connected. Negotiating TLSv1 session
[L] error:14094438:SSL routines:SSL3_READ_BYTES:tlsv1 alert internal error
[L] Connection failed (Connection closed by server)

belongs to:

ioFTPD (dont know which version)
hennie1nl is offline   Reply With Quote
Old 07-24-2011, 10:20 AM   #7
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

hennie1nl

Thanks for the update, did this issue occur in prior builds?

I am not able to reproduce this issue on the servers I have access to test with.Based on the text from the status window for the DrFTPD server it appears that FlashFXP is trying to negotiate TLSv1 and falls back to SSLv3before finally failing.

The SSL handshake code has not been changed since 1559and when it was changed we removed 2 legacy OpenSSL compatibility settings, if it is determined that these settings are needed for drFTPD I can re-activate them. In my testing it did not appear that they were needed to properly establish a connection, however it might be a server specific compatibility issue.

Would it be possible to send me a private message with the ip/port of the servers, I don't need to login to test the SSL handshake.
bigstar is offline   Reply With Quote
Old 07-25-2011, 03:41 AM   #8
hennie1nl
Junior Member
FlashFXP Beta Tester
 
Join Date: Jan 2007
Posts: 15
Default

Hi bigstar, yes the issue has been there for many builds already.
Like I mentioned a client like Filezilla works fine when logging in.
hennie1nl is offline   Reply With Quote
Old 07-25-2011, 05:49 AM   #9
mikarama
Junior Member
FlashFXP Beta Tester
 
Join Date: Jul 2010
Posts: 13
Default

had very strange behaviors with this one in the local explorer :
single click behave like crtl click and entering a folder led me to its parent.
I'm back to stable builds as I need to get the job done.
mikarama is offline   Reply With Quote
Old 07-25-2011, 11:20 AM   #10
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Quote:
Originally Posted by mikarama View Post
had very strange behaviors with this one in the local explorer :
single click behave like crtl click and entering a folder led me to its parent.
I'm back to stable builds as I need to get the job done.
What operating system are you using?

So you're saying every single click would not un-select any previous items, thus multiple items were being selected?

I've never seen this before on any version of MS windows, I have however seen this on WINE.

Does this occur all the time, or is there a specific event that triggers this behavior? such as changing dirs, refreshing, changing the sort-order, etc.

Last edited by bigstar; 07-25-2011 at 11:38 AM.
bigstar is offline   Reply With Quote
Old 07-25-2011, 11:22 AM   #11
mikarama
Junior Member
FlashFXP Beta Tester
 
Join Date: Jul 2010
Posts: 13
Default

Quote:
Originally Posted by bigstar View Post
What operating system are you using?

So you're saying every single click would not un-select any previous items, thus multiple items were being selected?

I've never seen this before on any version of MS windows, I have however seen this on WINE.
win 7 64

yes, it was uber strange. I rolled back to a stable version immediatly
mikarama is offline   Reply With Quote
Old 07-25-2011, 11:46 AM   #12
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Quote:
Originally Posted by mikarama View Post
win 7 64

yes, it was uber strange. I rolled back to a stable version immediatly
Did this occur all the time, or is there a specific event that triggers this behavior? such as changing dirs, refreshing, changing the sort-order, etc.

I use Win 7 64bit daily with FlashFXP and I have never seen this behavior. I wonder if there might be some 3rd party app conflicting with FlashFXP?
bigstar is offline   Reply With Quote
Old 07-25-2011, 09:58 PM   #13
mikarama
Junior Member
FlashFXP Beta Tester
 
Join Date: Jul 2010
Posts: 13
Default

Can't discuss much about the issue, since it happened once and then I uninstalled.
Was just notifying it in case others had the issue. If not, it was probably a 'local' bug.
mikarama is offline   Reply With Quote
Old 07-26-2011, 04:25 PM   #14
zeeter
Junior Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Join Date: Jul 2005
Posts: 12
Default

At least the last 3 week's worth of builds, the selective transfer feature has been broken for me including this build 1614. Is this currently a bug or did the function change in any way that would force me to reconfigure it?

Thanks
zeeter is offline   Reply With Quote
Old 07-26-2011, 06:47 PM   #15
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Quote:
Originally Posted by zeeter View Post
At least the last 3 week's worth of builds, the selective transfer feature has been broken for me including this build 1614. Is this currently a bug or did the function change in any way that would force me to reconfigure it?

Thanks
Can you please explain how its not working for you, along with a screenshot of your selective transfer rule-set, you can send me a private message to keep it private.

The selective transfer rules were broken but as far as I can tell 100% fixed in build 1614.

I am quite puzzled.
bigstar is offline   Reply With Quote
Reply

Tags
edit, flashfxp, ftp, queue, window

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:55 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)