Go Back   FlashFXP Forums > > > >

FlashFXP 4.1 beta feedback Please post all 4.1 beta comments, suggestions and bug reports in this forum.

Closed Thread
 
Thread Tools Display Modes
Old 06-30-2011, 06:37 PM   #1
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default FlashFXP 4.1 BETA build 1604

FlashFXP 4.1 BETA build 1604
  1. Fixed > Remote > File List > Refreshing after the content in a folder changing by another user could sometimes result in an access violation.
  2. Fixed > Remote > File List > When selecting the "Parent Directory" sometimes it was counted as being selected. We typically exclude this item from selection.
  3. Fixed > SFTP > Remote View/Edit > File not found error triggered when the browser is in a folder via cached navigation and the working directory on the server is something else.
  4. Fixed > Remote > File List > Move Files > When moving files after deleting them from the list the item selection wasn't reset.
  5. Fixed > Remote > File List > Refresh > the previous focused item wasn't correctly restored when items within the list were added or removed.
FlashFXP 4.1 BETA build 1603
  1. Fixed > Queue List > Access violation when deleting the item selection. The code was missing a index range check to insure the index was still valid before applying the updated selection.

FlashFXP 4.1 BETA build 1602

  1. Fixed > File and Queue List > Item selection issues.
  2. Fixed > Queue > Item Edit > When multiple queued deletes were selected the result was not as expected.
  3. Fixed > Remote edit > Active edits dialog > Sometimes multi-select was failing to remove all of the selected items.
  4. Changed > Remote edit > Active edits dialog > The item selection color will now change to indicate whether or not the list control has focus.
  5. Changed > Remote edit > Active edits dialog > The item icons are now dimmed for items that were loaded from the edit history but currently do not exist locally.
  6. Fixed > List-views > Font resource leak.
  7. Changed > Move confirmation prompt > This prompt now includes the name of the selected item or the number of items selected.
  8. Fixed > Synchronized browsing > There was an unusual situation where synchronized browsing would sometimes get out of sync.
  9. Fixed > EnQueue Delete > Queue List > Item Edit > When the "Include sub-folders" option is unchecked the folder itself was not supposed to be deleted.
  10. Fixed > Remote edit > Active edits dialog > The right-click menu didn't always disable certain the menu items when multiple items were selected.
  11. Fixed > Download > file > If the local disk became full and the option "Check for free space before download" was unchecked FlashFXP didn't properly handle a write failure due to a fragment of code that was added to troubleshoot a write error.
Download via LiveUpdate

Last edited by bigstar; 07-01-2011 at 04:46 PM.
bigstar is offline  
Old 07-01-2011, 01:50 PM   #2
benjamin3
Senior Member
FlashFXP Beta Tester
 
Join Date: Jul 2005
Posts: 106
Default

thx for solving all those mentioined issues, i experience for the last versions that "RESUME" isnt properly working. right now im using 1603 , and i tried resuming 2 files which werent complete. i experience that one file was just overwritten, instead of being resumed. then i thought "ah ok resume doesnt work here, so it just overwrites".. but after finishing the second file was properly resumed. i experience this "RESUME" trigger behaviour in the last version i think starting 1540+ , perhaps you could take a look . and most of the time files before are just skipped properly cause they are already there and then if he finds the first matching not to be complete instead of resuming he just overwrites.

sounds funny right?

regards
benjamin3 is offline  
Old 07-01-2011, 02:11 PM   #3
benjamin3
Senior Member
FlashFXP Beta Tester
 
Join Date: Jul 2005
Posts: 106
Default

Another "bug" issue or call it "effect", if you login twice into your source , and mark the "parent directory", just move the cursor to there, and you see the complete directory size, if you then stay on this area and hit F5/reload while fxp'ing files via a second session then it switches to "0 byte", e.g. the same effect if you just mark some folder.

hope you know what i mean :-)
benjamin3 is offline  
Old 07-01-2011, 02:15 PM   #4
benjamin3
Senior Member
FlashFXP Beta Tester
 
Join Date: Jul 2005
Posts: 106
Default

another bug, if you move the bottom last file just to above during some transfer, it goes below the current transfer, but the marking is the current file suddenly. should normally the "moved" file...

please fix
benjamin3 is offline  
Old 07-01-2011, 04:55 PM   #5
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Quote:
Originally Posted by benjamin3 View Post
another bug, if you move the bottom last file just to above during some transfer, it goes below the current transfer, but the marking is the current file suddenly. should normally the "moved" file...

please fix
When a queue is being processed the item selection state is no longer kept in sync with the list view, what this means is as items are deleted the selection state will not follow the items.

Keeping the item selection state in sync as each individual item is added or removed from the list view adds a lot of overhead to the list control because these operations are slow.

This is something I will need to re-think, especially if users want me to keep this behavior regardless of the performance overhead penalty.
bigstar is offline  
Old 07-01-2011, 04:56 PM   #6
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

FlashFXP 4.1 BETA build 1604 RELEASED
bigstar is offline  
Old 07-02-2011, 04:58 PM   #7
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Queue list item selection idea,

What if the item selection is retained under the following situations.
1. When processing the transfer queue but only while the queue list is focused, if focus is shifted to another control the selection state is cleared.
2. At all other times while the queue isn't in progress.

This will eliminate the overall bottlneck and the only time there will be a bottleneck is when the user is working with the queue list.

Please let me know what you think, I will most likely implement this change in the next build.
bigstar is offline  
Old 07-02-2011, 05:32 PM   #8
Yil
Too much time...
FlashFXP Beta Tester
ioFTPD Administrator
 
Join Date: May 2005
Posts: 1,194
Default

1604: Open up FlashFxp, connect to a site. Open up a new session, connect to the same site. If you do that quickly everything works, if you wait a minute or two before opening up the 2nd Flash window it fails like this:

[18:08:24] WinSock 2.0 -- OpenSSL 1.0.0d 8 Feb 2011
[18:08:31] [R] Connecting to XXX -> DNS=XXX IP=XXX PORT=XXX
[18:08:31] [R] Connected to XXX
[18:08:31] [R] 220 FTP Server ready.
[18:08:31] [R] AUTH TLS
[18:08:32] [R] 234 AUTH TLS successful.
[18:08:32] [R] Connected. Negotiating TLSv1 session
[18:08:32] [R] Connection failed (Connection timed out)
[18:08:32] [R] Delaying for 300 seconds before reconnect attempt #1

I'm not sure when this started happening, but I'm intrigued by the "timed out" error. This is connecting to an ioFTPD server so it's possible it could be some sort of OpenSSL weirdness BUT the error message doesn't make sense...

I'm not sure it fails every time, but it's pretty common and just noticed it when upgrading the server box to 1604 but was using like 1525 and never had this issue, so I can't tell you when it might have started happening.

Oh, you cancel the retry and immediately reconnect and it works fine.

Oh, and not that it's a big deal, but I think I mentioned the "FlashFXP 4.1.0 (build 1604) [BETA]" line when you start it up being invisible (because it's black). Perhaps testing for a black background and switching to white would be a good idea. The really weird part is you can see the text if you highlight the area, BUT the text really isn't there at all if you double click on the status area to get the status window. The only thing you can see is the forum hotlink itself (not the Support forum: text) because it's in a different color.
Yil is offline  
Old 07-02-2011, 10:56 PM   #9
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Yil earlier tonight I discovered a situation where FlashFXP would report the connection failure as "connection timed out" when WSAGetLastError returns 0, Further testing revealed that in some cases WSASetLastError was clearing the last error before the failure message was generated. I have resolved this issue for the next build.

Its quite possible that the error message is very misleading in this case.

As for your specific issue, I'm really not sure, and I am not able to reproduce this behavior. Perhaps when we get the real socket error it might shed some light on the problem.

I am still investigating the hidden text, I suspect the text is being rendered before the user defined colors are being set, These issues with the UI have taken priority and I haven't had a chance to get to this yet.
bigstar is offline  
Old 07-04-2011, 01:24 PM   #10
benjamin3
Senior Member
FlashFXP Beta Tester
 
Join Date: Jul 2005
Posts: 106
Default

Im not able to move some file to top, if i right-click "move top" , it just stays in the queue.

first i marked 2 items from the bottom and clicked "move top" , but only one item was moved to top. then i tried again for the remaining item but nothing happens.

EDIT: i got this issue during transfer, if transfer is stopped temporary then i can move the items with the commands "move to top" .

strange.

Quote:
What if the item selection is retained under the following situations.
1. When processing the transfer queue but only while the queue list is focused, if focus is shifted to another control the selection state is cleared.
2. At all other times while the queue isn't in progress.
regarding your ideas, hm i let you decide. im just curious if some features stop working after beta releases so i just report everything i think it's worth to fix.
benjamin3 is offline  
Old 07-04-2011, 04:24 PM   #11
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Quote:
Originally Posted by benjamin3 View Post
Im not able to move some file to top, if i right-click "move top" , it just stays in the queue.

first i marked 2 items from the bottom and clicked "move top" , but only one item was moved to top. then i tried again for the remaining item but nothing happens.

EDIT: i got this issue during transfer, if transfer is stopped temporary then i can move the items with the commands "move to top" .

strange.



regarding your ideas, hm i let you decide. im just curious if some features stop working after beta releases so i just report everything i think it's worth to fix.
Thank you for bringing this to my attention, I have implemented the selection save on focus and it appears to be working correctly now. I will double check the move to top. My goal is to get a new build out tomorrow provided I don't find any unexpected issues.
bigstar is offline  
Closed Thread

Tags
download, fixed, flashfxp, item, sftp

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 04:46 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)