Go Back   FlashFXP Forums > > > >

FlashFXP 4.1 beta feedback Please post all 4.1 beta comments, suggestions and bug reports in this forum.

Closed Thread
 
Thread Tools Display Modes
Old 05-13-2011, 04:44 PM   #1
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default FlashFXP 4.1 BETA build 1579

FlashFXP 4.1 Build 1579 (beta)

  1. Re-addressed the MODE Z issue that resulted in incomplete uploads and corrupted downloads, and the incorrect sizes being reported in the session status window.
  2. Fixed several odd ball A/V errors when running FlashFXP via the command line.
  3. Optimized the memory usage and performance of several internal data lists.
  4. Optimized the auto save queue feature, it was sometimes triggering multiple times within seconds of the last save, normally the auto-save is only triggered once every minute if the queue is modified.
  5. Optimized the memory and resource usage of FlashFXP when run as a scheduled task.
  6. Optimized the performance of the queue storage list-view display when adding/removing items.
  7. Optimized the local browser shell garbage collection, the garbage collection list container capacity was never compacted throughout the program usage resulting in extra and unnecessary memory usage.
  8. Fixed some issues with the queue editor where the button states were enabled/disabled incorrectly and the source/target was reversed in some cases.
  9. Fixed an A/V on startup that occurred when the v3.6 key upgrade dialog appears behind the main window when the restore queue dialog was also shown.
  10. Changed the way the drawing code for the status window console, please let me know if you experience any issues.
Download it via LiveUpdate
bigstar is offline  
Old 05-14-2011, 02:28 AM   #2
benjamin3
Senior Member
FlashFXP Beta Tester
 
Join Date: Jul 2005
Posts: 106
Default

Hi bigstar,

1579 gives me a new behaviour :

Quote:
[L] SIZE some_file.***
[L] 550 some_file.***: No such file or directory.
[R] PASV
nearly on all files, the file is inside the directory, and after this "no such file" blabla, then the transfer starts.

funny aint ?

again copy/paste :

Quote:
[R] TYPE I
[R] 200 Type set to I.
[L] TYPE I
[L] 200 Type set to I.
[L] SIZE some_file.***
[L] 550 some_file.***: No such file or directory.
[R] PASV
[R] 227 Entering Passive Mode (xx,xx,xxx,xxx,xxx,xxx)
[L] PORT xx,xx,xxx,xxx,xxx,xxx)
[L] 200 PORT command successful.
[L] STOR some_file.***
[L] 150 Opening BINARY mode SSL data connection for 'some_file.***'.
[R] RETR some_file.***
[R] 150 Opening BINARY mode data connection for some_file.*** (xxxx bytes) using SSL/TLS.

Last edited by benjamin3; 05-14-2011 at 09:34 AM.
benjamin3 is offline  
Old 05-14-2011, 06:27 AM   #3
bassiliin
Junior Member
FlashFXP Registered User
 
Join Date: Dec 2010
Posts: 20
Default

Little UI request. Now is buttn toolbar too high comparing with buttons. Too much wasted space below buttons. I'm using classic theme, but same is with other themes as well. Or at least buttons should be in middle (little bit lower) so space above and below would be even. It'ld be nicer then.
Attached Thumbnails
FlashFXP 4.1 BETA build 1579-shot_2011-05-14_14-21-34_000-a  
bassiliin is offline  
Old 05-14-2011, 10:29 AM   #4
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Quote:
Originally Posted by benjamin3 View Post
nearly on all files, the file is inside the directory, and after this "no such file" blabla, then the transfer starts.
What build are you upgrading from?

Did these files fail and is this a re-attempt to transfer them?

In your File Transfer Rules (either global or per-site) do you have the option "Request file size/date prior to transfer" checked? When this option is checked it will send a SIZE, MLST, or MDTM command prior to each transfer to retrieve the size and date.

I noticed that this is a site to site transfer. I did not throughly test this type of transfer with my changes and its possible something is broken but only if the above option is unchecked.
bigstar is offline  
Old 05-14-2011, 10:35 AM   #5
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Quote:
Originally Posted by bassiliin View Post
Little UI request. Now is buttn toolbar too high comparing with buttons. Too much wasted space below buttons. I'm using classic theme, but same is with other themes as well. Or at least buttons should be in middle (little bit lower) so space above and below would be even. It'ld be nicer then.
What version of Windows are you using?

Do you mean you're using the classic theme in FlashFXP or in Windows? If not Windows what theme are you using?

When you change the toolbar buttons via the Preferences sometimes the toolbars don't resize to the exact defined height (especially when switching between buttons of different sizes), only after restarting FlashFXP are the buttons correct.

I can't quite tell from your screenshot because it doesn't reveal enough about the toolbars, but thats not right at all.

Do you have the 'modern style' checked for the toolbars?

Last edited by bigstar; 05-14-2011 at 10:40 AM.
bigstar is offline  
Old 05-14-2011, 11:01 AM   #6
bassiliin
Junior Member
FlashFXP Registered User
 
Join Date: Dec 2010
Posts: 20
Default

OS is WinXP with no modifications. FlashFXP 4.1 build 1579, theme is Classic. Same with Tango and Techie. They change toolbar bigger and still keeping too much space under button. Switching back to Classic theme toolbar goes smaller but still keeping same amount of bigger space under btton. And it doesn't matter if modern style is checked or not. Buttons are too high on toolbar. I'll try to find from which version it started behaving such way.

I noticed same look in my laptop also (there is build 1569). Also tried plain build 1545, same look, buttons are near upper edge of toolbar.

Last edited by bassiliin; 05-14-2011 at 11:20 AM.
bassiliin is offline  
Old 05-14-2011, 11:54 AM   #7
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

I just tested build 1579 and compared the two and there are some quite obvious issues when used on older versions of Windows or if themes are disabled.

In build 1579 the borders aren't being applied correctly.

Modern unchecked (Windows 7)



Modern checked (Windows 7)






Modern unchecked (Windows XP)




Modern checked (Windows XP)




This fix will be applied to the next release.

The problem was caused by extra space being added for the edge borders when there were no borders on the toolbar.
bigstar is offline  
Old 05-14-2011, 12:06 PM   #8
rco133
Member
FlashFXP Beta Tester
 
Join Date: Oct 2006
Posts: 38
Default

Hi.

After upgrading to 1579 I am experiencing that when I connect to FTP servers using AUTH TLS and Secure File Listings, the list of files/folders is often empty. I then have to press F5 one or more times to get the list of files.

The above behaviour is not happening all the time, so troubleshooting may be a bit difficult.

I don't recall this being an issue in previous releases.

I am running Win XP Pro with SP3 if that is of any importance.

rco133
rco133 is offline  
Old 05-14-2011, 01:17 PM   #9
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Quote:
Originally Posted by rco133 View Post
Hi.

After upgrading to 1579 I am experiencing that when I connect to FTP servers using AUTH TLS and Secure File Listings, the list of files/folders is often empty. I then have to press F5 one or more times to get the list of files.
Are you using MODE Z compression?

Can you please send me a private message with a copy of the session log.
bigstar is offline  
Old 05-14-2011, 01:18 PM   #10
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

I discovered a small drawing issue in the status window console, when resizing the program window the console pane will sometimes flicker black/white. This will be addressed in the next update.
bigstar is offline  
Old 05-15-2011, 03:44 AM   #11
rco133
Member
FlashFXP Beta Tester
 
Join Date: Oct 2006
Posts: 38
Default

Quote:
Originally Posted by bigstar View Post
Are you using MODE Z compression?

Can you please send me a private message with a copy of the session log.
Hi.

Yes, I am using MODE Z Compression.

I will try and see if I can log a session where the listing fails.

Somehow it seems to happen espessialy if I connect to a server in the left pane, and then connect to a server in the right pane, before the connection in the left is completely established.

Since it doesn't happen every time, I will see if I can log a session where it happens.

rco133.
rco133 is offline  
Old 05-15-2011, 02:02 PM   #12
benjamin3
Senior Member
FlashFXP Beta Tester
 
Join Date: Jul 2005
Posts: 106
Default

Quote:
Originally Posted by bigstar View Post
What build are you upgrading from?

Did these files fail and is this a re-attempt to transfer them?

In your File Transfer Rules (either global or per-site) do you have the option "Request file size/date prior to transfer" checked? When this option is checked it will send a SIZE, MLST, or MDTM command prior to each transfer to retrieve the size and date.

I noticed that this is a site to site transfer. I did not throughly test this type of transfer with my changes and its possible something is broken but only if the above option is unchecked.
1574 -> 1579

since 1574 this issue "appears" , the files are transferred normal as they should, i think this is quite a bug , and no the "request file size" option isnt check. i use the global_settings no specific setting used.

regards
ben
benjamin3 is offline  
Closed Thread

Tags
download, flashfxp, optimized, queue, usage

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 04:24 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)