Go Back   FlashFXP Forums > > > >

FlashFXP 4.0 RC 1 Use this forum to ask questions, make suggestions, or provide feedback for FlashFXP 4.0 RC 1.

 
 
Thread Tools Display Modes
Old 07-28-2010, 09:29 PM   #1
junq316
Junior Member
 
Join Date: Jul 2010
Posts: 5
Default BUG: SSL Data doesn't work over SOCKS 4 Proxy

In FlashFXP 3.6.0.1240, when using a Socks 4 Proxy to connect to an SSL enabled Server, Secure Directory Listing works fine:

Code:
[R] PWD
[R] 257 "/" is current directory.
[R] TYPE A
[R] 200 Type set to A.
[R] PROT P
[R] 200 Protection set to Private
[R] PASV
[R] 227 Entering Passive Mode (*,*,*,*,16,1)
[R] Opening data connection via Proxy
[R] LIST -al
[R] Connected. Negotiating TLSv1 session..
[R] 150 Opening ASCII mode data connection for directory listing using SSL/TLS.
[R] TLSv1 negotiation successful...
[R] TLSv1 encrypted session using cipher DHE-DSS-AES256-SHA (256 bits)
[R] List Complete: 548 bytes in 0.67 seconds (0.8 KB/s)
Trying the very same server, with exactly same options (imported from FlashFXP 3.6.0.1240 through tools->backup) I get an SSL Error:

Code:
[R] PWD
[R] 257 "/" is current directory.
[R] TYPE A
[R] 200 Type set to A.
[R] PROT P
[R] 200 Protection set to Private
[R] PASV
[R] 227 Entering Passive Mode (*,*,*,*,16,144)
[R] Opening data connection via Proxy
[R] LIST -al
[R] Connected. Negotiating TLSv1 session
[R] error:1408F044:SSL routines:SSL3_GET_RECORD:internal error
[R] Failed TLSv1 negotiation, disconnected
[R] 150 Opening ASCII mode data connection for directory listing using SSL/TLS.
[R] 435 Failed TLS negotiation on data channel (using SSL_accept()), disconnected: Success.
[R] List Error
Connecting without Proxy to verify the Issue appears to be within the Proxy Implementation:

Code:
[R] PWD
[R] 257 "/" is current directory.
[R] TYPE A
[R] 200 Type set to A.
[R] PROT P
[R] 200 Protection set to Private
[R] PASV
[R] 227 Entering Passive Mode (*,*,*,*,15,247)
[R] Opening data connection IP: *,*,*,* PORT: 4087
[R] LIST -al
[R] Connected. Negotiating TLSv1 session
[R] 150 Opening ASCII mode data connection for directory listing using SSL/TLS.
[R] TLSv1 negotiation successful...
[R] TLSv1 encrypted session using cipher DHE-DSS-AES256-SHA (256 bits)
[R] List Complete: 548 bytes in 0.62 seconds (0.9 KB/s)
The proxy server used for those tests is danted: http://www.inet.no/dante/
junq316 is offline  
Old 07-29-2010, 03:29 AM   #2
MHJ
Junior Member
FlashFXP Registered User
 
Join Date: Mar 2004
Posts: 15
Thumbs up confirmed

hello,

i can confirm the same error using a socks5 proxy connection

found a workaround though:

replace the ssl libraries with older ones (OpenSSL v0.9.8i) till the issue is fixed.
i uploaded them here: <removed by admin>

at the bottom right corner there's a link that says "Save file to your PC:"
hit "click here" to download the file.

how to:

1) download the rar file
2) extract the ssl libraries
3) close flashfxp 4 (if open)
4) copy the ssl libraries to your flashfxp 4 directory replacing the old ones
5) done

if you start flashfxp 4 now you should see the following in the status window:

FlashFXP 4.0 (4.0.0 build 1458) [BETA] - PREVIEW RELEASE

WinSock 2.0 -- OpenSSL 0.9.8i 15 Sep 2008

Last edited by bigstar; 07-29-2010 at 08:55 AM. Reason: propering
MHJ is offline  
Old 07-29-2010, 08:58 AM   #3
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

MHJ I appreciate your attempt to help other users with this issue but for the security and safety of our users we do not recommend users using 3rd party download links.

I am working on a fix for this issue and it will be posted very soon.

Last edited by bigstar; 07-29-2010 at 10:56 AM.
bigstar is offline  
Old 07-29-2010, 10:09 AM   #4
MHJ
Junior Member
FlashFXP Registered User
 
Join Date: Mar 2004
Posts: 15
Default

Quote:
Originally Posted by bigstar View Post
MHJ I appreciate your attempt to help other users with this issue but for the security and safety of our users we do not recommend using 3rd party replacement files.
i understand that but in this case it's actually the flashfxp v3 ssl libraries, so not really "third party" so i didn't see a problem, but ok. thanks for the fix in advance.
MHJ is offline  
Old 07-29-2010, 10:57 AM   #5
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Sorry I meant to say 3rd party download links.

I have the problem fixed and I'm preparing the new build for release.
bigstar is offline  
Old 07-29-2010, 11:09 AM   #6
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

The download link has been updated and the fix has been posted.
bigstar is offline  
Old 07-29-2010, 02:07 PM   #7
junq316
Junior Member
 
Join Date: Jul 2010
Posts: 5
Default

Quote:
Originally Posted by bigstar View Post
The download link has been updated and the fix has been posted.
Thanks bigstar for the quick fix!
junq316 is offline  
 

Tags
data, flashfxp, proxy, tlsv1, [r]

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:49 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)