Go Back   FlashFXP Forums > > > >

Bug Reports FlashFXP 3.0 RC 3 Bug Reports

 
 
Thread Tools Display Modes
Old 07-13-2004, 12:32 AM   #1
divfor
Junior Member
 
Join Date: Jul 2004
Posts: 4
Default

faint, this is bugs report, not support.
in my mind, flashfxp not support FXP well in Windows XP + sp1 or sp2. i have try same two sites using ultrafxp, it works well. I have captured the packets of FXP using ethereal tools, it appears that flashfxp makes a wrong port request to fxp dst_site after getting a "enter passive mode x.x.x.x, p1, p2" from fxp src_site.
divfor is offline  
Old 07-13-2004, 03:58 AM   #2
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,840
Default

your post has nothing to do is the thread it was posted in, so
split into it's own thread

your 'bug report' doesn't have any usefull info for us to help you or troubleshoot this problem.
if you want this issue resolved, check out forum posting RULES
http://forum.flashfxp.com/showthread...&threadid=4406
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Old 07-14-2004, 10:32 AM   #3
divfor
Junior Member
 
Join Date: Jul 2004
Posts: 4
Default build1010 FXP fails in Winxp with windows firewall

i note that windows xp + sp2 with a microsoft windows firewall will make flashfxp3.0 build 1010 FXP failure. I catputure the packets flashfxp sent, found that flashfxp (maybe firewall changed) send a PORT request to dst_site with a IP and a port of flashfxp's host, not that src_site gived in "Enter PASV x,x,x,x,p,p"

if close the firewall, everything will be ok.

i cann't change or set windows firewall to resolve this problem.
divfor is offline  
Old 07-14-2004, 01:15 PM   #4
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,840
Default

it's not flashfxp's fault..unless you can show us flashfxp's status log that shows it sends incorrect PORT command.
most likely XP's firewall is trying to "fix" that command thinking it's incorrect

threads merged since they are same issue
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Old 07-14-2004, 06:10 PM   #5
divfor
Junior Member
 
Join Date: Jul 2004
Posts: 4
Default

I think it is FlashFxp's problem because:
1. UltraFxp works well for the same environment and same two sites.
2. FlashFxp can work well in FXP from A site to B site, but fails in FXP from B to A. but if turn off MS firewall, the two directions all works well.

btw, FlashFXP always logs correctly in the statuts log windows.
divfor is offline  
Old 07-14-2004, 06:19 PM   #6
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,840
Default

flashfxp send what it shows...
if A to B works but B to A doesn't, make sure you have Alternative FXP settings correctly configured..
ie in both cases same site is getting PASV command and the other site getting PORT command
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Old 07-14-2004, 06:40 PM   #7
divfor
Junior Member
 
Join Date: Jul 2004
Posts: 4
Default

I forget to note that the setting for two sites is same, default settings.
divfor is offline  
 

Tags
appears, flashfxp, fxp, support, windows

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
http proxy support mintu General Discussion 1 01-24-2005 02:02 PM


All times are GMT -5. The time now is 02:54 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)