Go Back   FlashFXP Forums > > > >

Bug Reports FlashFXP 3.0 RC 3 Bug Reports

 
 
Thread Tools Display Modes
Old 05-27-2004, 04:50 AM   #1
fobban
Senior Member
FlashFXP Registered User
ioFTPD Foundation User
 
Join Date: Jan 2003
Posts: 186
Default Denied files getting downloaded?

* FlashFXP v[3].[0], build [998], [x]registered, [ ]unregistered, [ ]pirated
* OS [x] WinXP, [ ] Win2K, [ ] Win98, [ ] WinME, [ ] Other
* Running behind NAT/router [ ] Yes & Model [ ], [x] No, [ ] Not sure
* Running firewall [x] Yes, Name [Kerio Personal Firewall], Ver. [4.0.16], or [ ] No
* Running Antivirus [x] Yes, Name [Norton Antivirus] or [ ] No
* Network [ ] xDSL, [ ] CABLE, [ ] Dail-Up, [x] Other

This is from my status window when I'm trying to download a 0-byte files using TLS (same with SSL btw)
Quote:
[R] RETR [site]-[COMPLETE]-[52F@732.3MB_at_967KBps]-[site]
[R] Connected. Negotiating TLSv1 session..
[R] 550 [site]-[COMPLETE]-[52F@732.3MB_at_967KBps]-[site]: Permission denied.
Transferred: [site]-[COMPLETE]-[52F@732.3MB_at_967KBps]-[site] 0 bytes in 0,00 seconds
I tried it several times and the file is downloaded (well created at least ).

Seems like it's TLS/SSL that is the problem, this is without any encryption at all
Quote:
[R] RETR [site]-[COMPLETE]-[52F@732.3MB_at_967KBps]-[site]
[R] 550 [site]-[COMPLETE]-[52F@732.3MB_at_967KBps]-[site]: Permission denied.
[R] Transfer Failed!
Found a little error when it comes to uploads too. This is when i tried to upload a zip-file in a directory where it was not allowed using TLS:
Quote:
[R] STOR testfile.zip
[R] Connected. Negotiating TLSv1 session..
Transferred: testfile.zip 5 KB in 0,00 seconds (0,1 KB/s)
[R] TYPE A
[R] 550 testfile.zip: Permission denied.
Here it seems like the file is uploaded, but it never appeares on the site. First i thought this would have been a server problem (using ioFTPD 5-8-5r) but it only happens when I use encryption, so without TLS/SSL i get this:

Quote:
[R] STOR testfile.zip
[R] 550 testfile.zip: Permission denied.
[R] Transfer Failed!
fobban is offline  
Old 05-27-2004, 07:13 AM   #2
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Hello,

Thank you for your bug reports.

I tried to reproduce the problems you outlined below. I tested using ioFTPd and Serv-U. With both ftp servers I was unable to reproduce any of these problems.

Which version of openssl are you using? FlashFXP will show the version on startup in the status window.

Code:
[06:55:48] [R] STOR IO.SYS
[06:55:48] [R] Connected. Negotiating SSL session..
[06:55:48] [R] 550 Permission denied.
[06:55:48] [R] Transfer Failed!

[07:10:12] [R] RETR IO.SYS
[07:10:12] [R] Connected. Negotiating TLSv1 session..
[07:10:12] [R] 550 IO.SYS: Permission denied.
[07:10:12] [R] Transfer Failed!
bigstar is offline  
Old 05-27-2004, 07:27 AM   #3
fobban
Senior Member
FlashFXP Registered User
ioFTPD Foundation User
 
Join Date: Jan 2003
Posts: 186
Default

OpenSSL 0.9.7d 17 Mar 2004
fobban is offline  
 

Tags
download, flashfxp, upload, [r], [x]

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
"Only resume files transferred in binary mode" Gary King General Discussion 1 03-31-2005 01:19 AM


All times are GMT -5. The time now is 07:25 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)