Old 09-03-2002, 03:51 PM   #1
jAck|DvDRiP
Junior Member
 
Join Date: Sep 2002
Posts: 3
Default Connection Lost; Attempting to Reconnect *PROBLEM*

Here's what's going on:

Everytime i'm downloading something from *ANY* FTP server, i get disconnected (Connection Lost), then it attempts to reconnect, it resumes the file, everything OK again, 1 min. or so, it happens again, and then again, then again, and again, and again ..

This happens with EVERY FTP Server i log on to ...

What's the matter? Is this a possible bug?
I didn't notice this problem on FlashFXP 1.4 !

Here's what happens:

===========================================
FlashFXP v2.0 Release Candidate 2 (Debug Version)
Online Support Forums http://forum.flashfxp.com

WinSock 2.0
Connecting to Westh's FTP
Connected to 130.239.137.85 Port 21
220 Serv-U FTP Server v3.0 for WinSock ready...
USER yebe
331 User name okay, need password.
PASS (hidden)
230 User logged in, proceed.
SYST
215 UNIX Type: L8
PWD
257 "/" is current directory.
TYPE A
200 Type set to A.
PORT 192,168,200,12,5,128
200 PORT Command successful.
LIST
150 Opening ASCII mode data connection for /bin/ls.
226 Transfer complete.
CWD Allt möjligt och omöjligt
250 Directory changed to /Allt möjligt och omöjligt
PWD
257 "/Allt möjligt och omöjligt" is current directory.
PORT 192,168,200,12,5,129
200 PORT Command successful.
LIST
150 Opening ASCII mode data connection for /bin/ls.
226 Transfer complete.
TYPE I
200 Type set to I.
PORT 192,168,200,12,5,130
200 PORT Command successful.
RETR Therapy - Diane.mp3
150 Opening BINARY mode data connection for Therapy - Diane.mp3 (3853048 bytes).
Connection lost: Westh's FTP
Attempting to Reconnect.

Connecting to Westh's FTP
Connected to 130.239.137.85 Port 21
220 Serv-U FTP Server v3.0 for WinSock ready...
USER yebe
331 User name okay, need password.
PASS (hidden)
230 User logged in, proceed.
SYST
215 UNIX Type: L8
PWD
257 "/" is current directory.
CWD /Allt möjligt och omöjligt/
250 Directory changed to /Allt möjligt och omöjligt
PWD
257 "/Allt möjligt och omöjligt" is current directory.
List (cached)
List Complete.
TYPE I
200 Type set to I.
PORT 192,168,200,12,5,132
200 PORT Command successful.
REST 1793024
350 Restarting at 1793024 - send STORE or RETRIEVE to initiate transfer.
RETR Therapy - Diane.mp3
150 Opening BINARY mode data connection for Therapy - Diane.mp3 (3853048 bytes).
Connection lost: Westh's FTP
Attempting to Reconnect.

Connecting to Westh's FTP
Connected to 130.239.137.85 Port 21
220 Serv-U FTP Server v3.0 for WinSock ready...
USER yebe
331 User name okay, need password.
PASS (hidden)
230 User logged in, proceed.
SYST
215 UNIX Type: L8
PWD
257 "/" is current directory.
CWD /Allt möjligt och omöjligt/
250 Directory changed to /Allt möjligt och omöjligt
PWD
257 "/Allt möjligt och omöjligt" is current directory.
List (cached)
List Complete.
TYPE I
200 Type set to I.
PORT 192,168,200,12,5,134
200 PORT Command successful.
REST 3511144
350 Restarting at 3511144 - send STORE or RETRIEVE to initiate transfer.
RETR Therapy - Diane.mp3
150 Opening BINARY mode data connection for Therapy - Diane.mp3 (3853048 bytes).
226 Transfer complete.
Resumed: Therapy - Diane.mp3 341.904 bytes in 12,73 (26,23 KBps)
CWD /
250 Directory changed to /
PWD
257 "/" is current directory.
List (cached)
List Complete.
Transfer queue completed
Transferred 1 file totaling 341.904 bytes in 16,01 (26,23 KBps)
===========================================

I'm using:

FlashFXP 2.0 RC2 Build 869
Windows XP Professional
3COM Remote 812 ADSL Router
No Firewall installed
jAck|DvDRiP is offline  
Old 09-03-2002, 04:31 PM   #2
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,839
Default

flashfxp is sending PORT command with wrong IP.
F6, "proxy/firewall/ident" tab, "bind sockets to this address" and specify your inet ip.

or use PASV mode
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Old 09-03-2002, 06:15 PM   #3
jAck|DvDRiP
Junior Member
 
Join Date: Sep 2002
Posts: 3
Default

I already tried using Passive Mode .. same thing over and over again ..

And binding sockets to my extern ip doesn't work, cause i can't logon ... here's what happen:

FlashFXP v2.0 Release Candidate 2 (Debug Version)
Online Support Forums http://forum.flashfxp.com

WinSock 2.0
Connecting to JaCKaL BrTurbo
Connected to ftp.brturbo.com Port 21
220 ftp.brturbo.com NcFTPd Server (licensed copy) ready.
USER jackal
331 User jackal okay, need password.
PASS (hidden)
230-You are user #24 of 1000 simultaneous users allowed.
230-
230-Bem-vindo ao servidor ftp.brturbo.com !!
230-Visite nosso site http://www.brturbo.com
230-Voce tem 1073741824 bytes disponiveis.
230-Voce ja esta utilizando 740821273 bytes.
230-
230 Restricted user logged in.
SYST
215 UNIX Type: L8
REST 100
350 Will attempt to restart at position 100.
REST 0
350 Will attempt to restart at position 0.
PWD
257 "/" is cwd.
TYPE A
200 Type okay.
PORT 200,181,212,195,6,64

and stops there .. nothing happens ..
Unless i turn Passive Mode ON, then the bind sockets work .. but the problem persists ..
jAck|DvDRiP is offline  
Old 09-03-2002, 07:19 PM   #4
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

That's very odd. If v1.4 worked for you so should v2.0..

Are you sure you're using the exact same settings for v2.0?

I suspect your ADSL router uses NAT so even though it's sending the internal IP your ADSL rotuer corrects it.

Have you made any recent changes since upgrading from 1.4? Might want to install v1.4 into a seperate folder for testing.

I can't explain why you're loosing connection, it could be anything. It could be that your ADSL router has a timeout.
bigstar is offline  
Old 09-03-2002, 07:40 PM   #5
jAck|DvDRiP
Junior Member
 
Join Date: Sep 2002
Posts: 3
Default

Nopah, haven't made any recent changes, except that i used to work on Win98SE, and now i'm working on XP ..
.. and yes, my router uses NAT ..

Right now i'm perfoming a test, and 1.4 has shown the same problem .. so i guess it's not related to the version ..

Could it be Windows XP ?!

My connection type is PPPoA (600 kbps / 300 kbps) ..

I'll do better, i'll attach some pictures of my Router configurations, and you see if anything that could be related to the problem strikes up.. mmK?

One thing .. i sometimes get this in iRC downloads also !

(ERROR) Failed to Receive Star.Wars.Episode.II.Attack.Of.The.Clones.DVDRip.X viD-DVL.cd1.avi from DV34.
[9:30pm] DCC Get of Star.Wars.Episode.II.Attack.Of.The.Clones.DVDRip.X viD-DVL.cd1.avi from DV34 timed out
[9:31pm] -DV34- *** Closing Connection: Connection Lost

PS.: Thnx for taking the time to help me out !
Attached Files
File Type: zip router.zip (242.0 KB, 87 views)
jAck|DvDRiP is offline  
 

Tags
directory, ftp, och, port, type

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
why do i get this error ? twisted General Discussion 0 05-02-2005 11:25 PM


All times are GMT -5. The time now is 01:22 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)