Old 08-15-2002, 01:44 PM   #1
LoKiDarkGod
Junior Member
 
Join Date: May 2002
Posts: 16
Default bug in resuming files?

I'm using the latest version (build 869) and I've noticed a bug in resuming. I have it set to use APPE to resume uploads, and whenever a file is resumed, it apparently fails CRC checking, the rar file is corrupt. It hasn't been a random thing either, it seems everytime a file is resumed, it fails the SFV check.
LoKiDarkGod is offline  
Old 08-22-2002, 12:42 PM   #2
LoKiDarkGod
Junior Member
 
Join Date: May 2002
Posts: 16
Default

*BUMP*

41 views of this thread and no one has anything to say? has no one had this problem?
LoKiDarkGod is offline  
Old 08-22-2002, 01:46 PM   #3
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,839
Default

if i'm not mistaken appe should really be used only with warftpd servers cuase they are messed up in this area..i'm not sure how it would affect other ftpd, personally i never use it.

also make sure you are transfering files as TYPE I and not TYPE A.
MxxCon is offline  
Old 08-22-2002, 08:16 PM   #4
PeNGuiN
Member
FlashFXP Beta Tester
 
Join Date: Apr 2002
Posts: 69
Default

LoKi, you're most likely trying to resume a file on a glftpd server or another server that supports 'on-the-fly' CRC32 generation. The CRC32 is only calculated over the 'uploaded' data (only the resumed part!), therefore you're getting an SFV error...
PeNGuiN is offline  
Old 08-22-2002, 08:26 PM   #5
LoKiDarkGod
Junior Member
 
Join Date: May 2002
Posts: 16
Default

no its not that the script says it's bad.. When I fxp a file, and it it resumed, for whatever reason, when the file finished (15,000,000) it's corrupt. I've tried a standalone SFV checker, as well as tried to extract it with winrar, and both say it's corrupt. I have tried turning off APPE to see if it fixes the problem, will keep ya's posted on results. Also, I have made sure that the files aren't being transfered as ASCII (TYPE A), that was one of the first things I looked at.
LoKiDarkGod is offline  
Old 08-23-2002, 03:28 AM   #6
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Any reason why you're not using REST? does it mess up using REST too?
bigstar is offline  
Old 08-23-2002, 08:48 PM   #7
LoKiDarkGod
Junior Member
 
Join Date: May 2002
Posts: 16
Default

I was originally using APPE due to an issue with one of the sites I was using, but since the issue was resolved, it just became second nature really. I have tried turning it off, and will keep you apprised after a few trials over various sites.
LoKiDarkGod is offline  
Old 08-27-2002, 10:37 PM   #8
LoKiDarkGod
Junior Member
 
Join Date: May 2002
Posts: 16
Default

well good news.. it doesn't appear to cause corrupt files when using REST instead of APPE. I will continue with APPE turned off, but maybe you might look into why APPE can cause invalid CRC's on files, incase someone else might need it to be turned on.
LoKiDarkGod is offline  
Old 08-28-2002, 12:43 AM   #9
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

I'm glad to see REST is working.

APPE and REST worked fine on all of my ftp servers, I suspected the problem was caused by the ftp server.

From my point of view there isn't anything more I can do.
bigstar is offline  
 

Tags
bug, fails, file, resumed, resuming

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:43 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)