Old 06-22-2002, 06:16 AM   #1
Cobra77
Junior Member
 
Join Date: Jun 2002
Posts: 3
Default Having trouble with FXP transfer...

There is a following problem: when transferring files from FTP to FTP, some amount of Kbytes (up to 30) remains uncopied. However FlashFXP reports that transfer *is* complete...

But that's not all, sadly. When trying to resume I've repeatedly got the following message:

===
*STOR smthing.zip
*150 Data connection accepted from error:error; transfer starting for smth.zip...
===

... and of course, nothing is transferred actually.

Most interesting that sometimes it goes normally (I mean, resumes and finishes ok) - but that's for about 2 or 3 attempts of 10.

Bug, may be?

P.S. FlashFXP is RC 2.0 build 860.
Cobra77 is offline  
Old 06-22-2002, 06:30 AM   #2
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

FXP transfers are transferred directly site to site. There is no way for FlashFXP to know if the file is incomplete, if both servers report a successful transfer FlashFXP assumes the file was transferred successfully.

When a site to site transfer is performed FlashFXP acts as a 3rd hand guiding each server along the way, once the transfer starts the two servers are on their own, FlashFXP sits and waits until both servers notify FlashFXP the file was completed and then it continues on to the next file.

Not all ftp servers are created equal, some ftp server software may not be compatible with a different ftp server software. In some instances if the ftp software is created poorly it may not even be compatible with itself.

The fact that the file is nearly complete leads me to believe that the ftp server sending the data is prematurely closing the data connection. It's not waiting for the recieving server to recieve all of the data before closing the connection.

The error:error in the status message you supplied is from ftp server. I don't know which ftp server that is but I have seen reports of that error many times before. I think it has problems with site to site transfers.
bigstar is offline  
Old 06-22-2002, 08:25 AM   #3
MidKnight
Senior Member
FlashFXP Beta Tester
ioFTPD Registered User
 
Join Date: Oct 2001
Posts: 857
Default

im not going to say much here bigstar, but you might remember my post about this awhile ago
MidKnight is offline  
Old 06-22-2002, 09:12 AM   #4
Cobra77
Junior Member
 
Join Date: Jun 2002
Posts: 3
Default

So it's the trouble of ftp-server itself, and nothing can be done... I see.

Thank you for the answer, bigstar.
Cobra77 is offline  
Old 06-23-2002, 01:10 AM   #5
Cobra77
Junior Member
 
Join Date: Jun 2002
Posts: 3
Default

BTW, one of this FTPs is definitely using Serv-U 4.0, configured to not allow PASV.
Cobra77 is offline  
Old 06-24-2002, 05:33 AM   #6
G0D
Junior Member
 
Join Date: May 2002
Posts: 6
Default

I only get that problem when the ftpserver is running gene6 or bulletproof. tried it with 2 machine's.
I only did this using the latest flash 1.x though
G0D is offline  
 

Tags
===, flashfxp, ftp, smth.zip, transfer

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 07:50 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)