Go Back   FlashFXP Forums > > > >

Bug Reports Found a bug? Please let us know.

 
 
Thread Tools Display Modes
Old 09-30-2002, 02:32 PM   #1
LeSandMan
Junior Member
 
Join Date: Sep 2002
Posts: 7
Thumbs down Problems with site to site transfers...

I'm using FlashFXP RC3 (build 878)
I'm trying to FXP a file from site A to site B. A is Linux B is G6 Ftp server on W2000. I have disabled passive mode on both sites, and in Proxy settings. Set both sites NOT to use Passive mode for site-to-site trasfers on uploads and downloads... and yet I still see this in the status window:

[15:22:39] TYPE I
[15:22:39] 200 Type set to I.
[15:22:39] TYPE I
[15:22:39] 200 Type set to I.
[15:22:39] PASV
[15:24:39] Connection lost: SiteB

Thanks for your help.
LeSandMan is offline  
Old 09-30-2002, 02:41 PM   #2
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

The configuration you set is impossible. One of the sites MUST use passive mode, It's what makes site to site transfers possible. By enabling passive mode on both you effectively cancel each other out.
bigstar is offline  
Old 09-30-2002, 03:30 PM   #3
LeSandMan
Junior Member
 
Join Date: Sep 2002
Posts: 7
Default

Hmm... The B (target) site is one having problems with PASV, so is it possible to have the source site use PASV instead of the destination? I set it up that way in Site settings, but it still uese PASV on the target site.

Thanks.
LeSandMan is offline  
Old 09-30-2002, 03:52 PM   #4
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Yes, this is done via the Alternative FXP options located in the Site Manager / Options Tab. I was under the impression that this is the option you changed.
bigstar is offline  
Old 09-30-2002, 04:17 PM   #5
LeSandMan
Junior Member
 
Join Date: Sep 2002
Posts: 7
Default

That is the option I changed. I tired it in a few ways. Having both sites use Alternative FXP method, then site A and not B, then Site B and not A and also neither site. In all cases FlashFXP sends PASV command to site B.

Thanks for your replies, I really apreciate your trying to help
LeSandMan is offline  
Old 09-30-2002, 04:50 PM   #6
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Site A - allows PASV
Site B - doesn't allow PASV

For Site A don't check any alternative fxp options.
For Site B check both alternative fxp options.

If that doesn't work please provide a complete copy of the status window log.
bigstar is offline  
Old 09-30-2002, 10:26 PM   #7
LeSandMan
Junior Member
 
Join Date: Sep 2002
Posts: 7
Default

Here it is.
LeSandMan is offline  
Old 10-01-2002, 12:16 AM   #8
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Are you sure site A supports passive mode? Provided that's site A PASV is being sent it. Without any coloring or markings it's really hard for me to make much sense of that log.

Open the flashfxp.ini with notepad and add the following line under [main]
DebugTag=1

Then show me what you get.
bigstar is offline  
Old 10-01-2002, 06:43 AM   #9
LeSandMan
Junior Member
 
Join Date: Sep 2002
Posts: 7
Default

I didn't notice any new messages in the log or any other changes after I set the debug option. Here are the pictures of site settings and the log window, so that colors could be seen.
LeSandMan is offline  
Old 10-01-2002, 06:46 AM   #10
LeSandMan
Junior Member
 
Join Date: Sep 2002
Posts: 7
Default

And this is a picture of my site setttings.
Attached Thumbnails
Problems with site to site transfers...-site_settings-jpg  
LeSandMan is offline  
Old 10-01-2002, 01:17 PM   #11
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

It seems to me that the Alternative FXP options in the site manager were miss labeled. (based on some tests I just now conducted)

It should of read
[ ] Downloading (Not PASV)
[ ] Uploading (PASV)

So uncheck the Uploading box.
bigstar is offline  
Old 10-01-2002, 01:37 PM   #12
LeSandMan
Junior Member
 
Join Date: Sep 2002
Posts: 7
Thumbs up

Cool, it worked

Thank you.
LeSandMan is offline  
 

Tags
200, set, site, type, [152239]

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:17 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)