Old 09-16-2002, 08:47 AM   #1
Uxorious
Junior Member
 
Join Date: Sep 2002
Posts: 6
Default TLS not really working

Hi there I'm running the RC3 (878) and have tons of problems with TLS.

Sometimes when getting a dir or connecting, FlashFXP will write a bunch of garbage characters and then refuse to connect.

99% of the time FlashFXP will refuse to get the last few Kb of a file. As soon as the server prints the "completed" text on teh control line the dataline also dies.
Uxorious is offline  
Old 09-16-2002, 09:31 AM   #2
PeNGuiN
Member
FlashFXP Beta Tester
 
Join Date: Apr 2002
Posts: 69
Default

I doubt FFXP will close the dataline prematurely. It's the server that tells the client a file is done, I think. Download the 878 from this site and make sure you're not running a pirated version. Replace your SSL DLLs with the ones posted on this site as well.
PeNGuiN is offline  
Old 09-16-2002, 12:42 PM   #3
Uxorious
Junior Member
 
Join Date: Sep 2002
Posts: 6
Default

Quote:
Originally posted by PeNGuiN
I doubt FFXP will close the dataline prematurely. It's the server that tells the client a file is done, I think. Download the 878 from this site and make sure you're not running a pirated version. Replace your SSL DLLs with the ones posted on this site as well.
I'm running 878 and it's the eval version so I assume that should be fine.
Where on the site are there posted SSL DLL updates?
I guess it might be the server- does anybody have experience with glftpd-tls?
Uxorious is offline  
Old 09-16-2002, 01:19 PM   #4
Linkster
Moderator
Administrator
 
Join Date: Oct 2001
Location: New Mexico, USA
Posts: 1,070
Default

if you downloaded and installed 878 from the website, it has updated dll's...I have experience with glftpd..please paste all the text/garbage you are getting. I've got 3 glftpd-tls servers that are working correctly with flashfxp.
Linkster is offline  
Old 09-16-2002, 02:16 PM   #5
PeNGuiN
Member
FlashFXP Beta Tester
 
Join Date: Apr 2002
Posts: 69
Default

Linkster, I have a lot of experience with glftpd-TLS as well and I've never seen a glftpd server miscommunicate with FFXP so far...
PeNGuiN is offline  
Old 09-16-2002, 06:01 PM   #6
Uxorious
Junior Member
 
Join Date: Sep 2002
Posts: 6
Default

Quote:
Originally posted by Linkster
if you downloaded and installed 878 from the website, it has updated dll's...I have experience with glftpd..please paste all the text/garbage you are getting. I've got 3 glftpd-tls servers that are working correctly with flashfxp.
Yeah I downloaded it from the site.
No problems in non-TLS mode ... frequent problems in TLS mode.
I'm starting to wonder if it's the crap-ass Linksys router doing bad stuff ... they've been known to have MTU issues.
I'm at work now ... but when I get hoem I'll see if I can get something and post it.

What bugs me is that FlashFXP doesn't notify me the download is broken. It gets told by the server that the file is X bytes long, but if it downloads less and the connection is closed shouldn't it tell me?
Uxorious is offline  
Old 09-20-2002, 07:52 PM   #7
mitchjs
Junior Member
 
Join Date: Sep 2002
Posts: 4
Default

I too have tons of problems with file being cut a few k short

if i download 20 files 5 will be corrupt, i just do another tranfer on the same file... sometimes it takes 3 or 4 shots to get the last bit of data

very annoying...


its got to be SSL related

i used to use safetp and never had anyproblems

mitch
mitchjs is offline  
Old 09-20-2002, 09:46 PM   #8
Uxorious
Junior Member
 
Join Date: Sep 2002
Posts: 6
Default

Quote:
Originally posted by mitchjs
I too have tons of problems with file being cut a few k short

if i download 20 files 5 will be corrupt, i just do another tranfer on the same file... sometimes it takes 3 or 4 shots to get the last bit of data

very annoying...


its got to be SSL related

i used to use safetp and never had anyproblems

mitch
Well I'm glad it's not just me.

*rest of comment removed*
Uxorious is offline  
Old 09-20-2002, 10:16 PM   #9
mitchjs
Junior Member
 
Join Date: Sep 2002
Posts: 4
Default

i just tried that smartftp

its aweful!!! the interface, yick...

it may work right... but its soooo damm hard to use

please fix ssl transfers... i want to use flashfxp!!!

the best ftp proggy out there!

mitch
mitchjs is offline  
Old 09-20-2002, 11:04 PM   #10
Uxorious
Junior Member
 
Join Date: Sep 2002
Posts: 6
Default

Quote:
Originally posted by mitchjs
i just tried that smartftp

its aweful!!! the interface, yick...

it may work right... but its soooo damm hard to use

please fix ssl transfers... i want to use flashfxp!!!

the best ftp proggy out there!

mitch
Heh funny how people have different opinions.
I don't actually like the Flash interface - I've always used BulletProof. The smart interface was good though - multithreaded so you can be on multiple sites etc. Worked well for me.
And the transfers are flawless as opposed to Flash.
Uxorious is offline  
Old 09-20-2002, 11:30 PM   #11
mitchjs
Junior Member
 
Join Date: Sep 2002
Posts: 4
Default

mutil thread is nice...

but everytime u start a session with a new site, its a new window

flash's windows are cleaner...

he will figure out the file transfer problem.. i got faith


mitch
mitchjs is offline  
Old 09-20-2002, 11:36 PM   #12
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Sorry guys but TLS seems to work perfectly fine, perhaps you can provide us some sites that are problematic and we can test FlashFXP on them, That's the best we can do. If you want to contact me privately please email me at support@flashfxp.com
bigstar is offline  
Old 09-20-2002, 11:38 PM   #13
Uxorious
Junior Member
 
Join Date: Sep 2002
Posts: 6
Default

Quote:
Originally posted by bigstar
Sorry guys but TLS seems to work perfectly fine, perhaps you can provide us some sites that are problematic and we can test FlashFXP on them, That's the best we can do. If you want to contact me privately please email me at support@flashfxp.com
I'm having the problem with glftpd, and I'm not the only one.
Check the www.glftpd.com forums - lots of people have problems with FlashFXP and glftpd.
Uxorious is offline  
Old 09-20-2002, 11:42 PM   #14
mitchjs
Junior Member
 
Join Date: Sep 2002
Posts: 4
Default

there definitly is a problem


i only use 1 ftp that is ssl, now IT could be the site...
i will consider using another ftp for a day or two...

the server is
LundFTPD 2.12 +SRP+TLS

it also supports safetp... which i just switched to

i used to use it, then flash got ssl, so i switched to that

thats when i noticed all the file shortage problems

ill make some tests and report back

mitch
mitchjs is offline  
 

Tags
connect, flashfxp, refuse, time, tls

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:49 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)