Old 06-09-2005, 12:50 AM   #1
Miky
Member
 
Join Date: Feb 2003
Posts: 31
Question low gigabit speed

* FlashFXP v[3].[2], build [1080], [X]registered, [ ]unregistered, [ ]pirated
* OS [X] WinXP, [ ] Win2K, [ ] Win98, [ ] WinME, [ ] Other
* Running behind NAT/router [ ] Yes & Model [ ], [X] No, [ ] Not sure
* Running firewall [ ] Yes, Name [ ], Ver. [ ], or [X] No
* Running Antivirus [X] Yes, Name [AVG7] or [ ] No
* Network [ ] xDSL, [ ] CABLE, [ ] Dail-Up, [X] Other (LAN Gigabit)

When I'm uploading to the server it's going fine (35MB/s), but when I'm downloading it's disaster. If I'm lucky it downloads max 2 whole files in full speed and than speed drop down to hundreds of kB/s or even stop and after few seconds it jump up again. Average speed of that file is only around 4MB/s. I tried change recieve TCP/IP buffer size to 8KB like send buffer is, but it didn't help (I tried almost every value and nothing).
Transfer speed limit isn't set.
Other ftp clients work fine in full upload and download speed.

THX
Miky is offline  
Old 06-09-2005, 01:22 AM   #2
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Can you please describe your gigabit hardware (network adapters & router/switches)

Also are you using jumbo frames?

Try using the largest recieve TCP/IP buffer size or select "default", sometimes the default windows value work best if you've tweaked your windows tcp/ip settings.
bigstar is offline  
Old 06-09-2005, 02:19 AM   #3
Miky
Member
 
Join Date: Feb 2003
Posts: 31
Default

Server: PCI-e Marvell 88E8053, Linux (AMD64)
Client: PCI-e Marvell 88E8053, WinXP SP2 (32bit)
Switch: Edimax ES-5800R+

no jumbo frames, MTU only 1500

yes I tried 256kB recieve TCP/IP buffer size and 'default' too (no change).
I thing that in TCP/IP buffer is not problem, because other clients have 8kB set and work fine, but FFXP not .
Miky is offline  
Old 06-09-2005, 08:24 AM   #4
Miky
Member
 
Join Date: Feb 2003
Posts: 31
Default

I tried FFXP on another computer and it works fine there (download 40MB/s). So the problem is in my computer. Sorry for bothering .
Miky is offline  
Old 06-09-2005, 08:29 AM   #5
Hetfield
Senior Member
FlashFXP Scripter
 
Join Date: Nov 2002
Posts: 334
Default

Glad to see finally a user who recognise that if it works on another computer it's really useless to ask for help . On topic: these speeds issues are pretty much always due to firewalls, perhaps you missed something there.
Hetfield is offline  
 

Tags
download, flashfxp, ftp, speed, upload

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Won't let me connect Aingeal General Discussion 2 01-01-2005 05:34 PM


All times are GMT -5. The time now is 03:02 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)