Go Back   FlashFXP Forums > > >

Bug Reports Report bugs here.

 
 
Thread Tools Display Modes
Old 03-01-2005, 03:47 PM   #1
Greven
Junior Member
FlashFXP Registered User
 
Join Date: May 2003
Posts: 7
Default Error when "On transfer Complete=Quit (no confirmation)

In the last 5 or so versions, betas and other I get an error message when the program auto-quits after download.
Since my OS is in swedish I'll try to translate the message shortly:

"The Intruction on "0x0262aaad" referred to memory on "0x02972138". Memory operation could not be performed. The following error was returned: The memory could not be "read"
Press OK to end program."

I currently use version 3.1.11 (build 1070) BETA, Windows XP, Unfortunately SP2.

Anyone got an idea?

/Henrik

edit: added OS info
Greven is offline  
Old 03-12-2005, 07:55 AM   #2
chotaire
Member
FlashFXP Scripter
 
Join Date: Sep 2004
Posts: 82
Default

I use that feature regularly and I have never seen it on both US and localized DE versions of Windows XP. Can you try this on a different machine that runs the same localized version of Windows? Maybe that's not a FlashFXP problem but it has to do with your windows installation.
chotaire is offline  
Old 03-12-2005, 10:06 AM   #3
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

From what we can determine this error is caused by an external application or dll. If the error were within FlashFXP then our error handler would allow us to catch it.

Since FlashFXP embeds a local explorer window for browsing your hard drive all 3rd party shell enhancments are also loaded into FlashFXP. It's quite possible that one of them is causing this error on exit.

Due to the nature of this error it is very difficult to pin-point it to a specific external application/dll conflict.
bigstar is offline  
Old 03-12-2005, 11:18 AM   #4
Greven
Junior Member
FlashFXP Registered User
 
Join Date: May 2003
Posts: 7
Default

Mmm, I see now that other programs response in similar ways on this comp. I've read on some other forums that this could be related to the windows vitrual memory settings. I know, since I have 1gb of ram that I disabled disk caching. But now when i checked it once more it was enabled again.

Anyway, I can add that I have the Flashftp installation on a Secure Drive, that i have to unlock when i want to use it... The drive is made by Steganos Security Suite, AES encryption. I'll check if they maybe have som upgrade for me. As I see it know, it's possible that the problem first occured after last upgrade.

I'll get back... maybe

/H
Greven is offline  
Old 03-15-2005, 09:15 AM   #5
Greven
Junior Member
FlashFXP Registered User
 
Join Date: May 2003
Posts: 7
Default bug located

OKay developers, i've located the bug.

When I reseted the security password the bug disappeared.

The password i had contained swedish letters, "ö" (o with two dots) and "ä" (a with two dots) and for some reason this creates this error.

$me throws the ball to developers...

/Henrik
Greven is offline  
Old 03-15-2005, 10:39 AM   #6
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

I'm not entirely sure if this is the exact problem. I replaced my password with a password containing "ö" and "ä" and I was unable to reproduce the problem. The encryption routine fully supports all input characters as a password.

Did you change your security password or disable it?
bigstar is offline  
Old 03-15-2005, 10:48 AM   #7
Greven
Junior Member
FlashFXP Registered User
 
Join Date: May 2003
Posts: 7
Default

I just disabled it. Now believe it or not, the fifth time i tried the error returned even with no password, damn.

Okay, the story goes on hehe...
Greven is offline  
Old 04-04-2005, 07:25 AM   #8
Greven
Junior Member
FlashFXP Registered User
 
Join Date: May 2003
Posts: 7
Lightbulb

Okay, this might be the end of this thread.

I upgraded my Steganos Security Suite and after that made new tries with the error reported. The problems disappeared. No more error messages

This problem was related to that specific version of SSS. Halleluja

/H
Greven is offline  
 

Tags
download, error, memory, message, program

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
3.7.0 Known bugs darkone Bug Reports 6 12-10-2002 07:21 PM


All times are GMT -5. The time now is 08:01 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)