Go Back   FlashFXP Forums > > >

Bug Reports Report bugs here.

 
 
Thread Tools Display Modes
Old 11-22-2004, 01:10 AM   #1
robe
Junior Member
FlashFXP Registered User
 
Join Date: May 2002
Posts: 4
Default fressl.com cert doesn't get accepted

It seems as if FlashFXP does not trust certificates signed by freessl.com/Geotrust, it just states "This certificate is invalid." without any further diagnosis output. I attached the openssl output of a sample certificate. IE/Firefox/Thunderbird apparently trust the signing CA.
Attached Files
File Type: txt cert.txt (2.8 KB, 541 views)
robe is offline  
Old 11-22-2004, 01:17 AM   #2
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Does this cert work with other ftp clients?
bigstar is offline  
Old 11-22-2004, 01:58 AM   #3
robe
Junior Member
FlashFXP Registered User
 
Join Date: May 2002
Posts: 4
Default

Just tested it with smartftp, works fine. (It shows the same windows like IE when examining the certificate, stating that everything is fine).
robe is offline  
Old 11-22-2004, 03:02 AM   #4
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

On validation the OpenSSL function SSL_get_verify_result returns

X509_V_ERR_UNABLE_TO_GET_ISSUER_CERT_LOCALLY

The way I understand this X509 error is that your cert doesn't send the CA root authority as part of the X509 cert chain and since FlashFXP doesn't have the CA root authority locally it's unable to validate the cert. This isn't a strong subject for me, I'm not sure if FlashFXP would be able to validate the cert even if it had the CA root authority cert.

Currently FlashFXP is unable to validate this type of cert.

I tested this behavior with a few different ftp clients and I'm not entirely sure if they actually validate this type of cert or just accept it without warning the user.
bigstar is offline  
 

Tags
certificate, diagnosis, flashfxp, output, trust

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
why do i get this error ? twisted General Discussion 0 05-02-2005 11:25 PM


All times are GMT -5. The time now is 02:42 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)