Go Back   FlashFXP Forums > > >

Bug Reports Report bugs here.

 
 
Thread Tools Display Modes
Old 10-24-2004, 05:53 PM   #1
rcdc
Junior Member
FlashFXP Registered User
 
Join Date: Oct 2004
Posts: 5
Default corrupt excel ftp download

* FlashFXP v3.0 build 1015 registered
* OS Win2K
* Running behind microsoft ICS
* Running firewall Norton personal firewall
* Running Antivirus AVG 6.0
* Network ICS with satellite broadband download (though flash fxp just uses the dialup connection only as far as I can tell)

when I try to download a commission junction MS excel spreadsheet from datafeed.cj.com the download is always corrupt regardless of whether I choose binary ascii or automatic download. To confirm it was flash fxp I installed a trial version of cute ftp which downloaded the same file perfectly every time. However I much prefer flash fxp to any other ftp program I have tried. I would appreciate help as the trial on cute ftp will run out soon and I need this datafeed from commission junction

Many thanks
rcdc is offline  
Old 10-24-2004, 10:23 PM   #2
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,839
Default

can you post status log from that session?
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Old 10-25-2004, 11:45 AM   #3
rcdc
Junior Member
FlashFXP Registered User
 
Join Date: Oct 2004
Posts: 5
Default

I retrieved the file twice in a new session and changed transfer mode from ascii to binary inbetween but i notice in the log that it says ascii mode for both retrieves. log below

WinSock 2.0 -- OpenSSL 0.9.7d 17 Mar 2004
[L] Connecting to CJ datatransfer -> IP=216.34.209.22 PORT=21
[L] Connected to CJ datatransfer
[L] 220 Commission Junction FTP server. All transfers are logged.
[L] USER 1094978
[L] 331 Password
[L] PASS (hidden)
[L] 230- WARNING: This server is for exchange of business data with Commission Junction only.
[L] 230- Any attempt to upload data that has not been approved by Commission Junction
[L] 230- will result in termination of your ftp account. Access restrictions apply.
[L] 230 User 1094978 logged in from 62-241-188-100.dsl.pipex.com
[L] SYST
[L] 215 UNIX
[L] FEAT
[L] 500 FEAT not understood.
[L] REST 100
[L] 350 Requested file action pending further information.
[L] REST 0
[L] 350 Requested file action pending further information.
[L] PWD
[L] 257 "/1094978" is current directory.
[L] TYPE A
[L] 200 type set.
[L] PASV
[L] 227 Entering Passive Mod(216,34,209,22,139,10)
[L] Opening data connection IP: 216.34.209.22 PORT: 35594
[L] LIST -al
[L] 150 Opening ASCII mode data connection.
[L] 226 Transfer complete.
[L] List Complete: 63 bytes in 2.22 seconds (0.0 KB/s)
[L] CWD outgoing
[L] 250 CWD command succesful.
[L] PWD
[L] 257 "/1094978/outgoing" is current directory.
[L] PASV
[L] 227 Entering Passive Mod(216,34,209,22,139,11)
[L] Opening data connection IP: 216.34.209.22 PORT: 35595
[L] LIST -al
[L] 150 Opening ASCII mode data connection.
[L] 226 Transfer complete.
[L] List Complete: 69 bytes in 1.88 seconds (0.0 KB/s)
[L] CWD productcatalog
[L] 250 CWD command succesful.
[L] PWD
[L] 257 "/1094978/outgoing/productcatalog" is current directory.
[L] PASV
[L] 227 Entering Passive Mod(216,34,209,22,139,12)
[L] Opening data connection IP: 216.34.209.22 PORT: 35596
[L] LIST -al
[L] 150 Opening ASCII mode data connection.
[L] 226 Transfer complete.
[L] List Complete: 118 bytes in 1.91 seconds (0.1 KB/s)
[L] CWD 3941
[L] 250 CWD command succesful.
[L] PWD
[L] 257 "/1094978/outgoing/productcatalog/3941" is current directory.
[L] PASV
[L] 227 Entering Passive Mod(216,34,209,22,139,13)
[L] Opening data connection IP: 216.34.209.22 PORT: 35597
[L] LIST -al
[L] 150 Opening ASCII mode data connection.
[L] 226 Transfer complete.
[L] List Complete: 80 bytes in 1.89 seconds (0.0 KB/s)
[L] PASV
[L] 227 Entering Passive Mod(216,34,209,22,139,14)
[L] Opening data connection IP: 216.34.209.22 PORT: 35598
[L] RETR 1094978_3941_20041024.zip
[L] 150 ASCII mode connection for 1094978_3941_20041024.zip (123879 bytes)
[L] 226 transfer complete
Transferred: 1094978_3941_20041024.zip 120 KB in 32.11 seconds (3.8 KB/s)
Transfer queue completed
Transferred 1 file totaling 120 KB in 33.56 seconds (3.8 KB/s)
[L] PASV
[L] 227 Entering Passive Mod(216,34,209,22,139,16)
[L] Opening data connection IP: 216.34.209.22 PORT: 35600
[L] RETR 1094978_3941_20041024.zip
[L] 150 ASCII mode connection for 1094978_3941_20041024.zip (123879 bytes)
[L] 226 transfer complete
Transferred: 1094978_3941_20041024.zip 120 KB in 32.55 seconds (3.7 KB/s)
Transfer queue completed
Transferred 1 file totaling 120 KB in 34.06 seconds (3.7 KB/s)
[L] QUIT
[L] 221 Service closing control connection.
[L] Logged off: CJ datatransfer
rcdc is offline  
Old 10-25-2004, 02:24 PM   #4
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Almost all transfers need to be performed in BINARY mode, normally you leave the transfer mode to automatic and FlashFXP will automatically handle most file types.

You are trying to transfer a zip file in ASCII mode, this simply wont work, you need to transfer the file in BINARY mode.
bigstar is offline  
Old 10-25-2004, 03:27 PM   #5
rcdc
Junior Member
FlashFXP Registered User
 
Join Date: Oct 2004
Posts: 5
Default

I've tried the Options--> Preferences --> Transfer Tab and set to all 3 -- Ascii, Binary and Auto and under all 3 setting it does an Ascii transfer.
How do I get it to download in binary
rcdc is offline  
Old 10-25-2004, 03:40 PM   #6
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Sounds like there's a problem with your FlashFXP installation.

Download the FlashFXP setup from our website at http://www.flashfxp.com

edit...

After thought.. I'm not entirely sure but once you set the transfer mode to 'auto' via the Preferences you may need to restart for that value to take effect. I believe that's just the default value. you need to change FTP > Transfer Mode via the menu to change the current session transfer mode.
bigstar is offline  
Old 10-25-2004, 05:59 PM   #7
rcdc
Junior Member
FlashFXP Registered User
 
Join Date: Oct 2004
Posts: 5
Default

Set to auto, and restart worked fine.

the only thing I didn't understand was how to set the transfer mode for the current session without restarting

many thanks
rcdc is offline  
Old 10-25-2004, 06:08 PM   #8
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Sorry I forgot that FTP was renamed to Session on the menu.
so from the main menu, Session > Transfer Mode
bigstar is offline  
Old 10-26-2004, 08:45 AM   #9
rcdc
Junior Member
FlashFXP Registered User
 
Join Date: Oct 2004
Posts: 5
Talking

Many thanks indeed for first class support
rcdc is offline  
 

Tags
download, flashfxp, ftp, fxp, running

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:20 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)