Go Back   FlashFXP Forums > >

General Discussion Need help? Have a problem? Let us help you. Bug reports and feature requests should be made using the Bug Tracker or Feature Tracker

Closed Thread
 
Thread Tools Rate Thread Display Modes
Old 01-10-2005, 06:52 AM   #1
neilwr
Junior Member
FlashFXP Registered User
 
Join Date: Jan 2005
Posts: 4
Default Slow ftp traffice with Winxp SP2 installed

OK not sure if this has been asked b4 but I can not find any topic on it, so here goes.

Is anybody experiencing slow ftp transfers with Windows XP SP2 and Flash fxp v3.0.2 biuld 1045.

I have tried the following. By the way my connection is a 1.5m/b which can carry 160k so I use that as max data.

I have installed the following and tested.

Windows XP no SP speed 160k
Windows XP SP1 speed 160k
Windows XP SP2 speed drops to max 105k
Windows MCE SP2 speed drops to max 105k.

So my theory is that SP2 is some how hampering the transfers of files or flashfxp is not 100% compatable with SP2 from M$.

My details are below.
Flashfxp v3.0.2 buils 1045 registered
OS Windows XP SP1 so I have fll speed
Running behind NAT/router, Netgear DG 834
Software Firewall no
Antivirus yes, NAV Corp v9 sp2 compat, this was running on all builds above.
Networrk is ADSL

I do not have the logs from the ftp servers but this has been expereienced by many users in my relm.

Any help on this would be greatly welcome.
neilwr is offline  
Old 01-10-2005, 12:40 PM   #2
Linkster
Moderator
Administrator
 
Join Date: Oct 2001
Location: New Mexico, USA
Posts: 1,070
Default

Just out of curiousity, can you please test with PASV mode disabled? You might have to forward a few ports in your router to get it to work.
Linkster is offline  
Old 01-10-2005, 05:30 PM   #3
neilwr
Junior Member
FlashFXP Registered User
 
Join Date: Jan 2005
Posts: 4
Default Slow ftp traffice with Winxp SP2 installed

I have all ports open to my ftp server. Should not need to open ports for the client side.
neilwr is offline  
Old 01-10-2005, 06:07 PM   #4
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

When using active mode (passive mode disabled) an incoming connection is established with the ftp client. If your ports are blocked then you would need to forward them to get active mode to work.
bigstar is offline  
Old 01-11-2005, 03:04 AM   #5
neilwr
Junior Member
FlashFXP Registered User
 
Join Date: Jan 2005
Posts: 4
Default Slow ftp traffice with Winxp SP2 installed

I am not connecting to a ftp server on port 21. I am say connecting to a ftp server on port 2020, which uses passive. Now I have used this server under vanilla XP np SP. XP SP1 and XP SP2. The only slow down I receive is under XP SP2 where speed drops to 105k.

The only ftp ports that I have open are for my ftp server. which runs on a different machine. The main connection port say(2010) plus a passive port range of say 2020 - 2030.

I am sorry but I do not see how opening ports for a ftp client has to do with anything when it works fine under XP and XP SP1 just fails to work correctly under XP SP2.
neilwr is offline  
Old 01-11-2005, 05:29 AM   #6
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,839
Default Re: Slow ftp traffice with Winxp SP2 installed

Quote:
Originally posted by neilwr
I am sorry but I do not see how opening ports for a ftp client has to do with anything when it works fine under XP and XP SP1 just fails to work correctly under XP SP2.
if YOU do not see it, doesn't mean that it's not related.

if you do not want to cooperate and try our suggestions, there is only so much we can do.
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Old 01-14-2005, 04:10 PM   #7
Voxxel
Junior Member
 
Join Date: Jan 2003
Posts: 6
Default Re: Slow ftp traffice with Winxp SP2 installed

Quote:
Originally posted by neilwr
I am sorry but I do not see how opening ports for a ftp client has to do with anything when it works fine under XP and XP SP1 just fails to work correctly under XP SP2.
For starters, SP2 has a firewall enabled by default. Also, it has a limit on the number of raw TCP sockets that can be half-open at once. Try forwarding the ports. Try disabling the firewall. Install the TCP/IP patch from www.lvllord.de . I don't know if these things will help, but it's a good place to start.
Voxxel is offline  
Old 01-14-2005, 05:31 PM   #8
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,839
Default

tcpip.sys patch will not make any difference here.
and we can not recommend or suggest messing around with integral part of windows. do it on your own risk.
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Closed Thread

Tags
flashfxp, ftp, fxp, sp2, windows

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
site msg in ioA peorth WarC's scripts 5 01-22-2003 09:22 PM
Minor bug in 3.3.0 FTPServerTools Bug Reports 2 10-09-2002 06:06 AM


All times are GMT -5. The time now is 06:01 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)