Go Back   FlashFXP Forums > >

General Discussion Need help? Have a problem? Let us help you. Bug reports and feature requests should be made using the Bug Tracker or Feature Tracker

Closed Thread
 
Thread Tools Rate Thread Display Modes
Old 12-10-2004, 11:31 AM   #1
Gioggiolo
Junior Member
 
Join Date: Dec 2004
Posts: 12
Default On localhost Connection, Force Active Mode to use Another IP

Hello all, sorry for my bad english.

I use FlashFXP v3.0.2. I want "Force Active Mode to use this IP (example 111.111.111.111)" when open connection on localhost ip but it don't work. See this image:



While FlashFXP v2.1 work very well:



Is This a v3.0 bug?

Tnx
Gioggiolo
Gioggiolo is offline  
Old 12-10-2004, 12:28 PM   #2
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Is "111.111.111.111" a valid IP address on the local machine? v2.x didn't verify the IP Address but v3.x does.
bigstar is offline  
Old 12-10-2004, 01:29 PM   #3
Gioggiolo
Junior Member
 
Join Date: Dec 2004
Posts: 12
Default

"111.111.111.111" is a valid WAN IP.
Gioggiolo is offline  
Old 12-10-2004, 02:26 PM   #4
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Are you connecting to a LAN based site? You can only use a WAN IP on an internet based site.
bigstar is offline  
Old 12-10-2004, 05:59 PM   #5
Gioggiolo
Junior Member
 
Join Date: Dec 2004
Posts: 12
Default

"111.111.111.111" is an ADSL IP connected to
the internet through a router.
Gioggiolo is offline  
Old 12-11-2004, 06:22 AM   #6
Gioggiolo
Junior Member
 
Join Date: Dec 2004
Posts: 12
Default

So, is impossible to use this configuration in 3.0.2 version. I need this configuration and -savequeue switch
Gioggiolo is offline  
Old 12-11-2004, 11:23 AM   #7
Gioggiolo
Junior Member
 
Join Date: Dec 2004
Posts: 12
Default

Quote:
Originally posted by bigstar
v2.x didn't verify the IP Address but v3.x does.
It is possible to disable this verification with a HexEditor?

If it is not possible, i must search another solution or another client.
Gioggiolo is offline  
Old 12-11-2004, 12:16 PM   #8
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

I'm rather confused as to why you need to use your external IP address for a local host ftp server? Quite frankly it doesn't make any sense. Most configurations don't allow this and the ones that do usually end up sending data to your isp and back reducing the speed to your isp connection.

If that is not the case can you please explain in detail your situation.

P.S. I don't think that is your problem, as you stated "111.111.111.111" is a valid IP address.
bigstar is offline  
Old 12-11-2004, 01:44 PM   #9
Gioggiolo
Junior Member
 
Join Date: Dec 2004
Posts: 12
Default

The situation is complicated to be explained with my bad english. I try to explain it.

The Server FTP is located on internet but it has not external ip.
Using a software, my External IP becomes also the External IP of this Server FTP.

If i want to connect to this Server FTP, i must to use my Local IP, but the "Data connection" must to be on my External IP.

Now, Do you understand the situation?
Gioggiolo is offline  
Old 12-12-2004, 01:14 PM   #10
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

I was hoping for alittle more information then what you provided, Maybe even listing the exact software you're using.

Quote:
Using a software, my External IP becomes also the External IP of this Server FTP.
If this is the case then you should be able to connect to the ftp server using your external IP address.
bigstar is offline  
Old 12-12-2004, 05:23 PM   #11
Gioggiolo
Junior Member
 
Join Date: Dec 2004
Posts: 12
Default

Quote:
Originally posted by bigstar
If this is the case then you should be able to connect to the ftp server using your external IP address.
I have tried it but it doesnt work.
I think that my router blocks this "loop connection".
Gioggiolo is offline  
Closed Thread

Tags
active, flashfxp, force, localhost, work

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
why do i get this error ? twisted General Discussion 0 05-02-2005 11:25 PM
Deleted Profile On Flash rouil General Discussion 0 04-02-2005 09:03 PM
Transfer failed "[R] 501- ==YOU'RE BEHIND A NAT ROUTER==" error ardenj General Discussion 2 01-18-2005 11:40 PM


All times are GMT -5. The time now is 07:45 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)