Go Back   FlashFXP Forums > >

General Discussion Need help? Have a problem? Let us help you. Bug reports and feature requests should be made using the Bug Tracker or Feature Tracker

Reply
 
Thread Tools Rate Thread Display Modes
Old 09-23-2018, 04:07 AM   #1
spudgun
Junior Member
FlashFXP Beta Tester
 
Join Date: Jun 2007
Posts: 26
Default How can we update the SSL libraries as there are no program updates?

I've tried manually copying across the 4 latest ssl .dll files, but that doesn't seem to work as you get exception errors in Flash when connecting to SSL enabled sites and also this message doesn't popup when you start the program - Winsock 2.2 -- OpenSSL 1.1.0e 16 Feb 2017 - as after changing to the new .dll files it just says - Winsock 2.2 - so is there a way to do this without there being a program update which looks pretty unlikely at the moment?

Last edited by spudgun; 09-23-2018 at 04:28 AM.
spudgun is offline   Reply With Quote
Old 09-27-2018, 01:23 AM   #2
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,830
Default

Make sure that those dll files are 32bit, not 64bit.
Beyond that there's probably not much that can be done. :/
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline   Reply With Quote
Old 09-27-2018, 10:59 AM   #3
spudgun
Junior Member
FlashFXP Beta Tester
 
Join Date: Jun 2007
Posts: 26
Default

Quote:
Originally Posted by MxxCon View Post
Make sure that those dll files are 32bit, not 64bit.
Beyond that there's probably not much that can be done. :/
Thanks, I did make sure that I was using the 32bit .dll files - but no joy - so guess this is will become obsolete as soon as requirements are in force on host FTP sites for later SSL versions.

Any ideas on other FXP programs that can be used instead?
spudgun is offline   Reply With Quote
Old 10-06-2018, 06:24 PM   #4
dozegfx
Junior Member
FlashFXP Beta Tester
 
Join Date: Oct 2007
Posts: 17
Default

Win32 versions of the below are confirmed working.

libcrypto-1_1.dll and libssl-1_1.dll 1.1.0i work. (latest working, doesn't work with 1.1.1)

libeay32.dll and ssleay32.dll 1.0.2p work. (latest)

Hope that helps.
dozegfx is offline   Reply With Quote
Old 10-13-2018, 04:31 AM   #5
spudgun
Junior Member
FlashFXP Beta Tester
 
Join Date: Jun 2007
Posts: 26
Default

Quote:
Originally Posted by dozegfx View Post
Win32 versions of the below are confirmed working.

libcrypto-1_1.dll and libssl-1_1.dll 1.1.0i work. (latest working, doesn't work with 1.1.1)

libeay32.dll and ssleay32.dll 1.0.2p work. (latest)

Hope that helps.
Thank you very much, that is most helpful
spudgun is offline   Reply With Quote
Reply

Tags
exception, flash, program, ssl, update

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:39 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)