Go Back   FlashFXP Forums > >

General Discussion Need help? Have a problem? Let us help you. Bug reports and feature requests should be made using the Bug Tracker or Feature Tracker

Closed Thread
 
Thread Tools Rate Thread Display Modes
Old 02-02-2015, 05:50 PM   #1
gwotang
Junior Member
 
Join Date: Mar 2014
Posts: 5
Default Local Browser (File Icon Incorrect)

v5.0 build 3805

File icon will be displayed as a directory icon.
gwotang is offline  
Old 02-03-2015, 08:42 AM   #2
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Hello,

Thank you for your bug report.

What version of Windows are you using?

Can you please include a screenshot so I can clearly understand what's going on.

Does this issue occur as soon as you launch FlashFXP or does it appear after FlashFXP has been running for awhile?

Does this effect all files or just some? if just some is it limited to a specific file extension?

Does this happen in any specific folder location, everywhere, or randomly?
bigstar is offline  
Old 02-05-2015, 02:52 AM   #4
DayCuts
Senior Member
FlashFXP Beta Tester
 
Join Date: Dec 2003
Posts: 421
Default

I occasionally notice incorrect icons on the local browser side as well, though not necessarily the same issue. It is not often but what I have noticed is that it occurs when the current local directory is modified outside of flashfxp. In my case new files added. For example I just grabbed the 3805-r6 zip and my open client happened to be viewing the browser download location. When I switched to flashfxp one of the icons was incorrect (which is what reminded me of this post). I have seen this incorrect icon occur on both files and folders with no observable link to any particular filetype. The incorrect icon displayed in this instance was not related to any of the items in the list. Sometimes it is even a blank page (no association) icon. It also occurs both when flashfxp is the active process and when it is not.

Windows Vista, can occur anywhere but in my case only when the active local folder is modified outside of flashfxp (triggering the internal refresh).

Generic shell icons and Overlay icons options are off.
DayCuts is offline  
Old 02-05-2015, 01:17 PM   #5
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

gwotang

Is F:\ a removable drive or a regular hard drive?

Do you have "Generic shell icons" checked? If not can you please try checking it and see if it makes any difference.

If this change has no effect then do you have "Overlay icons" checked? If you do can you please try unchecking it and test.






I suspect that checking "Generic shell icons" will most likely either solve the problem or make it worse with all files having folder icons.

The file icons are retrieved using a background thread and until the actual icon is retrieved a temporary icon is used in its place, this temporary icon happens to be the generic shell icon.

Please let me know and I will do some more research on this.
bigstar is offline  
Old 02-05-2015, 10:22 PM   #6
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

While testing FlashFXP on Windows 10 Tech Preview virtual machine I found an unexpected way to reproduce this issue. Now I know you said you're using Win 7 but I can't replicate the behavior on my Win 7 development machine.

Using Windows 10 as a test bed I discovered that the background thread can get delayed and provide stale results to the UI thread and as a result the wrong icons are being displayed, There is also a secondary issue where my GetImageIndex function can return an undefined value which can also cause the wrong icon to be displayed.

This dev build should resolve the problem, please give it a try and let me know

<download link removed>

Unzip the flashfxp.exe file into your FlashFXP program folder replacing the existing flashfxp.exe

Last edited by bigstar; 02-06-2015 at 02:38 PM.
bigstar is offline  
Old 02-06-2015, 02:38 PM   #7
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Further testing has revealed that my fix isn't working correctly; it does solve the problem that I found but its doing a double lookup both in the main thread and background thread resulting in slower navigation. I am currently working on a revised fix.
bigstar is offline  
Old 02-06-2015, 04:03 PM   #8
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Updated development build ffxp5.0.0.3805-r8.zip

Unzip the flashfxp.exe file into your FlashFXP program folder replacing the existing flashfxp.exe
bigstar is offline  
Old 02-08-2015, 02:28 PM   #9
DayCuts
Senior Member
FlashFXP Beta Tester
 
Join Date: Dec 2003
Posts: 421
Default

Have not tried r8 yet, but in r7 the change was causing zip and directories to sometimes be listed together (treating zip like a folder). Couldn't force a reproduction but it seems the times i noticed it were when switching one side from remote to local. To correct it one has to navigate to another folder then back again as a normal refresh didn't work. Quite possibly already fixed in r8, time will tell.
DayCuts is offline  
Old 02-09-2015, 08:12 AM   #10
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Quote:
Originally Posted by DayCuts View Post
Have not tried r8 yet, but in r7 the change was causing zip and directories to sometimes be listed together (treating zip like a folder). Couldn't force a reproduction but it seems the times i noticed it were when switching one side from remote to local. To correct it one has to navigate to another folder then back again as a normal refresh didn't work. Quite possibly already fixed in r8, time will tell.
I noticed this as well though it was triggered by using the "compare folder content" followed by a refresh or sometimes by changing the sort direction.

Further testing revealed that when an item is not visible that an internal link check operation is delayed until later (which determines if a folder is really a zip file), however this information was required to sort the list in the correct order. After using the 'compare folder content' feature followed by a refresh (specifically on refresh) an internal flag that keeps track of whether or not the link check had been run was not reset but its related flags were.

I think r8 only partially addressed the problem but I'm not 100% sure, I have included the latest dev build.

ffxp5.1.0.3805-r9.zip

This build also includes an unrelated fix that attempts to resolve a problem with failed FTPS uploads being incorrectly detected as completed and removed from the queue when the control connection is lost during the transfer and then later the TLS data socket is gracefully closed without any errors.
bigstar is offline  
Closed Thread

Tags
build, directory, displayed, file, icon, incorrect, browser, local

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:25 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)