Go Back   FlashFXP Forums > >

General Discussion Need help? Have a problem? Let us help you. Bug reports and feature requests should be made using the Bug Tracker or Feature Tracker

Closed Thread
 
Thread Tools Rate Thread Display Modes
Old 02-28-2014, 12:20 PM   #1
manchifung
Junior Member
 
Join Date: Feb 2014
Posts: 2
Default site to site problem

Quote:
[01:09:01] [L] Logged off: abc (Duration: 9 seconds)
[01:09:01] [L] Connecting to abc -> IP=xx.xxx.xxx.xx PORT=21
[01:09:01] [L] Connected to abc
[01:09:01] [L] 220 (vsFTPd 2.0.5)
[01:09:01] [L] USER www
[01:09:01] [L] 331 Please specify the password.
[01:09:01] [L] PASS (hidden)
[01:09:01] [L] 230 Login successful.
[01:09:01] [L] SYST
[01:09:02] [L] 215 UNIX Type: L8
[01:09:02] [L] FEAT
[01:09:02] [L] 211-Features:
[01:09:02] [L] EPRT
[01:09:02] [L] EPSV
[01:09:02] [L] MDTM
[01:09:02] [L] PASV
[01:09:02] [L] REST STREAM
[01:09:02] [L] SIZE
[01:09:02] [L] TVFS
[01:09:02] [L] 211 End
[01:09:02] [L] PWD
[01:09:02] [L] 257 "/"
[01:09:02] [L] CWD /hynew
[01:09:02] [L] 250 Directory successfully changed.
[01:09:02] [L] PWD
[01:09:02] [L] 257 "/hynew"
[01:09:03] [R] Connecting to efg -> IP=xx.xxx.xxx.xx PORT=21
[01:09:03] [R] Connected to efg
[01:09:03] [R] 220 (vsFTPd 2.2.2)
[01:09:03] [R] USER www
[01:09:03] [R] 331 Please specify the password.
[01:09:03] [R] PASS (hidden)
[01:09:08] [R] 230 Login successful.
[01:09:08] [R] SYST
[01:09:08] [R] 215 UNIX Type: L8
[01:09:08] [R] FEAT
[01:09:08] [R] 211-Features:
[01:09:08] [R] EPRT
[01:09:08] [R] EPSV
[01:09:08] [R] MDTM
[01:09:08] [R] PASV
[01:09:08] [R] REST STREAM
[01:09:08] [R] SIZE
[01:09:08] [R] TVFS
[01:09:08] [R] UTF8
[01:09:08] [R] 211 End
[01:09:08] [R] PWD
[01:09:08] [R] 257 "/"
[01:09:08] [R] CWD /hynew
[01:09:08] [R] 250 Directory successfully changed.
[01:09:08] [R] PWD
[01:09:08] [R] 257 "/hynew"
[01:09:08] [R] TYPE A
[01:09:08] [R] 200 Switching to ASCII mode.
[01:09:08] [R] PASV
[01:09:08] [R] 227 Entering Passive Mode (xx,xxx,xxx,xx,234,102).
[01:09:08] [R] Opening data connection IP: xx.xxx.xxx.xx PORT: 60006
[01:09:08] [R] LIST -al
[01:09:08] [R] 150 Here comes the directory listing.
[01:09:08] [R] 226 Directory send OK.
[01:09:08] [R] List Complete: 115 bytes in 0.10 second (0.1 KB/s)
[01:09:13] [L] TYPE I
[01:09:13] [L] 200 Switching to Binary mode.
[01:09:13] [L] SIZE 1.jpg
[01:09:13] [L] 213 46025
[01:09:13] [L] MDTM 1.jpg
[01:09:13] [L] 213 20140213095455
[01:09:13] [R] TYPE I
[01:09:13] [R] 200 Switching to Binary mode.
[01:09:13] [R] SIZE 1.jpg
[01:09:13] [R] 550 Could not get file size.
[01:09:13] [L] PASV
[01:09:13] [L] 227 Entering Passive Mode (xx,xxx,xxx,xx,234,96)
[01:09:13] [R] PORT xx,xxx,xxx,xx,234,96
[01:09:13] [R] 200 PORT command successful. Consider using PASV.
[01:09:13] [R] STOR 1.jpg
[01:09:13] [R] 500 OOPS: vsf_sysutil_bind
[01:09:13] Site to Site Transfer Failed! (Attempting alternative method)
[01:09:13] [R] PASV
[01:09:13] [R] 500 OOPS: 500 OOPS: child died
[01:09:13] Site to Site Transfer Failed!
[01:09:13] [R] Transfer Failed: /hynew/1.jpg
[01:09:13] [L] TYPE A
[01:09:13] [R] Connection lost: efg (Duration: 10 seconds)
[01:09:13] [L] 200 Switching to ASCII mode.
[01:09:13] [L] PASV
[01:09:13] [L] 227 Entering Passive Mode (xx,xxx,xxx,xx,234,105)
[01:09:13] [L] Opening data connection IP: xx.xxx.xxx.xx PORT: 60009
[01:09:13] [L] LIST -al
[01:09:13] [L] 150 Here comes the directory listing.
[01:09:13] [L] 226 Directory send OK.
[01:09:13] [L] List Complete: 8 KB in 0.34 second (8.4 KB/s)
[01:09:13] Transfer queue completed
[01:09:13] Transferred 0 Files (0 bytes) in 0.53 second (0.0 KB/s)
[01:09:13] 1 File Failed

Local to ServerA is OK.
Local to ServerB is OK too.
But one I try to transfer ServerA to ServerB, it's failed.

2 servers are Linux Centos, vsftpd, and I am the Admin.
please let me know how to change vsftpd.conf file to make SiteToSite.
Thanks.
manchifung is offline  
Old 02-28-2014, 01:51 PM   #2
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

You need to add the following to your vsftpd.conf

pasv_promiscuous=YES
port_promiscuous=YES

https://security.appspot.com/vsftpd/vsftpd_conf.html
bigstar is offline  
Old 03-01-2014, 05:51 AM   #3
manchifung
Junior Member
 
Join Date: Feb 2014
Posts: 2
Default

Quote:
Originally Posted by bigstar View Post
You need to add the following to your vsftpd.conf

pasv_promiscuous=YES
port_promiscuous=YES

https://security.appspot.com/vsftpd/vsftpd_conf.html

Yes, I've added to vsftpd.conf, but it doesn't work.
manchifung is offline  
Old 03-01-2014, 12:52 PM   #4
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Quote:
Originally Posted by manchifung View Post
Yes, I've added to vsftpd.conf, but it doesn't work.

You restarted the vsftpd daemon after editing the config correct?


Assuming you did, there are two possible explanations.

1. There is an issue with the old versions of vsftpd you are using that is preventing this from working correctly, updating to a newer version might make it work.

Possible Solution: Upgrade vsftpd to the most current version.

2. At some point somewhere between your PC and the remote FTP server there is NAT (Network address translations) deployed with a FTP helper. The FTP helper doesn't know/care about site to site transfers so it blindly modifies the PORT command sent by FlashFXP, as a result the FTP server sees something different preventing the site to site transfer from working.

Possible Solution: Setup a secondary FTP server on a non-standard port such as 21000, typically a NAT FTP helper will only monitor for FTP type traffic on the standard FTP port (21). Or use SSL to secure the FTP connection, this will prevent a NAT FTP helper from messing things up.
bigstar is offline  
Closed Thread

Tags
[010902], [010908], [010913], [l], [r]

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 05:36 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)