Go Back   FlashFXP Forums > >

General Discussion Need help? Have a problem? Let us help you. Bug reports and feature requests should be made using the Bug Tracker or Feature Tracker

Closed Thread
 
Thread Tools Rate Thread Display Modes
Old 02-26-2013, 03:39 PM   #1
DamYan
Junior Member
FlashFXP Registered User
 
DamYan's Avatar
 
Join Date: Feb 2013
Posts: 3
Unhappy After set Application Password Protection cannot save password for ftp sites

I'm using latest FlashFXP 4.3.0 (build 1937) and have huge problem. When I set application password protection, cannot save password for a single FTP site. After cleaning application password and add new site - password is stored correctly.

Please, help me, because I want to use application password and stored passwords for sites both.
DamYan is offline  
Old 02-26-2013, 09:24 PM   #2
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Hello,

I'm not quite sure why you would be unable to save a site profile password with application password protection enabled. I tested this several times by turning application password protection on and off and was unable to find any problems with using application password protection.

When you enable application password protection the data files are encrypted on write and decrypted on read. The internal data structures remain the same.

Are you storing the sites in your site manager or via quick connect?

I will continue to investigate this issue and see if I can find anything that might explain it.

What version of Windows are you using?

Are you using a standard or portable installation of FlashFXP?

Please verify to ensure that none of your data files are marked as read-only, you can find the data folder location from Help > About > Details tab.
bigstar is offline  
Old 02-26-2013, 10:16 PM   #3
DamYan
Junior Member
FlashFXP Registered User
 
DamYan's Avatar
 
Join Date: Feb 2013
Posts: 3
Default

I'm using Windows 7 x64 Service Pack 1 and Windows 8 x64.

All folders have read/write access. I can't save password in another way, not just save to base. When I'm adding new ftp sites and saving password after application pass set - coudn't connect to saved sites (incorrect password...). So I think that's maybe is a little problem with crypting files with passwords?
Everything is OK, when clear application pass, and add new site with pass. In that way - sites with saved password works great.
DamYan is offline  
Old 02-27-2013, 09:21 AM   #4
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Can you please try the following.

1. Download the FlashFXP portable edition and install it into a new folder. Download Link

2. Run the portable edition, set an application password, use password

3. Add your site and see if it works.

Does it work?

4. If it doesn't then delete the site from the site manager. (please make sure you remove it)

5. Add the following site to the site manager ftp://test:flashfxp@176.58.118.76 and try to connect.

Does it work?

6. If it doesn't work then from within FlashFXP on the main menu select Tools > Backup / Restore Configuration > Backup and create a backup file.

7. Send the backup file to support at flashfxp.com and I will analyze the file.
bigstar is offline  
Old 03-12-2013, 04:37 AM   #5
DamYan
Junior Member
FlashFXP Registered User
 
DamYan's Avatar
 
Join Date: Feb 2013
Posts: 3
Default

That was a problem with my ftp site only, however many thanks for your interest!

Last edited by DamYan; 03-12-2013 at 04:44 AM.
DamYan is offline  
Old 03-12-2013, 03:02 PM   #6
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

You might want to make sure that the "Login Type" for your site is correctly set to "normal", also I would recommend upgrading to the latest build which is currently 1944.
bigstar is offline  
Closed Thread

Tags
application, flashfxp, ftp, password, stored

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:40 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)