Go Back   FlashFXP Forums > >

General Discussion Need help? Have a problem? Let us help you. Bug reports and feature requests should be made using the Bug Tracker or Feature Tracker

Closed Thread
 
Thread Tools Rate Thread Display Modes
Old 11-29-2012, 11:15 AM   #1
fifiyu
Junior Member
 
Join Date: Nov 2012
Posts: 5
Arrow Help: schedule tasks not run on Win Server 2008 R2

I used to schedule recurring job on Win server 2003. But now I did the same scheduling on Win server 2008 R2, the job did not run.

I can see the last run time changed, but there is no log, no file transferred. I tried switching off the run while log on option, still no luck.

I tried on Win 7, it also works.....

Would you please advise what should I do to make the job run as I wanted?

Thank you very much!
fifiyu is offline  
Old 11-30-2012, 04:50 PM   #2
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

What version/build of FlashFXP are you using?

If you're not already using 4.2.6 build 1897 I would recommend downloading it from here.

I did some tests under Windows 2008 R2 and I am not seeing any reason why a scheduled task would fail to run without displaying an error.

In addition to the logs in FlashFXP you'll want to check Windows Task Scheduler event logs as well. This can help troubleshoot errors where FlashFXP fails to launch.
bigstar is offline  
Old 11-30-2012, 08:39 PM   #3
fifiyu
Junior Member
 
Join Date: Nov 2012
Posts: 5
Default

I used the latest version in download. I have already fixed the issue.
Somehow FlashFXP didnot set up the job correctly in task scheduler.
Now I have to manually create a tasks with highest privilege, config the "start in" path. And it works fine since yesterday.

Although the job can't be find in FlashFXP anymore, at least it's working and I can control it.
fifiyu is offline  
Old 12-01-2012, 10:53 AM   #4
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Did you create the task directly through windows task manager?

If you did then most likely you're bypassing the task scheduling feature within FlashFXP. In order to run a task with all of the features and functionality of FlashFXP the task must be created within FlashFXP, certain advanced task properties can be changed via windows task manager but such as creating multiple task triggers.

A quick search on the microsoft website indicates the following
http://technet.microsoft.com/en-us/l.../cc722152.aspx

Quote:
Applies To: Windows 7, Windows Server 2008 R2, Windows Server 2012, Windows Vista

If a task is registered using the Administrators group for the security context of the task, then you must also make sure the Run with highest privileges check box is checked if you want to run the task.
I will make sure that FlashFXP is setting this flag when creating the task if the above condition is true, I am not 100% sure if it does off hand. I am starting to think it doesn't and I will correct this if that is the case.
bigstar is offline  
Old 12-01-2012, 11:11 AM   #5
fifiyu
Junior Member
 
Join Date: Nov 2012
Posts: 5
Default

And also if you set the Start in path for the task, it can solve some issues as well.
fifiyu is offline  
Old 12-01-2012, 05:01 PM   #6
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Setting the working directory for the task should not be needed, What specific issues did you notice without this being set?

After further research and investigating I am not entirely sure if FlashFXP should run the scheduled task with the "Run with highest privileges" option set, as this changes the context in which FlashFXP runs.The only instance where I can see this might be needed is when FlashFXP needs to transfer files to/from a local folder that require elevated administrative permissions and even then this could cause additional problems...

Such as.. If FlashFXP is installed with per-user settings then the elevated process would have a separate set of settings vs a copy of FlashFXP run without being elevated.

When you put FlashFXP on the Windows 2008 R2 server did you install FlashFXP? (or did you just copy over the FlashFXP program folder)

From within FlashFXP can you please paste the information from main menu > Help About > Details tab
bigstar is offline  
Old 12-01-2012, 11:23 PM   #7
fifiyu
Junior Member
 
Join Date: Nov 2012
Posts: 5
Default

Operating System: Windows XP x64 Service Pack 3

FlashFXP version: 4.2.5 (build 1813)

Installation type: All User - Common data folder

Program folder [Access: Read / Write]
C:\Program Files (x86)\FlashFXP 4\

Data folder [Access: Read / Write]
C:\ProgramData\FlashFXP\4\

Temp folder [Access: Read / Write]
C:\Users\ADMINI~1.UMS\AppData\Local\Temp\1\
fifiyu is offline  
Old 12-03-2012, 09:58 AM   #8
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Quote:
Originally Posted by fifiyu View Post
Operating System: Windows XP x64 Service Pack 3
Your copy of FlashFXP is running in Windows XP SP3 compatibility mode,
This is part of the reason why the scheduler isn't working correctly within FlashFXP, and probably why FlashFXP is requiring run with highest privilege set in the scheduler.

Windows Vista, 7, 2008 use ITaskScheduler v2 which uses a newer interface and provides more configuration options than ITaskScheduler v1 which is used on XP.

Running FlashFXP in a forced compatibility mode can lead to unpredictable results, Windows compatibility mode settings are intended for legacy programs that are no longer supported and do not support the current OS but were designed for an older version of Windows.

We are unable to provide any support for FlashFXP running in compatibility mode because the added compatibility layer can be unpredictable and can create more problems then it solves.
bigstar is offline  
Old 12-03-2012, 10:28 AM   #9
fifiyu
Junior Member
 
Join Date: Nov 2012
Posts: 5
Default

I wasn't running compatible mode....but it was not working as well. I just switch to compatible mode to try all the options.

Quote:
Originally Posted by bigstar View Post
Your copy of FlashFXP is running in Windows XP SP3 compatibility mode,
This is part of the reason why the scheduler isn't working correctly within FlashFXP, and probably why FlashFXP is requiring run with highest privilege set in the scheduler.

Windows Vista, 7, 2008 use ITaskScheduler v2 which uses a newer interface and provides more configuration options than ITaskScheduler v1 which is used on XP.

Running FlashFXP in a forced compatibility mode can lead to unpredictable results, Windows compatibility mode settings are intended for legacy programs that are no longer supported and do not support the current OS but were designed for an older version of Windows.

We are unable to provide any support for FlashFXP running in compatibility mode because the added compatibility layer can be unpredictable and can create more problems then it solves.
fifiyu is offline  
Old 12-03-2012, 12:52 PM   #10
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Quote:
Originally Posted by fifiyu View Post
I wasn't running compatible mode....but it was not working as well. I just switch to compatible mode to try all the options.
Oh, I was under the impression that the information you provided was from your last configuration that was working for you (but was not showing the task within FlashFXP)
bigstar is offline  
Closed Thread

Tags
job, log, run, server, win

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:40 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)