Go Back   FlashFXP Forums > >

General Discussion Need help? Have a problem? Let us help you. Bug reports and feature requests should be made using the Bug Tracker or Feature Tracker

Closed Thread
 
Thread Tools Rate Thread Display Modes
Old 12-08-2011, 02:52 AM   #1
klyupen
Junior Member
 
Join Date: Dec 2011
Posts: 2
Default Server File Search along with custom commands changed or a bug

Hi!

I noticed something when I was upgrading from build 1651->1673, when using "Server File Search" and want to execute a raw command on the selected items that was found during the search,it no longer use the absolute path to the file/folder, so custom commands that have worked for years can't be used anymore.

Should it be like this or is it a bug that have appeared along the road?

In both examples im standing in root "/" when executing the custom command and search.

FlashFXP V4 build 1651
[08:33:08] [L] site wipe -r /folder/folder/folder/filename.txt
[08:33:08] [L] 200 /folder/folder/folder/filename.txt successfully removed.

FlashFXP V4 build 1673
[08:42:29] [L] site wipe -r filename.txt
[08:42:29] [L] 200 Can't wipe: filename.txt does not exist or it's not a plain file/directory
klyupen is offline  
Old 12-08-2011, 09:25 AM   #2
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

The original behavior was a bug (see BUG #582), and the correct way to do this would be something like this "site wipe -r %p%f"
bigstar is offline  
Closed Thread

Tags
custom, custom command, flashfxp, search, server file search, [l]

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:19 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)