Go Back   FlashFXP Forums > >

General Discussion Need help? Have a problem? Let us help you. Bug reports and feature requests should be made using the Bug Tracker or Feature Tracker

Closed Thread
 
Thread Tools Rate Thread Display Modes
Old 12-21-2010, 05:29 PM   #1
Soundgarden
Junior Member
FlashFXP Registered User
 
Join Date: Dec 2010
Posts: 8
Default Cannot connect to ssl ftp sites with win 7

Hola!

First I am using:

FlashFXP version:
4.0.0 (build 1513) registered

Windows:
Windows 7 x64 (6.1.7600)

Connecting via DSL over a Hardware Router
Using G Data Security Suite with Firewall and Antivir


I have no problem to connect to sites via anonymous login, port 21, works fine
But when I want to connect to a site with Auth SSL it just shows
[R] Connecting to site -> IP=xxx.xxx.xxx.xxx PORT=xxx
[R] Connected to site
[R] Connection failed (Connection lost)

I turned off the Firewall and the Antivir to check if it works...same result.
I run FlashFxp as a Admin.

Then I tested it on my old computer with WinXp SP3, same preferences -> and it works.
So the problem seems to be with Win 7 x64 only; maybe Win 7 x64 IS the problem

Any suggestions maybe?

Thanx!
Soundgarden is offline  
Old 12-21-2010, 10:33 PM   #2
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,830
Default

are you using the same ip address and port on both computers?
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Old 12-22-2010, 02:08 AM   #3
Soundgarden
Junior Member
FlashFXP Registered User
 
Join Date: Dec 2010
Posts: 8
Default

Yes, same ip address and port on both computers.

I am using the same options and preferences in FlashFxp on both computers.

As I can connect in normal ftp mode to sites in Win 7 x64, it maybe is related to the ssl-setup?

I tried really everything, disabled/deactivated Windows Defender, Windows Firewall, GData Firewall, GData Antivir...reinstalled FlashFxp; but ssl-connections are not working.

Update 12.27 - uninstalled the whole GData Security Suite; did not help.

So maybe it is because I am using a OEM version of Windows 7 Home Premium? Do I need Prof or Ultimate version (for whatever reason...); or is it the x64 architecture? or just that one little option that is not set right...

Last edited by Soundgarden; 12-28-2010 at 04:14 AM. Reason: Added some
Soundgarden is offline  
Old 12-31-2010, 08:08 AM   #4
Soundgarden
Junior Member
FlashFXP Registered User
 
Join Date: Dec 2010
Posts: 8
Default

Well is anyone running FlashFxp with a Windows 7 x 64 version and can connect to ssl sites? Just to know that it CAN work
Soundgarden is offline  
Old 12-31-2010, 09:19 AM   #5
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Yes it does work
bigstar is offline  
Old 12-31-2010, 09:24 AM   #6
Soundgarden
Junior Member
FlashFXP Registered User
 
Join Date: Dec 2010
Posts: 8
Default

Ok thanx

Then I must go and find the error within my system.
Soundgarden is offline  
Old 12-31-2010, 11:14 AM   #7
Soundgarden
Junior Member
FlashFXP Registered User
 
Join Date: Dec 2010
Posts: 8
Default

Actually I guess it is a problem with the 'ident'...

Well well Happy New Year all!
Soundgarden is offline  
Old 01-12-2011, 03:42 PM   #8
Soundgarden
Junior Member
FlashFXP Registered User
 
Join Date: Dec 2010
Posts: 8
Default

Well well problem solved (to a big part).
In the NAT-options in my Router the local IP of my WinXP-Computer was fixed as the NAT-Server (enabled).
When I changed this local IP to the one of my Win7-Computer it worked fine.

I wonder if I can use both Computers with SSL-/Port 113 Connections if I disable the NAT-Server and open Port 113 in the Router (NAT-Options)?
Soundgarden is offline  
Old 01-13-2011, 12:41 AM   #9
Linkster
Moderator
Administrator
 
Join Date: Oct 2001
Location: New Mexico, USA
Posts: 1,070
Default

if your router has a port triggering option, this can be helpful for multiple computers. I'd look into that.
Linkster is offline  
Old 01-13-2011, 03:40 AM   #10
Soundgarden
Junior Member
FlashFXP Registered User
 
Join Date: Dec 2010
Posts: 8
Default

i guess it has no port triggering option available but i will check back with the manufacturer of the router.

thanx for the hint!
Soundgarden is offline  
Old 01-14-2011, 04:40 AM   #11
Soundgarden
Junior Member
FlashFXP Registered User
 
Join Date: Dec 2010
Posts: 8
Default

Finally, i could set a port rule for port 113 for both local ip's (winxp computer, win7 computer) and disable the NAT-Server in the router. Now it works for both computers.
I just wonder if this is a secure solution

Thank you for all the help.

Cheers
Soundgarden is offline  
Closed Thread

Tags
flashfxp, ftp, site, x64, [r]

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:53 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)