Go Back   FlashFXP Forums > >

General Discussion Need help? Have a problem? Let us help you. Bug reports and feature requests should be made using the Bug Tracker or Feature Tracker

Closed Thread
 
Thread Tools Rate Thread Display Modes
Old 10-23-2010, 07:21 AM   #1
CatenaLogic
Junior Member
FlashFXP Registered User
 
Join Date: Sep 2010
Posts: 4
Default Issues when using FlashFXP in virtual machine

Hello,

I am using FlashFXP for quite a while now, and I am very happy with it. However, recently, I had to create a new development virtual machine, and since then my binary transfers no longer work.

The first "issue" was that I had to enable the "STAT -L" command to allow listing. When I am not in the virtual machine, I don't have to do this.

The second issue is the most important one: I can't get any transfers to work. Here is part of the log:

Code:
[R] SIZE 0036_issue.JPG
[R] 213 161485
[R] MDTM 0036_issue.JPG
[R] 213 20100901204408
[R] PORT 192,168,91,128,194,234
[R] 200 PORT command successful.
[R] RETR 0036_issue.JPG
[R] 150 Opening BINARY mode data connection for 0036_issue.JPG(161485 bytes).
[R] 425 Can't open data connection.
[R] Transfer Failed!
For now, I can transfer the files outside of my VM, but it would be great if you could help me solve this problem.

Thanks in advance!
CatenaLogic is offline  
Old 10-23-2010, 08:03 AM   #2
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Under a VM in most cases the data connection needs to be set to passive mode.
bigstar is offline  
Old 10-23-2010, 09:11 AM   #3
CatenaLogic
Junior Member
FlashFXP Registered User
 
Join Date: Sep 2010
Posts: 4
Default

thank you for your fast reply. The problem is that the site doesn't support passive mode
CatenaLogic is offline  
Old 10-23-2010, 12:12 PM   #4
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Port mode requires an incoming connection, this might be very difficult to configure on a virtual machine, if the site is being accessed over the internet you'll need to configure your router/firewall and maybe the host machine depending on how you have networking configured. If the VM network supports NAT you might be able to get it working with very little changes.
bigstar is offline  
Old 10-23-2010, 03:50 PM   #5
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,838
Default

since your server requires PORT mode, you'll need to consult documentation of your virtualization software either how to configure port forwarding if your VM networking is configured as NAT, or figure out how to change it from NAT to bridge mode.
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Old 11-03-2010, 09:40 AM   #6
CatenaLogic
Junior Member
FlashFXP Registered User
 
Join Date: Sep 2010
Posts: 4
Default

Thank you very much for your replies. I will see if I can configure VMWare correctly.
CatenaLogic is offline  
Old 11-03-2010, 09:46 AM   #7
CatenaLogic
Junior Member
FlashFXP Registered User
 
Join Date: Sep 2010
Posts: 4
Default

Just to let you know:

It seemed that the network settings for the development machine were set to NAT instead of Bridged. Changing it to bridged seems to solve my problems!
CatenaLogic is offline  
Closed Thread

Tags
0036_issue.jpg, flashfxp, machine, virtual, [r]

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 01:50 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)