Go Back   FlashFXP Forums > >

General Discussion Need help? Have a problem? Let us help you. Bug reports and feature requests should be made using the Bug Tracker or Feature Tracker

Closed Thread
 
Thread Tools Rate Thread Display Modes
Old 04-03-2010, 01:04 PM   #1
MarksCarts
Junior Member
FlashFXP Registered User
 
Join Date: Jun 2007
Location: Dallas, TX
Posts: 18
Default Port mode successful - what does this site profile need?

I have a client whose servers do not like the passive mode connections. I've tried updating profiles for some of his sites in the past, but I just can't get it right. Can someone help me witht e settings I need to make?

I'm using a licensed version of FXP v. 3.6.0(Build 1240)

Following is an error log:

[R] 227 Entering Passive Mode (122,201,85,249,5,90)
[R] Opening data connection IP: 122.201.85.249 PORT: 1370
[R] Data Socket Error: Connection timed out
[R] List Error
[R] PASV
[R] 227 Entering Passive Mode (122,201,85,249,182,255)
[R] Opening data connection IP: 122.201.85.249 PORT: 46847
[R] MLSD
[R] 150 Accepted data connection
[R] 226-Options: -a -l
[R] 226 18 matches total
[R] List Complete: 1 KB in 1.44 second (1.4 KB/s)
[R] CWD /public_html
[R] 250 OK. Current directory is /public_html
[R] PWD
[R] 257 "/public_html" is your current location
[R] PASV
[R] 227 Entering Passive Mode (122,201,85,249,11,187)
[R] Opening data connection IP: 122.201.85.249 PORT: 3003
[R] Data Socket Error: Connection timed out
[R] List Error
[R] PASV
[R] 227 Entering Passive Mode (122,201,85,249,18,120)
[R] Opening data connection IP: 122.201.85.249 PORT: 4728
[R] Data Socket Error: Connection timed out
[R] List Error
[R] PASV mode failed, trying PORT mode.
[R] Listening on PORT: 54609, Waiting for connection.
[R] PORT 10,71,0,111,213,81
[R] 200 PORT command successful
[R] MLSD
[R] 150 Connecting to port 54609
[R] 226-Options: -a -l
[R] 226 32 matches total
[R] List Complete: 3 KB in 0.83 seconds (4.3 KB/s)
[R] PORT mode was successful, Please update your site profile.
[R] NOOP
[R] 200 Zzz...
[R] NOOP
[R] 200 Zzz...
[R] NOOP
[R] 200 Zzz...
MarksCarts is offline  
Old 04-03-2010, 01:28 PM   #2
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

In order to use PORT mode you'll need to configure your router to accept incoming connections and forward the ports to your computer. You'll need to then set the same port range in FlashFXP. In addition you'll need to tell FlashFXP your external IP address, either by using a dynamic dns address or by using http://iplookup.flashfxp.com, all of these settings in FlashFXP are set in the Preferences dialog.
bigstar is offline  
Old 04-03-2010, 01:44 PM   #3
MarksCarts
Junior Member
FlashFXP Registered User
 
Join Date: Jun 2007
Location: Dallas, TX
Posts: 18
Default

Thanks bigstar, I can see that I will have problems with this. I am currently using an hotel internet connection and have no access to the routers here. Alternatively, I assume my client or his webhost could change some settings to allow passive connection? If you have any advice on this I will pass along to my client. Installing my software for his clients is always a time-consuming pain due to this problem.
MarksCarts is offline  
Old 04-03-2010, 03:56 PM   #4
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,841
Default

check out http://slacksite.com/other/ftp.html for better understanding of how active and passive modes work.
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Closed Thread

Tags
connection, fxp, mode, port, [r]

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:46 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)