Go Back   FlashFXP Forums > >

General Discussion Need help? Have a problem? Let us help you. Bug reports and feature requests should be made using the Bug Tracker or Feature Tracker

Closed Thread
 
Thread Tools Rate Thread Display Modes
Old 03-18-2010, 07:44 AM   #1
msamitz
Junior Member
 
Join Date: Mar 2010
Posts: 3
Default Site to Site Transfer Not Completing...

I am behind a Sonicwall FW (TZ200N). I have allowed (unchecked) for ftp bounce attack protection as originally this was showing up in the logs. After clear it, there were no further indications in the log file of any alerts or dropped packets. I was working with Sonicwall TS and the packet-capture log shows all requests as being accepted and acknowledged. Nothing is being dropped or rejected. I worked with SW TS for over an hour trying to resolve the issue. All other attempts for find an issue with the SW as the cause were unsuccessful and their conclusion is that the problem is not a SW issue. I can't 100% disagree as even with all security services shut down, the transfer never completed.

I can without issue, upload and download to/from either ftp server. PC <--> FTP works...

From what I see, the process starts and moves along as the file is created on the destination server, but the process STOPS cold on the [R]STOR filename.ext. Below is the log for each try.

For this example, I am trying to move one flat file (license.txt) from site to site.
source: ftp.adamvernermemorial.org == 72.167.232.143
destin: ftp.imasupport.com == 72.167.232.201
LanIP: 192,168,5,101,4,184

[L] PASV
[L] 227 Entering Passive Mode (72,167,232,143,198,66)
[R] PORT 72,167,232,143,198,66
[R] 200 PORT command successful
[R] STOR license.txt

>>>>>>> system sits idle for a few minutes then repeats

[R] Connection lost: ftp.imasupport.com
[R] Transfer Failed!
[R] Attempting to Reconnect.
[R] Connecting to ftp.imasupport.com -> DNS=ftp.imasupport.com IP=72.167.232.201 PORT=21 (attempt # 1)
[R] Connected to ftp.imasupport.com
[R] 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
[R] 220-You are user number 8 of 75 allowed.
[R] 220-Local time is now 05:39. Server port: 21.
[R] 220-This is a private system - No anonymous login
[R] 220 You will be disconnected after 3 minutes of inactivity.
[R] USER msamitz
[R] 331 User msamitz OK. Password required
[R] PASS (hidden)
[R] 230-User msamitz has group access to: 450
[R] 230 OK. Current directory is /
[R] SYST
[R] 215 UNIX Type: L8
[R] FEAT
[R] 211-Extensions supported:
[R] EPRT
[R] IDLE
[R] MDTM
[R] SIZE
[R] REST STREAM
[R] MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNI X.gid*;unique*;
[R] MLSD
[R] ESTP
[R] PASV
[R] EPSV
[R] SPSV
[R] ESTA
[R] AUTH TLS
[R] PBSZ
[R] PROT
[R] 211 End.
[R] CWD /
[R] 250 OK. Current directory is /
[R] PWD
[R] 257 "/" is your current location
[R] TYPE A
[R] 200 TYPE is now ASCII
[R] Listening on PORT: 1208, Waiting for connection.
[R] PORT 192,168,5,101,4,184
[R] 200 PORT command successful
[R] MLSD
[R] 150 Connecting to port 1208
[R] 226-Options: -a -l
[R] 226 62 matches total
[R] List Complete: 6 KB in 0.36 seconds (18.9 KB/s)
[L] PASV
[L] 227 Entering Passive Mode (72,167,232,143,198,66)
[R] PORT 72,167,232,143,198,66
[R] 200 PORT command successful
[R] STOR license.txt

>>>>>>> system sits idle for a few minutes then repeats

[R] Connection lost: ftp.imasupport.com
[R] Transfer Failed!
[R] Attempting to Reconnect.
[R] Connecting to ftp.imasupport.com -> DNS=ftp.imasupport.com IP=72.167.232.201

This sequence keeps repeating. I have tried non-passive mode with no avail.

On the destination side, the file (license.txt) is created (size 0) and a .pureftp-upload.xxxxx file is also created.

Any help would be greatly appreciated.

Last edited by msamitz; 03-18-2010 at 08:04 AM.
msamitz is offline  
Old 03-18-2010, 07:55 AM   #2
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,840
Default

what about transfer in the other direction? does that work?
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Old 03-18-2010, 08:16 AM   #3
msamitz
Junior Member
 
Join Date: Mar 2010
Posts: 3
Default

Seems to do the same. Here is the log following after clearing the que and trying to move php.ini from destination to source

[L] ABOR
[L] 500 ?
[R] ABOR
[L] RETR license.txt
[L] Transfer Failed!
[L] Connection lost: ftp.adamvernermemorial.org
[R] ABOR
[R] 425 Could not open data connection to port 50178: Connection timed out
[R] 500 ?
[R] 500 ?
[R] Connection lost: ftp.imasupport.com
[R] Attempting to Reconnect.
[R] Connecting to ftp.imasupport.com -> DNS=ftp.imasupport.com IP=72.167.232.201 PORT=21 (attempt # 1)
[R] Connected to ftp.imasupport.com
[R] 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
[R] 220-You are user number 4 of 75 allowed.
[R] 220-Local time is now 06:14. Server port: 21.
[R] 220-This is a private system - No anonymous login
[R] 220 You will be disconnected after 3 minutes of inactivity.
[R] USER msamitz
[R] 331 User msamitz OK. Password required
[R] PASS (hidden)
[R] 230-User msamitz has group access to: 450
[R] 230 OK. Current directory is /
[R] SYST
[R] 215 UNIX Type: L8
[R] FEAT
[R] 211-Extensions supported:
[R] EPRT
[R] IDLE
[R] MDTM
[R] SIZE
[R] REST STREAM
[R] MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNI X.gid*;unique*;
[R] MLSD
[R] ESTP
[R] PASV
[R] EPSV
[R] SPSV
[R] ESTA
[R] AUTH TLS
[R] PBSZ
[R] PROT
[R] 211 End.
[L] Connecting to ftp.adamvernermemorial.org -> DNS=ftp.adamvernermemorial.org IP=72.167.232.143 PORT=21
[L] Connected to ftp.adamvernermemorial.org
[L] 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
[L] 220-You are user number 8 of 75 allowed.
[L] 220-Local time is now 06:14. Server port: 21.
[L] 220-This is a private system - No anonymous login
[L] 220 You will be disconnected after 3 minutes of inactivity.
[L] USER msamitz1
[L] 331 User msamitz1 OK. Password required
[L] PASS (hidden)
[L] 230-User msamitz1 has group access to: 450
[L] 230 OK. Current directory is /
[L] SYST
[L] 215 UNIX Type: L8
[L] FEAT
[L] 211-Extensions supported:
[L] EPRT
[L] IDLE
[L] MDTM
[L] SIZE
[L] REST STREAM
[L] MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNI X.gid*;unique*;
[L] MLSD
[L] ESTP
[L] PASV
[L] EPSV
[L] SPSV
[L] ESTA
[L] AUTH TLS
[L] PBSZ
[L] PROT
[L] 211 End.
[L] CWD /gmw
[L] 250 OK. Current directory is /gmw
[L] PWD
[L] 257 "/gmw" is your current location
[R] CWD /
[R] 250 OK. Current directory is /
[R] PWD
[R] 257 "/" is your current location
[R] TYPE A
[R] 200 TYPE is now ASCII
[R] Listening on PORT: 1474, Waiting for connection.
[R] PORT 192,168,5,101,5,194
[R] 200 PORT command successful
[R] MLSD
[R] 150 Connecting to port 1474
[R] 226-Options: -a -l
[R] 226 61 matches total
[R] List Complete: 6 KB in 0.25 seconds (26.6 KB/s)
[L] TYPE A
[L] 200 TYPE is now ASCII
[R] PASV
[R] 227 Entering Passive Mode (72,167,232,201,196,241)
[L] PORT 72,167,232,201,196,241
[L] 200 PORT command successful
[L] STOR php.ini
msamitz is offline  
Old 03-18-2010, 11:31 AM   #4
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,840
Default

any chance you could move either of ftp servers to port other than 21
or access to ftp server's logs to see the commands they get?

i suspect your firewall is silently modifying PORT command and changing IP of the other server to your IP.
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Old 03-18-2010, 12:06 PM   #5
msamitz
Junior Member
 
Join Date: Mar 2010
Posts: 3
Default

both servers are godaddy..... and so I doubt much chance of changing ports. And as far as the FW, the techs tweaked and turned all they could and nothing seemed to make any difference.
I also went in under site-manager on transfer and tried every combination with the passive and non-passive settings and still got nothing to happen.

I really wish I could get this working as it would make migrating some 9 WP sites effortless. I am certainly open for suggestions to try to resolve and or isolate the problem.

As it stands now, cannot be sure if it is a Godaddy issue, a settings issue, or something else on my end. Is there a way to test (public ftp's) that would assure me that my settings are correct and that site to site does work. Right now tooooo many variables that could be causing the problem. If one could reduce the number of unknowns, might have a better shot at resolving.
msamitz is offline  
Old 03-18-2010, 12:56 PM   #6
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,840
Default

any chance you could connect to those sites outside of your current setup to eliminate possibility that it's the firewall?

also i see that both sites have TLS in the welcome message, have you tried enabling encryption so that your firewall can't see raw ftp commands and mess with them?

maybe create a limited account so i can test it from my known working setup?
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Closed Thread

Tags
download, ftp, port, upload, [r]

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:18 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)