Go Back   FlashFXP Forums > >

General Discussion Need help? Have a problem? Let us help you. Bug reports and feature requests should be made using the Bug Tracker or Feature Tracker

Closed Thread
 
Thread Tools Rate Thread Display Modes
Old 10-13-2009, 08:41 AM   #1
_zakalwe_
Junior Member
 
Join Date: Oct 2009
Posts: 2
Default Low Bandwith with Win7 and TLS FTP-Sites

Hi,

I use Win7 and a 32MB/s Internet line.
Since I move to Windows 7 all FTP connections at TLS FTP Server only can reach the half bandwith. This value is sticked, not less but also not more.
FTP-Server without TLS are a little bit better but not significant.
Also I not able to connect to this TLS sites in the first try (connection lost) the second try always works.
Sites without TLS dont have this problem.
Meanwhile I install the OpenSSL stack with the sugestion that the Win7 SSL stack cause the problem but it have no effect - only 50% bandwith.

Also it dosen't care if I use a beta or normal version of Flashfxp. The problem ist always the same.
I try some other FTP Clients they all of them can use the complete bandwith.

I score this problem as a knockout feataure for me, for a good reason I have 32MB/s if I cant use this I need an other FTP Client. But this is badly for me because I like FlashFXP. For my needs the perfect client but I tranfere big data amounts daily from FTP Sites.

What can I do?

Last edited by _zakalwe_; 10-13-2009 at 08:42 AM. Reason: correction
_zakalwe_ is offline  
Old 10-13-2009, 12:08 PM   #2
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Hello,

Some users faced a similar problem with Windows Vista when connecting to ftp servers running drFTP, the problem was specific to the ftp server and OpenSSL that FlashFXP uses for SSL/TLS connections.

When you upgraded OpenSSL did you put the updated DLLs in the FlashFXP program folder? If you didn't then FlashFXP may not use the updated DLLs.

You can determine the version of OpenSSL being used by FlashFXP by looking in the ftp session window.

If all else fails you can try adjusting the TCP/IP buffer size setting in FlashFXP and see if it improves the performance any.

If you use a 3rd party firewall or Windows Firewall you can try removing FlashFXP from the allow list and applying the changes, and then going back and manually adding it back. Sometimes simply adding and removing the rule can have a huge impact on performance or functionality.
bigstar is offline  
Old 10-13-2009, 02:56 PM   #3
_zakalwe_
Junior Member
 
Join Date: Oct 2009
Posts: 2
Default

No I dont change the dll's in FlashFxp folder.
Meanwhile I changed same and now nothings works anymore.
Now i get errors like this:

[R] error:140943F2:SSL routines:SSL3_READ_BYTES:sslv3 alert unexpected message
[R] Konnte TLSv1 nicht aushandeln, Verbindung getrennt "(cant negotiate TLS. Connection refused)"
[R] 425 Unexpected end of handshake data
[R] Auflistungsfehler - List error

The increase of the TCP/IP buffer size creats a little improvment. With this the bandwith rise up to 2/3.
But it was only a single test I'll do some more tommorrow. For the moment - thanks für your support.
_zakalwe_ is offline  
Closed Thread

Tags
bandwith, flashfxp, ftp, problem, tls

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 01:00 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)