Go Back   FlashFXP Forums > >

General Discussion Need help? Have a problem? Let us help you. Bug reports and feature requests should be made using the Bug Tracker or Feature Tracker

Closed Thread
 
Thread Tools Rate Thread Display Modes
Old 05-29-2008, 08:07 AM   #1
mikepatterson81
Junior Member
FlashFXP Registered User
 
Join Date: Jul 2005
Posts: 4
Default Flash FXP freezing on ftping / data issues???

Ok here is my system

OS: XP 64 bit Pro
Mem: 4 gigs
Processor: intel x3350 quad core

I have 2 scenarios with issues...

I have a mediagate 350HD which for the past year has worked great. I have it combined with a QNAP TS201 NAS system. For the past year everything was great. Recently I build this system and put XP pro 64 since it sees the full 4 gigs of dual channel memory.

First issue:

1) what happens is that when I upload my MEDIA files via ftp to the QNAP NAS system is that when the FILE is at 100% it doesnt' stop the transfer it slowly lowers the speed and then sits at 0.0 for about a minute. I have set it to reconnect and resume after one minute, but it does this after every file for some reason. When I try to resend the files it skips them because it says they are complete, I do this just to check to make sure it all there, but I'm not sure why it does this.... so basically it uploads it...the yellow progress and number say 100%, it drops to 0.0 speed slowly and then just sits there.. until it reconnects and checks.. then it moves on to the next file...

Second issue:
2) Now once I have uploaded this MEDIA file once its finished and Flashfxp says its 100% I goto play the MEDIA file and the MEDIA pauses, the sound continues and then the video just starts again in sync. I thought this was an issue with the wireless portion, but when I redid the wireless, changed everything the MEDIA freeze frames in the same SPOTS.. weird.. never had this problem before with 32 bit windows...

Just to try it.. I instead of using FlashFXP, I copied the files over via connecting via NETWORK DRIVE and copied the media into the QNAP NAS drive... Worked great so far...

My only conclusion is that its FLASHFXP and windows 64bit...?? is there a patch, a workaround... or am I missing a setting...I set this up just like my laptop which has been running good for over a year since I have reformatted it (XP 32bit)... actually i just copied the sites information and replaced the default so it was just like teh other one...I even tried manually configuring it, neither option seems to fix the freezing on the upload or playing the file...

Downloading works great still...I am able to download files easily and have even verified with extracting rar files, etc..and it was fine...
mikepatterson81 is offline  
Old 05-29-2008, 08:50 AM   #2
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

1) How long exactly do these transfers take to complete?

I suspect that the control connection is being disconnected due to inactivity, During a file transfer the control connection remains in an idle wait state and some firewalls / routers / proxies will automatically close a connection that has been idle longer than the limit set for the device. This poses a problem for ftp connections because the connection is dropped without notifying the client, FlashFXP doesn't realize the control connection is lost until it attempts to get the transfer complete result and then it realizes the connection is lost. The proper way to resolve this type of issue is to configure the firewall / router /proxy by increasing or disabling the idle timeout limit. There is an option you can enable within FlashFXP and your millage with vary depending on the ftp server. This option is "Send Noops during transfer" Located in the Preferences > Connection > Proxy tab.

2) I'm not really sure.

FlashFXP runs great on windows 64bit and that should not cause you any problems.
bigstar is offline  
Old 05-30-2008, 11:37 PM   #3
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,845
Default

i don't see how stuttering playback is flashfxp's fault.
it uploaded your file and that's it. if anything that could be cuasing this problem, you should look into ftpserver. it's the part that actually writes file to the destination drive.
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Old 06-02-2008, 10:15 PM   #4
mikepatterson81
Junior Member
FlashFXP Registered User
 
Join Date: Jul 2005
Posts: 4
Default

OK.. I have done some testing....

I took 3 more movies and uploaded them via FLASHFXP, then took the same movies and just copied them over the network via the network drive....

EVERY single one with FLASHFXP skipped and paused....like it had glitches...those SAME movies that were copied via network drive had NO ISSUES.....

Like I said previously had NO issues.. ahve been a user of Flash fxp for many years.. but with 32 bit windows....I switched to 64bit and all the problems started to happen.

Not sure why...Also when uploading it gets to 100% and then slowly drops speed to 0.0 and just sits there until the autoreconnect kicks in..it doesn't move to the enxt file.. I have done the NOOP command and tried different checks and stuff.. but I have no issues with my laptop which is 32 bit..

If would like I can record what is going on.. and show you the settings via my 32bit laptop and my 64 bit desktop...same thing.. again I have been a user for many years and have never seen these problems....till now...kind of annoying when watching a movie and every 5-10 minutes teh frames pause and the audio continues...
mikepatterson81 is offline  
Old 06-03-2008, 10:44 PM   #5
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,845
Default

so are you saying when you upload the same movie from your 32bit laptop, they playback fine?
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Old 06-04-2008, 09:32 AM   #6
mikepatterson81
Junior Member
FlashFXP Registered User
 
Join Date: Jul 2005
Posts: 4
Default

yes... it works perfectly...

Ok something else interesting.. I have put 64bit on another system.. and will be doing some more testing.. but I uploaded a rar file to my other system and it became corrupt... not sure why, but somehow its corrupting files.. loosing chunks of data.. or doing something.. I am going to try a re-install just to see what it does...
mikepatterson81 is offline  
Old 06-04-2008, 04:45 PM   #7
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,845
Default

what flashfxp build are you using?
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Old 06-23-2008, 01:18 PM   #8
tjpMT2
Junior Member
FlashFXP Registered User
 
Join Date: Apr 2007
Posts: 1
Default

I'm getting similar problems however my files do not completely upload they hit anywhere from 1% to 80% and then freeze, my files are 40mb-80mb .zip files 10mb.zip went through fine as did .php files and small .jpg's. Uploaded a 94mb .zip file a couple weeks ago and wen't fine.
tjpMT2 is offline  
Closed Thread

Tags
download, flashfxp, ftp, fxp, media, upload

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:35 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)