Go Back   FlashFXP Forums > >

General Discussion Need help? Have a problem? Let us help you. Bug reports and feature requests should be made using the Bug Tracker or Feature Tracker

Closed Thread
 
Thread Tools Rate Thread Display Modes
Old 12-19-2007, 03:17 AM   #1
AkilleuZ
Junior Member
 
Join Date: Dec 2007
Posts: 4
Default PASV mode failed, trying PORT mode

Hi

I have a problem connecting 2 my server, from UNI. Asfar as i know its the only "public" place i have troulbe connecting to the server from. I really hope you can help me.

Here is the log:


[R] Connecting to 212.242.XX.209 -> IP=212.242.XX.209 PORT=21
[R] Connected to 212.242.XX.209
[R] 220 BulletProof FTP Server ready ...
[R] USER XX
[R] 331 Password required for XX.
[R] PASS (hidden)
[R] 230 User XX logged in.
[R] SYST
[R] 215 UNIX Type: L8
[R] FEAT
[R] 211-Extensions supported:
[R] CLNT
[R] MDTM
[R] PASV
[R] REST STREAM
[R] SIZE
[R] 211 End.
[R] CLNT FlashFXP 3.5.1.1200
[R] 200 "FlashFXP 3.5.1.1200" noted.
[R] PWD
[R] 257 "/" is current directory.
[R] TYPE A
[R] 200 Type set to A.
[R] PASV
[R] 227 Entering Passive Mode (212,242,XX,209,46,71)
[R] Opening data connection IP: 212.242.XX.209 PORT: 11847
[R] Data Socket Error: Connection timed out
[R] List Error
[R] PASV
[R] 227 Entering Passive Mode (212,242,XX,209,46,72)
[R] Opening data connection IP: 212.242.XX.209 PORT: 11848
[R] Data Socket Error: Connection timed out
[R] List Error
[R] PASV mode failed, trying PORT mode.
[R] Listening on PORT: 59963, Waiting for connection.
[R] PORT 172,21,187,206,234,59
[R] 530 PORT command only accepts client IP address (130.225.184.23!=172.21.187.206).
[R] List Error

PORT: 21 is open on the server firewall.

Thank you for your time
AkilleuZ is offline  
Old 12-19-2007, 04:30 AM   #2
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

The server needs more than just port 21 open for PASV data connections.. it doesn't look like PORT mode will work with the ftp server configuration, my guess is that your setup is using a transparent proxy.. normally the client IP should be the same for the data connection.
bigstar is offline  
Old 12-19-2007, 04:36 AM   #3
AkilleuZ
Junior Member
 
Join Date: Dec 2007
Posts: 4
Default

Hi

Ok. I can easaly open more ports on the firewall where the server is. Which range of ports du you recomend i open?

Is there anything else i have to do?

I have tried to get one of my friends to connect from his home, and he can connect to the server.
AkilleuZ is offline  
Old 12-19-2007, 07:58 AM   #4
AkilleuZ
Junior Member
 
Join Date: Dec 2007
Posts: 4
Default

For fun i just tried to connect to the FTP ser through Firefox.

If i do that i can connect to the server without any problems.

I really hope someone can help me out here.
AkilleuZ is offline  
Old 12-19-2007, 09:55 AM   #5
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,840
Default

http://www.inicom.net/forum/showthread.php?t=4275
interesting that you are unregistered user and yet using build 1200
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]

Last edited by MxxCon; 12-19-2007 at 10:00 AM.
MxxCon is offline  
Old 12-19-2007, 11:27 AM   #6
AkilleuZ
Junior Member
 
Join Date: Dec 2007
Posts: 4
Default

Yes im using an unregistered version but trail.

I havnt bought it yet but i will if can get it to work. The reason im using it, is that one of my friends told me that this program is the very best, and so far i works very well. I just have this problem, and hopefully someone can help me.
AkilleuZ is offline  
Old 12-19-2007, 03:31 PM   #7
DayCuts
Senior Member
FlashFXP Beta Tester
 
Join Date: Dec 2003
Posts: 421
Default

A couple of things to try.

Try configuring the server to use a set range of ports for passive connections, and make sure this same range is appropriately configured in any router/firewall.

If passive simply wont work (it may be something on your Uni network configuration causing it) then use active mode (PORT). Both flashfxp and your server software will have configuration options regarding this, on the client side you can fiddle with the active mode ip/port range setting, and on the server side you can set the server to allow fxp or 'ftp bounce' as some servers call it. It is currently not allowed by your server which is why you are getting the "530 PORT command only accepts client IP address (130.225.184.23!=172.21.187.206)." error.
DayCuts is offline  
Closed Thread

Tags
flashfxp, ftp, mode, port, [r]

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 04:28 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)