Go Back   FlashFXP Forums > >

General Discussion Need help? Have a problem? Let us help you. Bug reports and feature requests should be made using the Bug Tracker or Feature Tracker

Closed Thread
 
Thread Tools Rate Thread Display Modes
Old 09-05-2007, 01:36 PM   #1
yellow
Junior Member
 
Join Date: Sep 2007
Posts: 4
Default Ident Server: Unable to listen on port 113

* FlashFXP v[3].[4], build [1179], [ ]registered, [x]unregistered, [ ]pirated
* OS [ ] Vista, [x] WinXP, [ ] Win2K, [ ] Win98, [ ] WinME, [ ] Other (explain)
* Running behind NAT/router [x] Yes & Model [linux router], [ ] No, [ ] Not sure
* Running firewall [ ] Yes, Name [ ], Ver. [ ], or [x] No
* Running Antivirus [ ] Yes, Name [ ] or [x] No
* Network [ ] xDSL, [x] CABLE, [ ] Dail-Up, [ ] Other

Ever since I moved a couple days ago to my new place, everytime I start flashfxp i get: "Ident Server: Unable to listen on port 113". Normally thats when the port is in use but I checked it with tcpview as well as telnetting localhost on 113, nothing's listening. Just for kicks I tried changing FlashFXP ident listening port to something random, like 118, and it reports the same error (obviously with a new port number).

mIRC listens perfectly for identd. Although it isn't an issue, this is a local error, the identd port is forwarded correctly on the gateway. I am a system technician and my computer is very clean with no junk on it. Hijackthis is clean, etc. I tried FlashFXP in safe mode, I get the same error. I tried unplugging it from the network and restarting, same error. I tried reinstalling it and using a different version, same error. I tried some netsh winsock reset commands and ip reset commands, nothing seems to work.

I am pretty much baffled by this. I've checked the other threads and it seems others have had this problem, but with no fix? I do not wish to run a standalone identd server.

Thanks,
yellow is offline  
Old 09-05-2007, 04:14 PM   #2
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

I suspect the problem might be due to the fact you're using 1179..

Download this beta version if you plan on using beta releases
http://www.inicom.net/forum/showthread.php?t=12729
bigstar is offline  
Old 09-05-2007, 04:20 PM   #3
yellow
Junior Member
 
Join Date: Sep 2007
Posts: 4
Default

Ident Server: Unable to listen on port 113
FlashFXP v3.4.1 build 1197 [BETA]
Support Forums at http://forum.flashfxp.com
Report a Bug at http://bugtracker.inicom.net

WinSock 2.0 -- OpenSSL 0.9.8e 23 Feb 2007

no luck thanks for your help still.
yellow is offline  
Old 09-06-2007, 12:08 AM   #4
yellow
Junior Member
 
Join Date: Sep 2007
Posts: 4
Default

anyone else able to have a stab at this? i really dont want to format my computer just so flashfxp's identd will listen
yellow is offline  
Old 09-06-2007, 03:03 PM   #5
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Have you tried closing every application before starting FlashFXP?

mIRC can conflict with FlashFXP based on your mIRC settings, make sure identd is only enabled while connecting. Same with FlashFXP.

There has to be some other application listening on this port. If you can't find a program I'd recommend you do a adware/spyware scan and make sure you don't have some hidden application running on your computer.
bigstar is offline  
Old 09-06-2007, 06:07 PM   #6
yellow
Junior Member
 
Join Date: Sep 2007
Posts: 4
Default

ive closed every application before starting yes, i mostly mentioned mIRC just to let you know that in fact another program was able to bind to port 113, where flashfxp could not. i have closed down everything (including mIRC) before running flashfxp and still it says that. this is also why i chose to run it in safe mode w/ networking, because all/most of the startup processes wouldn't start up, and i could confirm it was not a software conflict. the thing is though, is that i know nothing else is listening on 113. i check this with tcpview as well as telnetting localhost on 113.

however, when it comes down to it i still dont believe its a port conflict at all. i mentioned above that i changed flashfxp's identd listening port to any random port, and it complains that its unable to listen on that port (for any port). it seems to be a bug with flashfxp itself.

example:

Ident Server: Unable to listen on port 113
FlashFXP v3.4.1 build 1197 [BETA]
Support Forums at http://forum.flashfxp.com
Report a Bug at http://bugtracker.inicom.net

WinSock 2.0 -- OpenSSL 0.9.8e 23 Feb 2007
Ident Server: Unable to listen on port 24687

this is after changing flashfxp to listen for identd on port 24687 (available) after changing it from default 113. i will turn on enable only when connecting now to show you, but it is the same thing.

FlashFXP v3.4.1 build 1197 [BETA]
Support Forums at http://forum.flashfxp.com
Report a Bug at http://bugtracker.inicom.net

WinSock 2.0 -- OpenSSL 0.9.8e 23 Feb 2007
Ident Server: Unable to listen on port 24687
[L] Connecting to Adobe -> DNS=ftp.adobe.com IP=192.150.18.26 PORT=21
[L] Connected to Adobe

the ident server error popped up only when i chose to connect to the adobe site (only when connecting).

i have indeed done an adware/spyware scan on my computer, it is very clean. i also checked all the running processes and dug through all the hijackthis entries, its all clean.
yellow is offline  
Old 09-07-2007, 11:31 AM   #7
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

The only other thing I can think of is windows firewall.. I know you said you aren't using one, but other than that I don't have any other ideas.

If your computer have multiple network interfaces you need to make sure the firewall is disabled on each of them, or make sure FlashFXP is properly added to the exclude list.
bigstar is offline  
Old 09-09-2007, 07:33 AM   #8
ArtX
Senior Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Join Date: Jan 2004
Posts: 301
Default

it could be the router blocking it - i had one router that was a pain in the butt (belkin) i had to allow port 113 - which isnt the best idear in the world, on the linksys i have now no issue.

If you allow the port and it works i would suggest only allowing that rule when your using flash.

only other thing i can think of is that the isp is blocking or doing something else on that port - or are you using the same isp after you moved or a new one ?
ArtX is offline  
Old 09-09-2007, 11:41 AM   #9
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,839
Default

Carpo, it can not possibly be his router or isp. both of these causes are external.
flashfxp can not listen on a specified port because it's in use or does not have permissions to do it. this problem is local to his system, not external like router or isp.
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Closed Thread

Tags
error, flashfxp, port, running, [x]

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 01:18 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)