Go Back   FlashFXP Forums > >

General Discussion Need help? Have a problem? Let us help you. Bug reports and feature requests should be made using the Bug Tracker or Feature Tracker

Closed Thread
 
Thread Tools Rate Thread Display Modes
Old 05-12-2007, 11:39 AM   #1
Nobel
Junior Member
FlashFXP Registered User
 
Join Date: Jan 2007
Posts: 5
Default Copy files on the same FTP server

Hi

I have a Synology NAS server on my LAN and I can in FlashFXP log on to the drive using FTP on the left and on the right site on the same time. I then can move/copy files from one folder to another on the Synology server.

When I then log on my Synology NAS server on my office (via the internet) and try the same, the process stops, just after I has startet. (se log)
I have in the firewall open port 20-21 and 55536–56559 and can use the Synology NAS server fine to copy to and from via FTP to my PC, but the “intern” work where I move files from one folder to another on the Synology NAS server dose not work.

In this exempel I try to copy the file aawsepersonal.exe from one folder to another. But the process stops after STOR… the file aawsepersonal.exe is made but is 0 kb.

What can be the problem?

Regards
Nobel

log:

[L] CWD /Test
[L] 250 CWD command successful.
[L] PWD
[L] 257 "/Test" is current directory.
[R] TYPE I
[R] 200 Type set to I.
[L] TYPE I
[L] 200 Type set to I.
[R] PASV
[R] 227 Entering Passive Mode (80,165,xxx,xxx,48,246)
[L] PORT 80,165,xxx,xxx,48,246
[L] 200 PORT command successful.
[L] STOR aawsepersonal.exe
Nobel is offline  
Old 05-12-2007, 01:06 PM   #2
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

A hardware device or software program between you and your NAS server is blocking the site to site transfer. This can occur with NAT (Network Address Translation) based solutions, NAT is not site to site friendly.

To overcome this problem you may need to run the FTP server on a non-standard port. Normally FTP is on port 21 but if you were to use say port 2034 that should prevent NAT from causing problems.

Using a secure connection (AUTH SSL/TLS) is another option.

If neither of these options are possible one other option would be to run a socks proxy on your home network. Then configure FlashFXP to use the socks proxy when connecting to your NAS from the office.
bigstar is offline  
Old 05-13-2007, 06:14 AM   #3
Nobel
Junior Member
FlashFXP Registered User
 
Join Date: Jan 2007
Posts: 5
Default

Quote:
Originally Posted by bigstar
To overcome this problem you may need to run the FTP server on a non-standard port. Normally FTP is on port 21 but if you were to use say port 2034 that should prevent NAT from causing problems.
Hi

Thank you for the quick reply. I changed the port number from 21 to 2021, and that have solved the problem.
Thanks for the help.
Regards

Nobel
Nobel is offline  
Closed Thread

Tags
flashfxp, ftp, server, synology, [l]

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:02 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)