Go Back   FlashFXP Forums > >

General Discussion Need help? Have a problem? Let us help you. Bug reports and feature requests should be made using the Bug Tracker or Feature Tracker

Closed Thread
 
Thread Tools Rate Thread Display Modes
Old 08-16-2006, 07:50 PM   #1
Whiskey
Junior Member
 
Join Date: Aug 2006
Posts: 1
Default Pause after each file

I'm getting a 5-6 second pause after each file transfer and directory listing request. This is a new install of the latest version and I've never encountered this problem in previous versions. Obviously this makes for long transfers when dealing with many small files.
Whiskey is offline  
Old 08-16-2006, 08:39 PM   #2
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Please post a copy of the ftp session log. With timestamps enabled.

I imagine the delay is on the server side since FlashFXP doesn't doesn't on purpose.

The ftp session log will give us the answers.
bigstar is offline  
Old 09-01-2006, 03:17 AM   #3
BitBasher
Junior Member
FlashFXP Registered User
 
Join Date: Jul 2005
Posts: 1
Default

I just updated to 3.4, and I got this delay too.

It turns out it was PASV mode. The ftp server I was connecting to doesn't support PASV, but it seems that when this newer version of FlashFXP attempts to establish a PASV connection, it takes a LONG time for it to finally give up and switch back to port? mode.

The older version of FlashFXP I was using (to the same server) does NOT have this problem.

For now, my workaround is to manually turn off PASV mode on connections that don't support it - auto-PASV isn't cutting it. :P

Bit.
BitBasher is offline  
Old 09-03-2006, 10:49 AM   #4
Seome
Inicom Networks Support
Ultimate Scripter
 
Join Date: Mar 2005
Posts: 58
Default

The old version of FlashFXP failed to connect when PASV mode did not work. The new version automatically retries in PORT mode when this failure occurs. From what I understand FlashFXP should remember this and not try PASV connections again when this has happened but I have seen a few session logs where this is not the case. This whole try/fail/retry takes several seconds for each file/listing. You can stop this from occurring by unchecking "use passive mode" in the site manager for the sites Option tab.

If you have a session log of this occurring please send it to support@inicom.net so we can document it.
Seome is offline  
Closed Thread

Tags
file, makes, pause, problem, versions

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:00 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)