Go Back   FlashFXP Forums > >

General Discussion Need help? Have a problem? Let us help you. Bug reports and feature requests should be made using the Bug Tracker or Feature Tracker

Closed Thread
 
Thread Tools Rate Thread Display Modes
Old 12-20-2005, 07:54 PM   #1
jozima
Junior Member
 
Join Date: Dec 2005
Posts: 5
Default PRET doesnt work

I already looked at the other PRET-Threads but did not find anything which did work.

Following message comes when i try to flash with Auth TLS:

[R] MKD /test
[R] 257 "/test" created.
[R] CWD /test
[R] 250 CWD command successful.
[R] PWD
[R] 257 "/test" is current directory.
[R] STAT -la
[R] List Complete: 121 bytes in 0,43 seconds (0,3 KB/s)
[R] PROT P
[R] 200 Protection set to Private
[L] PROT P
[L] 200 Command okay
[L] CPSV
[L] 500 You need to use a client supporting PRET (PRE Transfer) to use PASV
Secure site to site transfers not supported by this ftp server
[R] Transfer Failed!
1 File failed to transfer
Server Error, Aborted


The joke is: Other people can do this..i am the only one where it doesnt work! I had problems with this *$§§%&* PRET since the first time i saw it.
Why isnt there just a little trigger where you can say "Enable PRET" and that it is?

The thing with "This site does not support FEAT command" is known to me...

And, yes, the other people do flash with auth tls too...

When i try to flash WITHOUT AUTH TLS, then this appears:

[L] PASV
[L] 500 You need to use a client supporting PRET (PRE Transfer) to use PASV
[R] Transfer Failed!
[L] PASV
[L] 500 You need to use a client supporting PRET (PRE Transfer) to use PASV
[R] Transfer Failed!
[L] PASV
[L] 500 You need to use a client supporting PRET (PRE Transfer) to use PASV
[R] Transfer Failed!
[L] PASV
[L] QUIT

So pleeeeeeeeeeeeeeease, can anyone tell me, why this doesnt work?

I am really disappointed...flashfxp was so good to me all over the years
jozima is offline  
Old 12-20-2005, 08:13 PM   #2
jozima
Junior Member
 
Join Date: Dec 2005
Posts: 5
Default

• If Passive mode fails two times in a row, FlashFXP will switch to PORT mode or vice versa.

This should be something what should happen after two times of failing PASV, or not???
jozima is offline  
Old 12-20-2005, 08:16 PM   #3
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

PRET support is determined based on the FEAT reply. Paste the login message and show us the FEAT reply. Only when PRET is listed will it be used in FlashFXP.
bigstar is offline  
Old 12-20-2005, 08:32 PM   #4
jozima
Junior Member
 
Join Date: Dec 2005
Posts: 5
Default

there is no FEAT reply because the entry message is totally modified!
But i am just talking to one who has no problems with this, and the FEAT reply isnt at him, too.
Other ppl than me can do it, with flashfxp!

I asked and asked and some ppl do not use passive mode...but they do connect to the internet direct, not via router like me.....could it be because of this??

I am really desperate because of this!

Here the loginmsg, but like i said...modified:

[L] Connecting to test -> IP=xxx.xxx.xxx.xxx PORT=1234
[L] Connected to test
Ident Request: xxx.xxx.xxx.xxx - UserID: testo
[L] 220 ssh version v2.0
[L] AUTH TLS
[L] 234 AUTH TLS successful
[L] Connected. Negotiating TLSv1 session..
[L] TLSv1 negotiation successful...
[L] TLSv1 encrypted session using cipher EDH-RSA-DES-CBC3-SHA (168 bits)
[L] PBSZ 0
[L] 200 Command okay
[L] USER tester
[L] 331 Password required for tester.
[L] PASS (hidden)
[L] 230-
[L] 230-
[L] 230- Welcome...........
[L] 230-
[L] 230-
[L] 230 tester logged in successfully.
[L] ACCT tester
[L] 500 No command handler for ACCT
[L] CWD /
[L] 250 Directory changed to /
[L] PWD
[L] 257 "/" is current directory
jozima is offline  
Old 12-20-2005, 08:49 PM   #5
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

It looks like you might have FEAT disabled for the site in the Site Manager.
Make sure this option is not checked "Site does not support FEAT command"
bigstar is offline  
Old 12-20-2005, 10:23 PM   #6
jozima
Junior Member
 
Join Date: Dec 2005
Posts: 5
Default

it is NOT checked! (((
i am not a noob *G*
jozima is offline  
Old 12-20-2005, 10:37 PM   #7
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Then FEAT should be sent to the ftp server
bigstar is offline  
Old 12-21-2005, 12:03 AM   #8
jozima
Junior Member
 
Join Date: Dec 2005
Posts: 5
Default

got to know that you dont know anything too. :|

i tried different versions of flashfxp too and no i am using the 3.3.5 beta, but nothing changes..

and the joke is: about 2 weeks ago, i did work!!

and no, i did not change anything to my network or anything else..

since 5 days i have a new windows installation with new, clean registry but nothing...

i really dont know what i can do
jozima is offline  
Old 12-21-2005, 05:53 PM   #9
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,827
Default

Quote:
Originally Posted by jozima
i am not a noob *G*
and yet you didn't read http://www.inicom.net/forum/showthread.php?t=4745
MxxCon is offline  
Closed Thread

Tags
flashfxp, ftp, transfer, [l], [r]

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:30 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)