Go Back   FlashFXP Forums > >

General Discussion Need help? Have a problem? Let us help you. Bug reports and feature requests should be made using the Bug Tracker or Feature Tracker

Closed Thread
 
Thread Tools Rating: Thread Rating: 3 votes, 5.00 average. Display Modes
Old 12-14-2005, 07:42 AM   #1
mikezs
Junior Member
FlashFXP Registered User
 
Join Date: Jul 2004
Posts: 4
Default Passive mode with a proxy

When using a proxy is FlashFXP, (i only have access to port 21 with it) FlashFXP will not let me turn passive mode off!

In image 1, passive mode is unchecked then as you can see in image 2, FlashFXP is still trying to use passive mode!!

Please could you let me know how to make sure the client doesnt use passive mode!

Thanks
Attached Thumbnails
Passive mode with a proxy-2-jpg  
Attached Images
Passive mode with a proxy-1-jpg 
mikezs is offline  
Old 12-14-2005, 07:47 AM   #2
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

FlashFXP doesn't support active mode when using a socks proxy. Only passive mode is supported.

What you can do is configure the proxy to only proxy the control connection, that way you can use passive or port for the data connections. to do this prefix the proxy IP address with a !

It would look like this !10.1.1.100
bigstar is offline  
Old 12-14-2005, 08:39 AM   #3
mikezs
Junior Member
FlashFXP Registered User
 
Join Date: Jul 2004
Posts: 4
Default

I dont understand what this flag does; Uses the proxy only for the direct connection to the server, and the local machine to connect to the passive ports?

I dont have the ability to connect to any ports with the local machine other than web, and a few other ports, so this is the reason a proxy is required. If i uses STAT -l to list the directory, it works perfectly (on servers that support it) but i cannot seem to get a directory listing for this one.

EDIT: Oh yea, and it doesnt fix my problem, i stil cant list the directory
mikezs is offline  
Old 12-14-2005, 10:13 AM   #4
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Sorry I didn't fully understand your situation, Now I do. Unforutately the ! command wont help your situation.

If you can't connect via socks using passive mode then you wont be able to get a listing with FlashFXP since the socks mode doesn't support active mode.
bigstar is offline  
Closed Thread

Tags
flashfxp, image, mode, passive, proxy

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:42 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)