Go Back   FlashFXP Forums > >

General Discussion Need help? Have a problem? Let us help you. Bug reports and feature requests should be made using the Bug Tracker or Feature Tracker

Closed Thread
 
Thread Tools Rate Thread Display Modes
Old 09-06-2005, 03:58 AM   #1
Ammo1
Member
FlashFXP Registered User
 
Join Date: Jan 2003
Posts: 34
Question Understanding Scheduler..

I wanted to connect to a particular server at midnight using the built in scheduler to transfer approx. 6GB of data. The below comes from part of the log generated and I was wondering why the time discrepancy and also how do I fix the "decompression errors"...

Quote:
[00:00:00] Schedule - Starting..
[00:00:00] [R] Connecting to FTP -> IP=xx.xxx.xx.xxx PORT=21
[00:00:00] [R] Connected to FTP
[00:00:01] [R] 220 ..::blah::.. blah blah blah!
[00:00:01] [R] USER User
[00:00:01] [R] 331 User name okay, need password.
[00:00:01] [R] PASS (hidden)
[00:00:01] [R] 230 User logged in, proceed.
[00:00:01] [R] SYST
[00:00:01] [R] 215 UNIX Type: L8
[00:00:01] [R] FEAT
[00:00:02] [R] 211-Extension supported
[00:00:02] [R] CLNT
[00:00:02] [R] MDTM
[00:00:02] [R] MDTM YYYYMMDDHHMMSS[+-TZ];filename
[00:00:02] [R] SIZE
[00:00:02] [R] SITE PSWD;EXEC;SET;INDEX;ZONE;CHMOD;MSG
[00:00:02] [R] REST STREAM
[00:00:02] [R] XCRC filename;start;end
[00:00:02] [R] MODE Z
[00:00:02] [R] 211 End
[00:00:02] [R] CLNT FlashFXP 3.2.0.1080
[00:00:02] [R] 200 Noted.
[00:00:03] [R] MKD /f:/Category folder/
[00:00:03] [R] 257 "/f:/Category folder/ directory created.
[00:00:03] [R] CWD /f:/Category folder/
[00:00:03] [R] 250 Directory changed to /f:/Category folder/
[00:00:03] [R] PWD
[00:00:03] [R] 257 "/f:/Category "folder" is current directory.
[00:00:03] [R] TYPE A
[00:00:04] [R] 200 Type set to A.
[00:00:04] [R] MODE Z
[00:00:04] [R] 200 MODE Z ok.
[00:00:04] [R] PASV
[00:00:04] [R] 227 Entering Passive Mode (xx,xxx,xx,xxx,95,8)
[00:00:04] [R] Opening data connection IP: xx.xxx.xx.xxx PORT: 24328
[00:00:04] [R] LIST -al
[00:00:04] [R] 150 Opening ASCII mode data connection for /bin/ls.
[00:00:05] [R] 226 Transfer complete.
[00:00:05] [R] List Complete: 113 bytes in 1.59 second (0.1 KB/s)
[00:00:05] [R] TYPE I
[00:00:05] [R] 200 Type set to I.
[00:00:05] [R] PASV
[00:00:05] [R] 227 Entering Passive Mode (xx,xxx,xx,xxx,95,9)
[00:00:05] [R] Opening data connection IP: xx.xxx.xx.xxx PORT: 24329
[00:00:06] [R] STOR CD1.iso
[00:00:06] [R] 150 Opening BINARY mode data connection for CD1.iso.
[00:12:01] [R] 426 Data connection closed, error decompressing data stream.
[00:12:01] [R] Transfer Failed!
[00:12:01] [R] PASV
[00:12:02] [R] 227 Entering Passive Mode (xx,xxx,xx,xxx,95,12)
[00:12:02] [R] Opening data connection IP: xx.xxx.xx.xxx PORT: 24332
[00:12:02] [R] REST 29286673
[00:12:02] [R] 350 Restarting at 29286673. Send STORE or RETRIEVE.
[00:12:02] [R] STOR CD1.iso
[00:12:02] [R] 150 Opening BINARY mode data connection for CD1.iso.
[00:17:09] [R] 426 Data connection closed, error decompressing data stream.
[00:17:09] [R] Transfer Failed!
[00:17:09] [R] PASV
[00:17:10] [R] 227 Entering Passive Mode (xx,xxx,xx,xxx,95,13)
[00:17:10] [R] Opening data connection IP: xx.xxx.xx.xxx PORT: 24333
[00:17:10] [R] REST 41741328
[00:17:10] [R] 350 Restarting at 41741328. Send STORE or RETRIEVE.
[00:17:10] [R] STOR CD1.iso
[00:17:10] [R] 150 Opening BINARY mode data connection for CD1.iso.
[03:23:39] [R] 426 Data connection closed, error decompressing data stream.
[03:23:39] [R] Transfer Failed!
[03:23:41] [R] PASV
[03:23:41] [R] 227 Entering Passive Mode (xx,xxx,xx,xxx,95,80)
[03:23:41] [R] Opening data connection IP: xx.xxx.xx.xxx PORT: 24400
[03:23:41] [R] REST 493860778
[03:23:41] [R] 350 Restarting at 493860778. Send STORE or RETRIEVE.
[03:23:41] [R] STOR CD1.iso
[03:23:41] [R] 150 Opening BINARY mode data connection for CD1.iso.
[03:25:38] [R] 226 Transfer complete.
[03:25:38] Resumed: CD1.iso 10.58 MB in 1 minute 56 seconds (92.7 KB/s)
[03:25:38] [R] PASV
[03:25:39] [R] 227 Entering Passive Mode (xx,xxx,xx,xxx,95,81)
[03:25:39] [R] Opening data connection IP: xx.xxx.xx.xxx PORT: 24401
[03:25:39] [R] STOR CD2.iso
[03:25:39] [R] 150 Opening BINARY mode data connection for CD2.iso.
What I'm talking about is what happened here:
[00:17:10] [R] 150 Opening BINARY mode data connection for CD1.iso.
[03:23:39] [R] 426 Data connection closed, error decompressing data stream.
[03:23:39] [R] Transfer Failed!


and why the 3 hours basically unaccounted for? It looks to me like from shortly after Midnight until 3:23AM it transferred CD1.iso then crapped out because there was an error decompressing the data - on the other side? or mine? I'm not sure of the server on the other side.

Thanx..

FYI..obviously log was edited to keep IPs and original file names and dirs out.
Code:
* FlashFXP v[3].[2], build [1080], [x]registered, [ ]unregistered, [ ]pirated
* OS [x] WinXP, [ ] Win2K, [ ] Win98, [ ] WinME, [ ] Other
* Running behind NAT/router [X] Yes & Model [Netgear CG814WG], [ ] No, [ ] Not sure
* Running firewall [ ] Yes, Name [ ], Ver. [ ], or [X] No
* Running Antivirus [X] Yes, Name [avast! Pro 4.6] or [ ] No
* Network [ ] xDSL, [X] CABLE, [ ] Dail-Up, [ ] Other
Ammo1 is offline  
Old 09-06-2005, 06:50 AM   #2
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,831
Default

all the lines that start with numbers are messages sent FROM the server.
[00:17:10] [R] 150 Opening BINARY mode data connection for CD1.iso.
[03:23:39] [R] 426 Data connection closed, error decompressing data stream.
so yes, at 00:17:10 it started transferring, and did so for ~3:05hours, then for whatever reason your server crapped out.

more specifically, why you got that 'decompressing data' error..you enabled on-the-fly-compression with MODE Z command. it works by compressing blocks of data at a time (typically 4k) and sending them. something happened between you sending the correct compressed block and server receiving damaged one, which it wasn't able to decompress.
so to some degree, it's good that your transfer failed because without the on-the-fly-compression your transfer could have continued but that small part of data could be corrupt and you wouldn't know about it.
MxxCon is offline  
Old 09-06-2005, 07:37 AM   #3
Ammo1
Member
FlashFXP Registered User
 
Join Date: Jan 2003
Posts: 34
Default

OK...thanx MxxCon. So, keeping the compression option checked in FlashFxp would be a good idea in your opinion?

I haven't really done alot of large file transfers such as this before.
Ammo1 is offline  
Old 09-06-2005, 07:03 PM   #4
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,831
Default

i'd suggest you do further testing and try to figure out if those errors are valid or some other unknown issue..
try to transfer some stuff with and without 'mode z' and see if crc checks out ok..
MxxCon is offline  
Closed Thread

Tags
connection, data, flashfxp, ftp, [r]

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:35 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)