Go Back   FlashFXP Forums > >

General Discussion Need help? Have a problem? Let us help you. Bug reports and feature requests should be made using the Bug Tracker or Feature Tracker

Closed Thread
 
Thread Tools Rate Thread Display Modes
Old 08-13-2005, 04:38 PM   #1
mhs
Junior Member
 
Join Date: Aug 2005
Posts: 8
Default Active mode / bad router ?

hi
info:
flashfxp - latest ver unreg
antivir - kaspersky
router netgear rp614v3 / using spi (The SPI(Stateful Inpection) Firewall protects your LAN against Denial of Service attacks. This should only be disabled in special circumstances.)
and dmz mode off (i dont want it / bc i wanna be more secure)

i forwarded those ports ( 2000 - 2050 ) on my router to my internal ip
and in flashfxp i unchecked the "Use Passive Mode" , checked "Send noops during transfer"
checked "limit local port range to min:2000 max 2050"
and also checked "Force active mode ...." and in that box i entered my external ip

and when im trying to connect to any server im getting this error

Code:
[R] TYPE A
[R] 200 Type set to A.
[R] MODE Z
[R] 200 MODE Z ok.
[R] PORT x,x,x,x,7,214
[R] QUIT
[R] Logged off: xxxxxxxxxxxxxxxxxxxxxxxxxx
the passive mode works ok , but i think it wont metter because i wanna do the FXP so i think if i dont get the Active mode to work the FXP wont work neither ...
can some1 plz help me ....
mhs is offline  
Old 08-13-2005, 05:15 PM   #2
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,831
Default

FXP transfers have nothing to do with active/passive mode on YOUR connection.
FXP transfers create active+passive connection between 2 servers.
so if you want to FXP, you can connect using pasv mode just fine.

otherwise, try to temporary remove router from your setup and see if that makes any difference.
MxxCon is offline  
Old 08-13-2005, 05:22 PM   #3
mhs
Junior Member
 
Join Date: Aug 2005
Posts: 8
Default

ok then ..
i switched to PASIVE MODE and i tiried to FXP
Code:
[R] List Complete: 183 bytes in 0,81 seconds (0,2 KB/s)
[L] TYPE I
[L] 200 Type set to I.
[R] TYPE I
[R] 200 Type set to I.
[L] MODE S
[L] 200 MODE S ok.
[L] PASV
[L] 227 Entering Passive Mode (217,75,242,136,4,162)
[R] PORT 217,75,242,136,4,162
[R] 200 PORT Command successful.
[R] STOR test.zip
[R] 150 Opening BINARY mode data connection for test.zip.
[L] RETR test.zip
[L] ABOR
[L] 226 ABOR command successful.
[R] ABOR
[R] 226 ABOR command successful.
[R] Transfer Failed!
[L] TYPE A
[L] 200 Type set to A.
[L] MODE Z
[L] 200 MODE Z ok.
[L] PASV
[L] 227 Entering Passive Mode (217,75,242,136,4,163)
[L] Opening data connection IP: 217.75.242.136 PORT: 1187
[L] LIST -al
[L] 150 Opening ASCII mode data connection for /bin/ls.
[L] 226 Transfer complete.
[L] List Complete: 3 KB in 0,83 seconds (4,0 KB/s)
[R] TYPE A
[R] 200 Type set to A.
[R] PASV
[R] 227 Entering Passive Mode (149,139,10,48,12,247)
[R] Opening data connection IP: 149.139.10.48 PORT: 3319
[R] LIST -al
[R] List Complete: 327 bytes in 0,81 seconds (0,4 KB/s)
Transfer queue completed
1 File failed to transfer
left = source


if i remove router or set DMZ mode on my router to my internal IP
it works ok //
mhs is offline  
Old 08-13-2005, 08:49 PM   #4
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,831
Default

ah, sounds like your router is breaking fxp.
i think flashfxp v3.2 has new ability to get around such routers.

btw, flashfxp v3.2 have been released for quiet a while, which means you are using flashfxp for more than 30days, which means you are voilating flashfxp's license terms...
MxxCon is offline  
Old 08-13-2005, 09:48 PM   #5
mhs
Junior Member
 
Join Date: Aug 2005
Posts: 8
Default

umm ok .. but i just insalled it // cause i was using ultrafxp which is actually free
but i just got new router and it didnt work on ultrafxp so friend adviced me to check that soft out.. but still nothing // i searched for answer to that on almost every engine etc ... ;/ so i decided to post the problem here ;/

and i guess u wont help me either // damn

any1 else have any idea how to fix that ?:P
mhs is offline  
Old 08-13-2005, 11:19 PM   #6
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

What port are the ftp servers running on? Ususally this problem mostly occurs with port 21 ftp servers. One solution is to ask the ftp admin to run the ftp server on another port.

The solution MxxCon suggested only works 1% of the time.
bigstar is offline  
Old 08-13-2005, 11:55 PM   #7
mhs
Junior Member
 
Join Date: Aug 2005
Posts: 8
Default

tried that 2 // doesnt work // maybe somethings wrong w/ netgears routers? hmm idk
mhs is offline  
Old 08-14-2005, 01:26 AM   #8
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Which netgear router? All the netgear routers that I have personally tested will do fxp on non-port 21 ftp servers. For port 21 your out of luck unless you use SSL or enable DMZ.
bigstar is offline  
Old 08-14-2005, 10:37 AM   #9
mhs
Junior Member
 
Join Date: Aug 2005
Posts: 8
Default

router netgear rp614v3 / using spi (The SPI(Stateful Inpection) Firewall protects your LAN against Denial of Service attacks. This should only be disabled in special circumstances.)
and dmz mode off (i dont want it / bc i wanna be more secure)
mhs is offline  
Old 08-14-2005, 01:30 PM   #10
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,831
Default

try to disable stateful inspection.
and buy flashfxp
MxxCon is offline  
Old 08-14-2005, 03:07 PM   #11
mhs
Junior Member
 
Join Date: Aug 2005
Posts: 8
Default

disabled SPI and still doesnt work //
mhs is offline  
Old 09-14-2005, 09:04 PM   #12
mhs
Junior Member
 
Join Date: Aug 2005
Posts: 8
Default

hahaha i just found out how to fix it !!!!!!!!!!!!!!
that means i > u

what u gotta do is u need to enable upnp ( it worked for me )

Code:
 UPnP
Universal Plug and Play (UPnP) helps devices, such as Internet appliances and computers, access the network and connect to other devices as needed. UPnP devices can automatically discover the services from other registered UPnP devices on the network.
mhs is offline  
Closed Thread

Tags
flashfxp, fxp, mode, router, [r]

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:16 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)