Go Back   FlashFXP Forums > >

FlashFXP v5.x Public Beta Please direct all comments, suggestions, bug reports, and feedback for public beta releases to this forum.

Closed Thread
 
Thread Tools Rate Thread Display Modes
Old 09-06-2014, 04:30 PM   #1
SamKook
Junior Member
 
Join Date: May 2012
Posts: 24
Default Can't get transfer to start when loading queue from CLI

I've finally started implementing queuing a queue from CLI with the -id and -single switch in my script and I'm running in a problem using v5.0.0 b3765 RC3.

Loading a second queue works perfectly, as it's supposed to be, but I can't get the transfer to start automatically until I load a second queue which is very problematic since I won't necessarily do that.

Even without using -id and -single, I can't get it to start automatically.

Previously, I was loading a queue like so which works fine:
Code:
Flashfxp.exe -c2 -get "queue.fqf"
But for the -id and -single to work, the queue has to be specified using -queue(I tried without and it failed to load the second queue) and I can't get it to work(I tried putting the -get parameter everywhere):
Code:
Flashfxp.exe -c2 -queue="queue.fqf" -get
or
Code:
Flashfxp.exe -id="Test" -single -c2 -queue="queue.fqf" -get
both open the queue in a FlashFXP instance, but doesn't start the transfer.
If I launch the one with -id and -single again, then it will be queue in the running instance and all transfers will start.
SamKook is offline  
Old 09-07-2014, 12:05 PM   #2
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

I have confirmed that the -get command is no longer working as expected.

After reviewing recent code changes I found a change that was made to address an issue with downloading files via the CLI and this change caused -get to break when using -queue=

A fix will be included in the next update; which I hope to release later today.
bigstar is offline  
Old 09-09-2014, 03:54 PM   #3
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

There has been an unforeseen delay while waiting for some feedback from another beta tester regarding a pending issue.

In the mean time you can download an updated flashfxp.exe from the link below
Download ffxp5.0.0.3766.zip


Unzip the flashfxp.exe into your FlashFXP program folder.
bigstar is offline  
Old 09-09-2014, 04:36 PM   #4
SamKook
Junior Member
 
Join Date: May 2012
Posts: 24
Default

Thanks, I was itching to try it.

It works perfectly now(both the queue starting with -queue and adding items to a running queue).
SamKook is offline  
Closed Thread

Tags
loading, queue, single, start, transfer

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 04:16 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)