View Full Version : Can't get transfer to start when loading queue from CLI

09-06-2014, 04:30 PM
I've finally started implementing queuing a queue from CLI with the -id and -single switch in my script and I'm running in a problem using v5.0.0 b3765 RC3.

Loading a second queue works perfectly, as it's supposed to be, but I can't get the transfer to start automatically until I load a second queue which is very problematic since I won't necessarily do that.

Even without using -id and -single, I can't get it to start automatically.

Previously, I was loading a queue like so which works fine:
Flashfxp.exe -c2 -get "queue.fqf"
But for the -id and -single to work, the queue has to be specified using -queue(I tried without and it failed to load the second queue) and I can't get it to work(I tried putting the -get parameter everywhere):
Flashfxp.exe -c2 -queue="queue.fqf" -get
Flashfxp.exe -id="Test" -single -c2 -queue="queue.fqf" -get
both open the queue in a FlashFXP instance, but doesn't start the transfer.
If I launch the one with -id and -single again, then it will be queue in the running instance and all transfers will start.

09-07-2014, 12:05 PM
I have confirmed that the -get command is no longer working as expected.

After reviewing recent code changes I found a change that was made to address an issue with downloading files via the CLI and this change caused -get to break when using -queue=

A fix will be included in the next update; which I hope to release later today.

09-09-2014, 03:54 PM
There has been an unforeseen delay while waiting for some feedback from another beta tester regarding a pending issue.

In the mean time you can download an updated flashfxp.exe from the link below
Download ffxp5.0.0.3766.zip

Unzip the flashfxp.exe into your FlashFXP program folder.

09-09-2014, 04:36 PM
Thanks, I was itching to try it.

It works perfectly now(both the queue starting with -queue and adding items to a running queue).