Thread: iojTQ
View Single Post
Old 07-18-2004, 03:46 AM  
MadFred
Member
 
Join Date: May 2003
Posts: 38
Default

[11:37] iojTQ : 1-> Connected
[11:37] iojTQ : 2 -> Connected
[11:37] iojTQ : 3 -> Connected
[11:37] iojTQ : 4 -> Connected
[11:37] iojTQ : 5 -> Connected
[11:37] * Last context: tclhash.c/688 []
[11:37] * Please REPORT this BUG!
[11:37] * Check doc/BUG-REPORT on how to do so.
[11:37] * Wrote DEBUG
[11:37] * SEGMENT VIOLATION -- CRASHING!

this i what i get 99% of the times i try to get the bot running, after the 4th or 5th site it crashes.
I have tried to mix the sites in the connection list, to see if it was a specific site that caused it, but no.
If i start the bot, without having the tcl loaded , and later add the script to eggdrop.conf and do a rehash, it will work a bit better, connecting to all sites etc, but after some time it will crash with the same kind of error as above.

I have tried with windrop 1.6.13/1.6.16/1.6.17 on windows boxes, and with 1.6.16 on a linux box (RH9)
Same errors on the windrops on different boxes.
On linux it will run without crashing, but no command will work and if i dont disable sites that are down it will stop responding, even though its still running.

The error i get on linux only comes when trying a !cmd :
12:38] Tcl error [pubassed]: wrong # args: should be "lindex list index"

Any idea what to do ?
If it was possible to get the cmds running on linux it would be realy nice since it seems a lot more stable there, at least for me
(and no i dont run it together with gl)

Keep up the good work anyway, its a nice script and wanted one =)
MadFred is offline   Reply With Quote