View Single Post
Old 07-28-2004, 08:44 AM  
Junior Member
Join Date: Jul 2004
Posts: 2
Default RaidenFTPD and "Data Channel Fingerprint..."

Have tried the SmartFTP client and It does work.

So is there a way to disable this check?
(Read the blue text, answer from Raiden forum).

* FlashFXP v[3].[0], build [1014RC4], [X]registered
* OS [X] WinXP
* Running behind NAT/router [X] No
* Running firewall [X] Yes, Name [Kerio], Ver. [2.1.5]
* Running Antivirus [X] No
* Network [X] Other, LAN 10MBit

* FTP server(s) name [RaidenFTPD], version [2.4.1499], [Regged]

-----------------------------Logged from FlashFXP--------------------------------
[R] 200 PROT P accepted.
[R] 227 Entering Passive Mode (xxx,xxx,xxx,xxx,xxx,xx)
[R] Opening data connection IP: PORT: xxxx
[R] LIST -al
[R] Connected. Negotiating TLSv1 session..
[R] 150 Opening ASCII data connection for ls /---===Something===---/ using SSL/TLS.
[R] Warning: Data Channel FingerPrint Doesn't match control Connection.
[R] Failed TLSv1 negotiation, disconnected

[R] 226-free disk space under this directory : 13576 mb
[R] 226 Transfer finished successfully. Data connection closed .
[R] List Complete: 0 bytes in 0,89 seconds (0,0 KB/s)

* It's 2 RaidenFTPD servers running VLS SSL with all the settings doublechecked,
like ip, bounce, VLS slave etc. etc.

* The servers Dont have the same certificates (Based on the servers adresses)
so that is the only differences.

--------------------------- pasted from raidenFTPD forum ------------------------
(Answer from PN169)
RE : problem with VLS SSL and new FlashFXP?

get a newer one of flashfxp
I don't see this problem in newer version.

otherwise use the same server certificate on the vls servers
or ask flashfxp author to give an option to disable this check.

the_whisper is offline