View Single Post
Old 07-25-2013, 01:53 AM  
Junior Member
Join Date: Nov 2007
Posts: 1
Default How to Force ASCII Mode

I have edited the Preferences to ASCII Transfer.
I have disabled smart mode handling.

The transfer (Up and down) defaults to Binary. I cannot get a transfer to work as ASCII.

I have also tried auto and added .file* to the list of ascii extensions.

This is important as the Server is EBCDIC and I need ASCII so that the server can translate the code page.
I want the ability to upload/download files specific as Binary\ASCII depending on what I set in preference.

I have tried to manually execute the commands but I am unable to for some reason.
If I execute the RETR manually (i.e. TYPE A, PASV, RETR...) the session times out. But I don't care about this error, I just want to be able to select BINARY\ASCII manually.

See logs:
[R] 215 MVS is the operating system of this server. FTP Server is running on z/OS.
[R] 200 Representation type is Ascii NonPrint
[R] 200 Representation type is Image
[R] 501 command aborted -- FTP server not configured for SIZE
[R] 200 Representation type is Image
[R] 227 Entering Passive Mode (196,216,152,200,6,61)
[R] Opening data connection IP: PORT: 1597
[R] 125 Sending data set ABCD.EFGH.DOWNLOAD.XXX.FILE FIXrecfm 100
[R] 250 Transfer completed successfully.
Download: 'ABCD.EFGH.DOWNLOAD.XXX.FILE' 300 bytes in 0.03 second (0.3 KB/s)
Transfer queue completed
Transferred 1 File (300 bytes) in 0.29 second (0.3 KB/s)

After calming down a little I saw in the Session menu an option for File Transfer. This seems to always be auto and is NOT changed when the preference is changed.
At least I can control ASCI\Binary of the transfer at will.
This may help others as it is not obvious at first.

Last edited by Hexanon; 07-25-2013 at 02:07 AM. Reason: Found own solution
Hexanon is offline