View Single Post
Old 06-15-2012, 08:04 AM  
MONGi
Member
 
Join Date: May 2012
Posts: 71
Default Problem zur SSL/TLS-Verschlüsselung

Hallo zusammen.

Ich nutze im Moment ioFTPD und bin soweit sehr zufrieden damit.

Allerdings habe zwei Probleme, welche ich seither noch nicht lösen konnte und zähle somit auf eure Erfahrungswerte.

1. Alle notwendigen Einstellungen zum betreiben der SSL/TLS-Verschlüsselung habe ich vorgenommen:
- Require_Encrypted_Auth = !*
- Require_Encrypted_Data = !*
- Encryption_Protocol = SSL3/TLS
- Min_Cipher_Strength = 168
- Max_Cipher_Strength = 168
Und auch die Ports über den Router zum Server weitergeleitet!

Wenn ich nun eine Verbindung innerhalb meines Netzwerkes (local oder von einem anderen PC innerhalb des Netzwerkes) herstelle und habe z.B. im FTP-Client SSL deaktiviert, verbindet sich der Client trotzdem erflogreich mit dem Server....dass dürfte doch normalerweise nicht sein!?

Wird eine neue Verbindung durch den Client hergestellt, diesmal mit SSL (Auth TLS), verbindet er sich wieder erfolgreich, was an der Stelle auch völlig in Ordnung ist.

2. Allerdings würde ich gerne den Hash-Algorithmus (von Standart 256bit auf z.B. 168bit) ändern:
[L] 220 FTP Server ready.
[L] AUTH TLS
[L] 234 AUTH TLS successful.
[L] Verbunden. TLSv1 Session aushandeln..
[L] TLSv1 Aushandlung erfolgreich...
[L] TLSv1 verschlüsselte Sitzung mit Cipher DHE-RSA-AES256-SHA (256 bits)
[L] PBSZ 0
[L] 200 PBSZ 0 successful.

So, dies sind meine zwei Fragestellungen und wäre über Hilfe seeeeehr dankbar

Schöne Grüße und ein erholsames Wochenende
Matze
MONGi is offline